aboutsummaryrefslogtreecommitdiffstats
path: root/www/ump
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /www/ump
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'www/ump')
-rw-r--r--www/ump/Makefile10
-rw-r--r--www/ump/pkg-plist4
2 files changed, 9 insertions, 5 deletions
diff --git a/www/ump/Makefile b/www/ump/Makefile
index bc43e56634f8..a522abb51e79 100644
--- a/www/ump/Makefile
+++ b/www/ump/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ump
PORTVERSION= 1.10
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:timidity/} \
http://www.geocities.com/SiliconValley/Lab/2826/1-10/:ump \
@@ -51,10 +51,14 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xpf - --exclude '*/libarc/*' \
--exclude '*/utils/mblock.h' --exclude '*/utils/memb.h'
ALL_TARGET= ump
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES=ump.so
+
# USE_MOTIF= yes
# CONFIGURE_ENV= MOTIFLIB="${MOTIFLIB}"
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
.if ${HAVE_GNOME:Mesound}!=""
USE_GNOME= esound
@@ -82,7 +86,7 @@ post-configure:
@cd ${WRKSRC}; ${SETENV} CONFIG_HEADERS='' CONFIG_FILES=ump/Makefile ${SH} ./config.status
do-install:
- ${MKDIR} ${PREFIX}/lib/browser_plugins
- ${INSTALL_PROGRAM} ${WRKSRC}/ump/ump.so ${PREFIX}/lib/browser_plugins
+ ${MKDIR} ${WEBPLUGINS_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/ump/ump.so ${WEBPLUGINS_DIR}
.include <bsd.port.post.mk>
diff --git a/www/ump/pkg-plist b/www/ump/pkg-plist
index fd50f1c0a322..410e385730a1 100644
--- a/www/ump/pkg-plist
+++ b/www/ump/pkg-plist
@@ -1,2 +1,2 @@
-lib/browser_plugins/ump.so
-@dirrmtry lib/browser_plugins
+%%WEBPLUGINS_DIR%%/ump.so
+@dirrmtry %%WEBPLUGINS_DIR%%