aboutsummaryrefslogtreecommitdiffstats
path: root/www/varnish2
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2007-07-25 19:09:07 +0800
committerdes <des@FreeBSD.org>2007-07-25 19:09:07 +0800
commit80ebe7937d867da92f4fbbf9d2d8e9e0e5e2f366 (patch)
tree1c6a57250056a280015095c9c3fc432712e64b2d /www/varnish2
parent94f9e749fd744e55da81abf80077ab71082dcecc (diff)
downloadfreebsd-ports-gnome-80ebe7937d867da92f4fbbf9d2d8e9e0e5e2f366.tar.gz
freebsd-ports-gnome-80ebe7937d867da92f4fbbf9d2d8e9e0e5e2f366.tar.zst
freebsd-ports-gnome-80ebe7937d867da92f4fbbf9d2d8e9e0e5e2f366.zip
Upgrade to 1.1 + vendor patches for a number of regressions.
Diffstat (limited to 'www/varnish2')
-rw-r--r--www/varnish2/Makefile13
-rw-r--r--www/varnish2/distinfo6
-rw-r--r--www/varnish2/files/patch-svn-r174519
-rw-r--r--www/varnish2/files/patch-svn-r175026
-rw-r--r--www/varnish2/files/patch-svn-r175112
-rw-r--r--www/varnish2/files/patch-svn-r175210
-rw-r--r--www/varnish2/files/patch-svn-r175339
-rw-r--r--www/varnish2/files/patch-svn-r175435
-rw-r--r--www/varnish2/pkg-plist10
9 files changed, 163 insertions, 7 deletions
diff --git a/www/varnish2/Makefile b/www/varnish2/Makefile
index 6fe3b1320c30..50a684c0ebfc 100644
--- a/www/varnish2/Makefile
+++ b/www/varnish2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= varnish
-PORTVERSION= 1.0.4
-PORTREVISION= 2
+PORTVERSION= 1.1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,11 +16,13 @@ COMMENT= The Varnish high-performance HTTP accelerator
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --localstatedir=${PREFIX}
USE_LDCONFIG= yes
-MAN1= varnishd.1 varnishhist.1 varnishlog.1 varnishncsa.1 \
- varnishstat.1 varnishtop.1
+MAN1= varnishadm.1 varnishd.1 varnishhist.1 varnishlog.1 \
+ varnishncsa.1 varnishreplay.1 varnishstat.1 varnishtop.1
MAN7= vcl.7
+USE_REINPLACE= YES
USE_RC_SUBR= varnishd varnishlog
.include <bsd.port.pre.mk>
@@ -30,6 +31,10 @@ USE_RC_SUBR= varnishd varnishlog
BROKEN= does not compile
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
post-install:
${MKDIR} ${PREFIX}/etc/varnish
@[ -f ${PREFIX}/etc/varnish/default.vcl ] || \
diff --git a/www/varnish2/distinfo b/www/varnish2/distinfo
index 4f045547853b..b09eecca040e 100644
--- a/www/varnish2/distinfo
+++ b/www/varnish2/distinfo
@@ -1,3 +1,3 @@
-MD5 (varnish-1.0.4.tar.gz) = 2a917e485700d44b28c0d0b626ea90d8
-SHA256 (varnish-1.0.4.tar.gz) = f9f8f121cdea87133b7923b92ea08cac90ab08ffdc325166ccea22449114b2ea
-SIZE (varnish-1.0.4.tar.gz) = 533057
+MD5 (varnish-1.1.tar.gz) = 7e0d9937f9989362acfe370268bbc587
+SHA256 (varnish-1.1.tar.gz) = 345f7563c16eb2f00843ebe31c7da9612a1db59996bc87bdcba23b15111009f6
+SIZE (varnish-1.1.tar.gz) = 561608
diff --git a/www/varnish2/files/patch-svn-r1745 b/www/varnish2/files/patch-svn-r1745
new file mode 100644
index 000000000000..3f265f43d82d
--- /dev/null
+++ b/www/varnish2/files/patch-svn-r1745
@@ -0,0 +1,19 @@
+Index: bin/varnishd/cache_vrt.c
+===================================================================
+--- bin/varnishd/cache_vrt.c (revision 1744)
++++ bin/varnishd/cache_vrt.c (revision 1745)
+@@ -234,6 +234,14 @@
+ http_SetH(&sp->obj->http, HTTP_HDR_STATUS, p);
+ }
+
++int
++VRT_r_obj_status(struct sess *sp)
++{
++ CHECK_OBJ_NOTNULL(sp, SESS_MAGIC);
++ CHECK_OBJ_NOTNULL(sp->obj, OBJECT_MAGIC);
++ return (atoi(sp->obj->http.hd[HTTP_HDR_STATUS].b));
++}
++
+ void
+ VRT_l_resp_status(struct sess *sp, int num)
+ {
diff --git a/www/varnish2/files/patch-svn-r1750 b/www/varnish2/files/patch-svn-r1750
new file mode 100644
index 000000000000..f585d60de408
--- /dev/null
+++ b/www/varnish2/files/patch-svn-r1750
@@ -0,0 +1,26 @@
+Index: bin/varnishd/cache_response.c
+===================================================================
+--- bin/varnishd/cache_response.c (revision 1749)
++++ bin/varnishd/cache_response.c (revision 1750)
+@@ -76,8 +76,8 @@
+ http_PrintfHeader(sp->wrk, sp->fd, sp->http, "X-Varnish: %u", sp->xid);
+ TIM_format(sp->obj->last_modified, lm);
+ http_PrintfHeader(sp->wrk, sp->fd, sp->http, "Last-Modified: %s", lm);
+- if (sp->doclose != NULL)
+- http_SetHeader(sp->wrk, sp->fd, sp->http, "Connection: close");
++ http_PrintfHeader(sp->wrk, sp->fd, sp->http, "Connection: %s",
++ sp->doclose ? "close" : "keep-alive");
+ sp->wantbody = 0;
+ }
+
+@@ -129,8 +129,8 @@
+ http_PrintfHeader(sp->wrk, sp->fd, sp->http, "Age: %.0f",
+ sp->obj->age + sp->t_resp - sp->obj->entered);
+ http_SetHeader(sp->wrk, sp->fd, sp->http, "Via: 1.1 varnish");
+- if (sp->doclose != NULL)
+- http_SetHeader(sp->wrk, sp->fd, sp->http, "Connection: close");
++ http_PrintfHeader(sp->wrk, sp->fd, sp->http, "Connection: %s",
++ sp->doclose ? "close" : "keep-alive");
+ }
+
+ /*--------------------------------------------------------------------*/
diff --git a/www/varnish2/files/patch-svn-r1751 b/www/varnish2/files/patch-svn-r1751
new file mode 100644
index 000000000000..22eb2938b56a
--- /dev/null
+++ b/www/varnish2/files/patch-svn-r1751
@@ -0,0 +1,12 @@
+Index: bin/varnishd/cache_response.c
+===================================================================
+--- bin/varnishd/cache_response.c (revision 1750)
++++ bin/varnishd/cache_response.c (revision 1751)
+@@ -50,6 +50,7 @@
+
+ /* synthesize error page and send it */
+ SYN_ErrorPage(sp, code, reason, 0);
++ RES_BuildHttp(sp);
+ RES_WriteObj(sp);
+
+ /* GC the error page */
diff --git a/www/varnish2/files/patch-svn-r1752 b/www/varnish2/files/patch-svn-r1752
new file mode 100644
index 000000000000..0e2fd98452cb
--- /dev/null
+++ b/www/varnish2/files/patch-svn-r1752
@@ -0,0 +1,10 @@
+Index: Makefile.am
+===================================================================
+--- Makefile.am (revision 1751)
++++ Makefile.am (revision 1752)
+@@ -10,4 +10,4 @@
+ EXTRA_DIST = LICENSE autogen.sh varnishapi.pc.in
+
+ install-data-local:
+- $(install_sh) -d -m 0755 $(localstatedir)/varnish
++ $(install_sh) -d -m 0755 $(DESTDIR)$(localstatedir)/varnish
diff --git a/www/varnish2/files/patch-svn-r1753 b/www/varnish2/files/patch-svn-r1753
new file mode 100644
index 000000000000..ad906879afc3
--- /dev/null
+++ b/www/varnish2/files/patch-svn-r1753
@@ -0,0 +1,39 @@
+Index: bin/varnishhist/varnishhist.c
+===================================================================
+--- bin/varnishhist/varnishhist.c (revision 1752)
++++ bin/varnishhist/varnishhist.c (revision 1753)
+@@ -247,7 +247,7 @@
+ raw();
+ noecho();
+ nonl();
+- intrflush(stdscr, false);
++ intrflush(stdscr, FALSE);
+ curs_set(0);
+ erase();
+ for (;;) {
+Index: bin/varnishstat/varnishstat.c
+===================================================================
+--- bin/varnishstat/varnishstat.c (revision 1752)
++++ bin/varnishstat/varnishstat.c (revision 1753)
+@@ -78,7 +78,7 @@
+ raw();
+ noecho();
+ nonl();
+- intrflush(stdscr, false);
++ intrflush(stdscr, FALSE);
+ curs_set(0);
+ erase();
+
+Index: bin/varnishtop/varnishtop.c
+===================================================================
+--- bin/varnishtop/varnishtop.c (revision 1752)
++++ bin/varnishtop/varnishtop.c (revision 1753)
+@@ -201,7 +201,7 @@
+ raw();
+ noecho();
+ nonl();
+- intrflush(stdscr, false);
++ intrflush(stdscr, FALSE);
+ curs_set(0);
+ erase();
+ for (;;) {
diff --git a/www/varnish2/files/patch-svn-r1754 b/www/varnish2/files/patch-svn-r1754
new file mode 100644
index 000000000000..b2cdf2015edb
--- /dev/null
+++ b/www/varnish2/files/patch-svn-r1754
@@ -0,0 +1,35 @@
+Index: bin/varnishreplay/varnishreplay.c
+===================================================================
+--- bin/varnishreplay/varnishreplay.c (revision 1753)
++++ bin/varnishreplay/varnishreplay.c (revision 1754)
+@@ -145,7 +145,7 @@
+ if (lvl > debug)
+ return;
+ pthread_mutex_lock(&log_mutex);
+- fprintf(stderr, "%08x ", (unsigned int)pthread_self());
++ fprintf(stderr, "%p ", (void *)pthread_self());
+ va_start(ap, fmt);
+ vfprintf(stderr, fmt, ap);
+ va_end(ap);
+@@ -183,8 +183,8 @@
+ mailbox_destroy(&threads[fd]->mbox);
+ freez(threads[fd]);
+ }
+- thread_log(1, "thread %08x started\n",
+- (unsigned int)threads[fd]->thread_id);
++ thread_log(1, "thread %p started\n",
++ (void *)threads[fd]->thread_id);
+ }
+ return (threads[fd]);
+ }
+@@ -204,8 +204,8 @@
+ return;
+ mailbox_close(&threads[fd]->mbox);
+ pthread_join(threads[fd]->thread_id, NULL);
+- thread_log(1, "thread %08x stopped\n",
+- (unsigned int)threads[fd]->thread_id);
++ thread_log(1, "thread %p stopped\n",
++ (void *)threads[fd]->thread_id);
+ mailbox_destroy(&threads[fd]->mbox);
+ freez(threads[fd]);
+ }
diff --git a/www/varnish2/pkg-plist b/www/varnish2/pkg-plist
index d15ff79b3b53..1059650440b9 100644
--- a/www/varnish2/pkg-plist
+++ b/www/varnish2/pkg-plist
@@ -1,9 +1,16 @@
+bin/varnishadm
bin/varnishhist
bin/varnishlog
bin/varnishncsa
+bin/varnishreplay
bin/varnishstat
bin/varnishtop
etc/varnish/default.vcl
+include/varnish/shmlog.h
+include/varnish/shmlog_tags.h
+include/varnish/stat_field.h
+include/varnish/stats.h
+include/varnish/varnishapi.h
lib/libvarnish.so.0
lib/libvarnish.so
lib/libvarnish.la
@@ -16,5 +23,8 @@ lib/libvcl.so.0
lib/libvcl.so
lib/libvcl.la
lib/libvcl.a
+libdata/pkgconfig/varnishapi.pc
sbin/varnishd
@dirrm etc/varnish
+@exec mkdir %D/varnish
+@dirrmtry %D/varnish