aboutsummaryrefslogtreecommitdiffstats
path: root/www/varnish
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2010-05-05 02:15:51 +0800
committerdes <des@FreeBSD.org>2010-05-05 02:15:51 +0800
commiteacdba89fc32105ce74950000eddf5fd5ded253a (patch)
treec0530a289a3332933b5f9564a238f2745823897e /www/varnish
parent46e707b6e4d42377739c6224b3584112de9f3df8 (diff)
downloadfreebsd-ports-gnome-eacdba89fc32105ce74950000eddf5fd5ded253a.tar.gz
freebsd-ports-gnome-eacdba89fc32105ce74950000eddf5fd5ded253a.tar.zst
freebsd-ports-gnome-eacdba89fc32105ce74950000eddf5fd5ded253a.zip
Add upstream revision r4758: fix a bug that may cause Varnish to append
junk at the end of a chunk-encoded reply.
Diffstat (limited to 'www/varnish')
-rw-r--r--www/varnish/Makefile1
-rw-r--r--www/varnish/files/patch-r475813
2 files changed, 14 insertions, 0 deletions
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index e7e76b2410f4..672a788395c1 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -7,6 +7,7 @@
PORTNAME= varnish
PORTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF
diff --git a/www/varnish/files/patch-r4758 b/www/varnish/files/patch-r4758
new file mode 100644
index 000000000000..3603d37e2054
--- /dev/null
+++ b/www/varnish/files/patch-r4758
@@ -0,0 +1,13 @@
+Index: bin/varnishd/cache_response.c
+===================================================================
+--- bin/varnishd/cache_response.c (revision 4757)
++++ bin/varnishd/cache_response.c (revision 4758)
+@@ -325,7 +325,7 @@
+ }
+ if (ptr + len > high)
+ /* Chop tail of segment off */
+- len = 1 + high - low;
++ len = 1 + high - ptr;
+
+ ptr += len;
+