aboutsummaryrefslogtreecommitdiffstats
path: root/www/w3-4/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-12-23 00:10:54 +0800
committervs <vs@FreeBSD.org>2004-12-23 00:10:54 +0800
commit4e300200131c3858c845a5787359a140fc76d2c4 (patch)
tree85936abc494b7a21c7cd038e6de0e7e3bd933f42 /www/w3-4/Makefile
parent9aa1669a9b4a27080640c9825280aeb1d5ee8e7b (diff)
downloadfreebsd-ports-gnome-4e300200131c3858c845a5787359a140fc76d2c4.tar.gz
freebsd-ports-gnome-4e300200131c3858c845a5787359a140fc76d2c4.tar.zst
freebsd-ports-gnome-4e300200131c3858c845a5787359a140fc76d2c4.zip
- Update to 4.0.47
- Use bsd.emacs.mk - Reset maintainer: kiri is inactive PR: ports/38301 Submitted by: AMAKAWA Shuhei Approved by: maintainer silence
Diffstat (limited to 'www/w3-4/Makefile')
-rw-r--r--www/w3-4/Makefile62
1 files changed, 19 insertions, 43 deletions
diff --git a/www/w3-4/Makefile b/www/w3-4/Makefile
index 31dc37863410..0ecd40f111e0 100644
--- a/www/w3-4/Makefile
+++ b/www/w3-4/Makefile
@@ -5,59 +5,35 @@
# $FreeBSD$
#
-PORTNAME= w3
-PORTVERSION= 4.0.p46
+PORTNAME= w3-${EMACS_PORT_NAME}
+PORTVERSION= 4.0.p47
CATEGORIES+= www elisp
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= emacs-w3
-DISTNAME= w3-4.0pre.46
+DISTNAME= w3-4.0pre.47
-MAINTAINER= kiri@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= WWW browser based on emacs/mule
-BUILD_DEPENDS?= emacs-20.7:${PORTSDIR}/editors/emacs20
-RUN_DEPENDS?= emacs-20.7:${PORTSDIR}/editors/emacs20
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-emacs=yes
+INSTALL_TARGET= install dotemacs
+
+EMACS_PORT_NAME?= emacs21
+
INFO= w3-faq w3
-MAKE_ENV+= EMACSCMD=${EMACSCMD} ELISPDIR=${ELISPDIR} \
- MKDIR="${MKDIR}" CP=${CP} \
- INFODIR=${INFODIR} \
- INSTALL_DATA="${INSTALL_DATA}"
-
-PORTSDOCDIR= ${PREFIX}/share/doc/w3
-SAMPLEDIR= ${PREFIX}/share/examples/w3
-
-post-build:
-.for f in dot.emacs user-install
- @${SED} -e "s,%VERSION%,${VERSION},g" \
- -e "s,%PREFIX%,${PREFIX},g" \
- -e "s,%INFODIR%,${INFODIR},g" \
- -e "s,%ELISPDIR%,${ELISPDIR},g" \
- -e "s,%INFOFILE%,${INFOFILE},g" \
- -e "s,%ADDIR%,${ADDIR},g" \
- -e "s,%TOUCH%,${TOUCH},g" \
- -e "s,%MKDIR%,${MKDIR},g" \
- -e "s,%SAMPLEDIR%,${SAMPLEDIR},g" \
- -e "s,%DIRSECTION%,${DIRSECTION},g" \
- < ${FILESDIR}/${f}.tmpl > ${WRKDIR}/${f}
-.endfor
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PORTSDOCDIR}
- @${MKDIR} ${SAMPLEDIR}
-.for f in dot.mosaic-hotlist-default
- @${INSTALL_DATA} ${FILESDIR}/${f} ${SAMPLEDIR}
-.endfor
-.for f in dot.emacs
- @${INSTALL_DATA} ${WRKDIR}/${f} ${SAMPLEDIR}
-.endfor
- @${INSTALL_SCRIPT} ${WRKDIR}/user-install ${SAMPLEDIR}
+.include <bsd.port.pre.mk>
+
+PLIST_SUB+= EMACS_VERSION_SITE_LISPDIR=${EMACS_VERSION_SITE_LISPDIR}
+.if (${EMACS_NAME} == "xemacs")
+CONFIGURE_ARGS= --with-xemacs=${EMACS_NAME}
+.else
+CONFIGURE_ARGS= --with-emacs=${EMACS_NAME}
.endif
- @${CAT} ${PKGMESSAGE}
+CONFIGURE_ARGS+= --enable-site-install \
+ --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/w3
+CONFIGURE_ENV+= MAKEINFO='makeinfo --no-split'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>