aboutsummaryrefslogtreecommitdiffstats
path: root/www/w3m
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-02-10 14:10:32 +0800
committerkris <kris@FreeBSD.org>2000-02-10 14:10:32 +0800
commit048790ee9f8ac792bb866ce66e3e7d71423e8b65 (patch)
treeb9f5f9384f140dc97887e2f7cd7361f8b0577922 /www/w3m
parentcdb23572eb6cdc446acb63398f9bf6f79abf14d0 (diff)
downloadfreebsd-ports-gnome-048790ee9f8ac792bb866ce66e3e7d71423e8b65.tar.gz
freebsd-ports-gnome-048790ee9f8ac792bb866ce66e3e7d71423e8b65.tar.zst
freebsd-ports-gnome-048790ee9f8ac792bb866ce66e3e7d71423e8b65.zip
Make this build again. I'm not sure how this slipped through :/
Diffstat (limited to 'www/w3m')
-rw-r--r--www/w3m/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 2d48a8dcaef7..dc930a463f7b 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -48,11 +48,15 @@ SSL_CFLAGS= -I${OPENSSLINC}/openssl -I${OPENSSLINC}
SSL_LIBS= -L${OPENSSLLIB} -lssl -lcrypto
SED_CMD+= -e "s,undef USE_SSL,define USE_SSL,g"
-.endif
-EXTRA_SSL_LIBS= -lRSAglue -lrsaref -L${LOCALBASE}/lib
+.if defined(OPENSSL_RSAREF)
+EXTRA_SSL_LIBS= -lRSAglue -L${LOCALBASE}/lib -lrsaref
+.endif
MAKE_FLAGS+= DEFS="${SSL_CFLAGS} -I${LOCALBASE}/include" \
LIBS="${SSL_LIBS} ${EXTRA_SSL_LIBS}"
+.else
+MAKE_FLAGS+= DEFS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+.endif
post-configure:
@${CP} ${TARGET} ${TARGET}.in