aboutsummaryrefslogtreecommitdiffstats
path: root/www/webkit-gtk2
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit77aa43669359356c3cab5041fdfcd537e1cabf09 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /www/webkit-gtk2
parent0fdeab2269ff13fcc43d09958d528d0ce5ec786a (diff)
downloadfreebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.gz
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.zst
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Diffstat (limited to 'www/webkit-gtk2')
-rw-r--r--www/webkit-gtk2/Makefile1
-rw-r--r--www/webkit-gtk2/files/patch-Source_JavaScriptCore_wtf_gobject_GTypedefs.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index afa6bf637b8c..58c9a5264acc 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -28,6 +28,7 @@ USE_BISON= build
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_GNOME= gtk20 libxslt ltverhack
+USE_PKGCONFIG= build
USE_PERL5= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/www/webkit-gtk2/files/patch-Source_JavaScriptCore_wtf_gobject_GTypedefs.h b/www/webkit-gtk2/files/patch-Source_JavaScriptCore_wtf_gobject_GTypedefs.h
new file mode 100644
index 000000000000..d684456fb74d
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-Source_JavaScriptCore_wtf_gobject_GTypedefs.h
@@ -0,0 +1,11 @@
+--- Source/JavaScriptCore/wtf/gobject/GTypedefs.h.orig 2013-01-27 14:57:47.000000000 +0000
++++ Source/JavaScriptCore/wtf/gobject/GTypedefs.h 2013-01-27 14:57:56.000000000 +0000
+@@ -52,7 +52,7 @@
+ typedef struct _GHashTable GHashTable;
+ typedef struct _GInputStream GInputStream;
+ typedef struct _GList GList;
+-typedef struct _GMutex GMutex;
++typedef union _GMutex GMutex;
+ typedef struct _GPatternSpec GPatternSpec;
+ typedef struct _GPollableOutputStream GPollableOutputStream;
+ typedef struct _GSocketClient GSocketClient;