aboutsummaryrefslogtreecommitdiffstats
path: root/www/webkit-qt5
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-03-04 00:50:32 +0800
committerMax Brazhnikov <makc@FreeBSD.org>2014-03-04 00:50:32 +0800
commit4cd1e8830ecdea3996915303a7cdb1aaaec56ca8 (patch)
tree0facf8a13da71e87170cdfcf5902ed77d09cb72f /www/webkit-qt5
parent9110d8d5d340cf5fa7e7a59070603dd554e3959c (diff)
downloadfreebsd-ports-gnome-4cd1e8830ecdea3996915303a7cdb1aaaec56ca8.tar.gz
freebsd-ports-gnome-4cd1e8830ecdea3996915303a7cdb1aaaec56ca8.tar.zst
freebsd-ports-gnome-4cd1e8830ecdea3996915303a7cdb1aaaec56ca8.zip
KDE/FreeBSD team is happy to present Qt 5 in ports!
Alberto Villa (avilla@) has done all the hard work to create Qt 5 ports. Trivial update from 5.2.0-beta1 to 5.2.1 by me. Special thanks for Adriaan de Groot <groot@kde.org> for his assistance for Qt-5.2.0 update. Approved by: portmgr (bapt) (for Mk/bsd.port.mk)
Diffstat (limited to 'www/webkit-qt5')
-rw-r--r--www/webkit-qt5/Makefile85
-rw-r--r--www/webkit-qt5/files/patch-Source__JavaScriptCore__runtime__JSCJSValueInlines.h26
-rw-r--r--www/webkit-qt5/files/patch-Source__WebCore__page__NavigatorBase.cpp20
-rw-r--r--www/webkit-qt5/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurface.h11
-rw-r--r--www/webkit-qt5/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurfaceToken.h11
-rw-r--r--www/webkit-qt5/pkg-plist134
6 files changed, 287 insertions, 0 deletions
diff --git a/www/webkit-qt5/Makefile b/www/webkit-qt5/Makefile
new file mode 100644
index 000000000000..0c3a608f398b
--- /dev/null
+++ b/www/webkit-qt5/Makefile
@@ -0,0 +1,85 @@
+# $FreeBSD$
+
+PORTNAME= webkit
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= www
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt WebKit implementation
+
+LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libicui18n.so:${PORTSDIR}/devel/icu \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libwebp.so:${PORTSDIR}/graphics/webp
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+
+USE_GL= gl
+USE_GNOME= libxml2 libxslt
+USE_PERL5= build
+USE_PYTHON_BUILD= yes
+USE_QT5= core gui network opengl printsupport qml quick sql \
+ testlib widgets buildtools_build
+QT_DIST= ${PORTNAME}
+USE_RUBY= yes
+RUBY_NO_RUN_DEPENDS= yes
+USE_SQLITE= 3
+USE_XORG= x11 xcomposite xrender
+USES= bison:build gmake perl5 pkgconfig qmake:outsource
+# Keep make(1) from descending into obj/ subdirectories during tests.
+CONFIGURE_ENV= MAKEOBJDIR=.
+# Use flex(1) from ports.
+MAKE_ENV= PATH="${LOCALBASE}/bin:${PATH}"
+# Probably required.
+ALL_TARGET= first
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+QT_DEFINES= ACCESSIBILITY
+QT_CONFIG= accessibility accessibility-atspi-bridge
+
+OPTIONS_DEFINE= GSTREAMER
+OPTIONS_DEFAULT=GSTREAMER
+
+GSTREAMER_USE= GNOME=glib20 GSTREAMER=yes
+
+.include <bsd.port.pre.mk>
+
+# Base ld(1) segfaults on PowerPC (inherited from Qt 4):
+# http://bugs.freebsd.org/173042
+.if ${ARCH} == "powerpc"
+BUILD_DEPENDS+= ${LOCALBASE}/bin/ld:${PORTSDIR}/devel/binutils
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,python,${PYTHON_VERSION},g' \
+ -e 's,$$$${PYTHON},${PYTHON_VERSION},g' \
+ ${WRKSRC}/Source/WebCore/DerivedSources.make \
+ ${WRKSRC}/Source/WebCore/DerivedSources.pri \
+ ${WRKSRC}/Source/WebKit2/DerivedSources.make \
+ ${WRKSRC}/Source/WebKit2/DerivedSources.pri \
+ ${WRKSRC}/Source/JavaScriptCore/DerivedSources.make \
+ ${WRKSRC}/Source/JavaScriptCore/DerivedSources.pri \
+ ${WRKSRC}/Tools/qmake/mkspecs/features/configure.prf
+
+pre-configure:
+# Write a clean installation procedure to avoid the installation of
+# the file during the build stage.
+ @${REINPLACE_CMD} -e 's|\[QT_INSTALL_PLUGINS]|{ROOT_BUILD_DIR}/plugins|' \
+ ${WRKSRC}/Source/WebKit/qt/examples/platformplugin/platformplugin.pro
+ @${ECHO_CMD} "target.path = ${PREFIX}/${QT_PLUGINDIR_REL}/webkit" \
+ >> ${WRKSRC}/Source/WebKit/qt/examples/platformplugin/platformplugin.pro
+ @${ECHO_CMD} "INSTALLS += target" \
+ >> ${WRKSRC}/Source/WebKit/qt/examples/platformplugin/platformplugin.pro
+ @${REINPLACE_CMD} -Ee 's|linux-?\*|unix|g' \
+ ${WRKSRC}/Source/JavaScriptCore/DerivedSources.pri \
+ ${WRKSRC}/Source/JavaScriptCore/JavaScriptCore.pri \
+ ${WRKSRC}/Source/JavaScriptCore/Target.pri \
+ ${WRKSRC}/Source/WebCore/WebCore.pri \
+ ${WRKSRC}/Tools/qmake/mkspecs/features/features.prf
+.if ! ${PORT_OPTIONS:MGSTREAMER}
+ @${REINPLACE_CMD} -e 's|packagesExist.*gstreamer.*|false {|' \
+ ${WRKSRC}/Tools/qmake/mkspecs/features/features.prf
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/webkit-qt5/files/patch-Source__JavaScriptCore__runtime__JSCJSValueInlines.h b/www/webkit-qt5/files/patch-Source__JavaScriptCore__runtime__JSCJSValueInlines.h
new file mode 100644
index 000000000000..44b68255a214
--- /dev/null
+++ b/www/webkit-qt5/files/patch-Source__JavaScriptCore__runtime__JSCJSValueInlines.h
@@ -0,0 +1,26 @@
+--- ./Source/JavaScriptCore/runtime/JSCJSValueInlines.h.orig 2013-10-22 01:49:45.000000000 -0700
++++ ./Source/JavaScriptCore/runtime/JSCJSValueInlines.h 2013-11-08 00:51:34.238960064 -0800
+@@ -198,7 +198,11 @@
+ u.asBits.tag = CellTag;
+ else
+ u.asBits.tag = EmptyValueTag;
++#if defined(__sparc64__)
++ u.asBits.payload = reinterpret_cast<int64_t>(ptr);
++#else
+ u.asBits.payload = reinterpret_cast<int32_t>(ptr);
++#endif
+ }
+
+ inline JSValue::JSValue(const JSCell* ptr)
+@@ -207,7 +211,11 @@
+ u.asBits.tag = CellTag;
+ else
+ u.asBits.tag = EmptyValueTag;
++#if defined(__sparc64__)
++ u.asBits.payload = reinterpret_cast<int64_t>(const_cast<JSCell*>(ptr));
++#else
+ u.asBits.payload = reinterpret_cast<int32_t>(const_cast<JSCell*>(ptr));
++#endif
+ }
+
+ inline JSValue::operator bool() const
diff --git a/www/webkit-qt5/files/patch-Source__WebCore__page__NavigatorBase.cpp b/www/webkit-qt5/files/patch-Source__WebCore__page__NavigatorBase.cpp
new file mode 100644
index 000000000000..a784ca85189d
--- /dev/null
+++ b/www/webkit-qt5/files/patch-Source__WebCore__page__NavigatorBase.cpp
@@ -0,0 +1,20 @@
+--- ./Source/WebCore/page/NavigatorBase.cpp.orig 2012-12-18 20:04:33.000000000 +0100
++++ ./Source/WebCore/page/NavigatorBase.cpp 2013-01-07 04:01:53.177339022 +0100
+@@ -30,7 +30,7 @@
+ #include "NetworkStateNotifier.h"
+ #include <wtf/text/WTFString.h>
+
+-#if OS(LINUX)
++#if OS(LINUX) || OS(FREEBSD)
+ #include "sys/utsname.h"
+ #include <wtf/StdLibExtras.h>
+ #endif
+@@ -86,7 +86,7 @@
+
+ String NavigatorBase::platform() const
+ {
+-#if OS(LINUX)
++#if OS(LINUX) || OS(FREEBSD)
+ if (!String(WEBCORE_NAVIGATOR_PLATFORM).isEmpty())
+ return WEBCORE_NAVIGATOR_PLATFORM;
+ struct utsname osname;
diff --git a/www/webkit-qt5/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurface.h b/www/webkit-qt5/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurface.h
new file mode 100644
index 000000000000..184b5e202b0e
--- /dev/null
+++ b/www/webkit-qt5/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurface.h
@@ -0,0 +1,11 @@
+--- ./Source/WebCore/platform/graphics/surfaces/GraphicsSurface.h.orig 2012-12-18 20:04:31.000000000 +0100
++++ ./Source/WebCore/platform/graphics/surfaces/GraphicsSurface.h 2012-12-28 13:00:05.846909692 +0100
+@@ -36,7 +36,7 @@
+ typedef IOSurfaceRef PlatformGraphicsSurface;
+ #endif
+
+-#if OS(LINUX)
++#if OS(LINUX) || OS(FREEBSD)
+ typedef uint32_t PlatformGraphicsSurface;
+ #endif
+
diff --git a/www/webkit-qt5/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurfaceToken.h b/www/webkit-qt5/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurfaceToken.h
new file mode 100644
index 000000000000..bca58b6be1e2
--- /dev/null
+++ b/www/webkit-qt5/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurfaceToken.h
@@ -0,0 +1,11 @@
+--- ./Source/WebCore/platform/graphics/surfaces/GraphicsSurfaceToken.h.orig 2012-12-18 20:04:31.000000000 +0100
++++ ./Source/WebCore/platform/graphics/surfaces/GraphicsSurfaceToken.h 2012-12-28 13:02:03.566975217 +0100
+@@ -35,7 +35,7 @@
+
+ #if OS(DARWIN)
+ typedef mach_port_t BufferHandle;
+-#elif OS(LINUX)
++#elif OS(LINUX) || OS(FREEBSD)
+ typedef uint32_t BufferHandle;
+ #elif OS(WINDOWS)
+ typedef HANDLE BufferHandle;
diff --git a/www/webkit-qt5/pkg-plist b/www/webkit-qt5/pkg-plist
new file mode 100644
index 000000000000..7135111e68fb
--- /dev/null
+++ b/www/webkit-qt5/pkg-plist
@@ -0,0 +1,134 @@
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/bytearraytestdata.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qhttpheader_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquicknetworkreply_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquicknetworkrequest_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickurlschemedelegate_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickwebpage_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickwebpage_p_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickwebview_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickwebview_p_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qrawwebview_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qrawwebview_p_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qtwebsecurityorigin_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebdatabase_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebdownloaditem_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebdownloaditem_p_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebelement_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebhistory_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebiconimageprovider_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebkittest_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebloadrequest_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebnavigationhistory_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebnavigationhistory_p_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebnavigationrequest_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebpermissionrequest_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebplugindatabase_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebpreferences_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebpreferences_p_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebscriptworld.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebscriptworld_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebsecurityorigin_p.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/testwindow.h
+%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/util.h
+%%QT_INCDIR%%/QtWebKit/QWebDatabase
+%%QT_INCDIR%%/QtWebKit/QWebElement
+%%QT_INCDIR%%/QtWebKit/QWebElementCollection
+%%QT_INCDIR%%/QtWebKit/QWebFullScreenVideoHandler
+%%QT_INCDIR%%/QtWebKit/QWebHapticFeedbackPlayer
+%%QT_INCDIR%%/QtWebKit/QWebHistory
+%%QT_INCDIR%%/QtWebKit/QWebHistoryInterface
+%%QT_INCDIR%%/QtWebKit/QWebHistoryItem
+%%QT_INCDIR%%/QtWebKit/QWebKitPlatformPlugin
+%%QT_INCDIR%%/QtWebKit/QWebNotificationData
+%%QT_INCDIR%%/QtWebKit/QWebNotificationPresenter
+%%QT_INCDIR%%/QtWebKit/QWebPluginFactory
+%%QT_INCDIR%%/QtWebKit/QWebSecurityOrigin
+%%QT_INCDIR%%/QtWebKit/QWebSelectData
+%%QT_INCDIR%%/QtWebKit/QWebSelectMethod
+%%QT_INCDIR%%/QtWebKit/QWebSettings
+%%QT_INCDIR%%/QtWebKit/QWebSpellChecker
+%%QT_INCDIR%%/QtWebKit/QWebTouchModifier
+%%QT_INCDIR%%/QtWebKit/QtWebKit
+%%QT_INCDIR%%/QtWebKit/QtWebKitDepends
+%%QT_INCDIR%%/QtWebKit/QtWebKitVersion
+%%QT_INCDIR%%/QtWebKit/qtwebkitversion.h
+%%QT_INCDIR%%/QtWebKit/qwebdatabase.h
+%%QT_INCDIR%%/QtWebKit/qwebelement.h
+%%QT_INCDIR%%/QtWebKit/qwebhistory.h
+%%QT_INCDIR%%/QtWebKit/qwebhistoryinterface.h
+%%QT_INCDIR%%/QtWebKit/qwebkitglobal.h
+%%QT_INCDIR%%/QtWebKit/qwebkitplatformplugin.h
+%%QT_INCDIR%%/QtWebKit/qwebpluginfactory.h
+%%QT_INCDIR%%/QtWebKit/qwebsecurityorigin.h
+%%QT_INCDIR%%/QtWebKit/qwebsettings.h
+%%QT_INCDIR%%/QtWebKitWidgets/%%FULLVER%%/QtWebKitWidgets/private/qwebframe_p.h
+%%QT_INCDIR%%/QtWebKitWidgets/%%FULLVER%%/QtWebKitWidgets/private/qwebinspector_p.h
+%%QT_INCDIR%%/QtWebKitWidgets/%%FULLVER%%/QtWebKitWidgets/private/qwebpage_p.h
+%%QT_INCDIR%%/QtWebKitWidgets/%%FULLVER%%/QtWebKitWidgets/private/qwebviewaccessible_p.h
+%%QT_INCDIR%%/QtWebKitWidgets/QGraphicsWebView
+%%QT_INCDIR%%/QtWebKitWidgets/QWebFrame
+%%QT_INCDIR%%/QtWebKitWidgets/QWebHitTestResult
+%%QT_INCDIR%%/QtWebKitWidgets/QWebInspector
+%%QT_INCDIR%%/QtWebKitWidgets/QWebPage
+%%QT_INCDIR%%/QtWebKitWidgets/QWebView
+%%QT_INCDIR%%/QtWebKitWidgets/QtWebKitWidgets
+%%QT_INCDIR%%/QtWebKitWidgets/QtWebKitWidgetsDepends
+%%QT_INCDIR%%/QtWebKitWidgets/QtWebKitWidgetsVersion
+%%QT_INCDIR%%/QtWebKitWidgets/qgraphicswebview.h
+%%QT_INCDIR%%/QtWebKitWidgets/qtwebkitwidgetsversion.h
+%%QT_INCDIR%%/QtWebKitWidgets/qwebframe.h
+%%QT_INCDIR%%/QtWebKitWidgets/qwebinspector.h
+%%QT_INCDIR%%/QtWebKitWidgets/qwebpage.h
+%%QT_INCDIR%%/QtWebKitWidgets/qwebview.h
+%%QT_LIBDIR%%/cmake/Qt5WebKit/Qt5WebKitConfig.cmake
+%%QT_LIBDIR%%/cmake/Qt5WebKit/Qt5WebKitConfigVersion.cmake
+%%QT_LIBDIR%%/cmake/Qt5WebKitWidgets/Qt5WebKitWidgetsConfig.cmake
+%%QT_LIBDIR%%/cmake/Qt5WebKitWidgets/Qt5WebKitWidgetsConfigVersion.cmake
+%%QT_LIBDIR%%/libQt5WebKit.la
+%%QT_LIBDIR%%/libQt5WebKit.prl
+%%QT_LIBDIR%%/libQt5WebKit.so
+%%QT_LIBDIR%%/libQt5WebKit.so.5
+%%QT_LIBDIR%%/libQt5WebKit.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5WebKit.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5WebKit.so.%%FULLVER%%.debug
+%%QT_LIBDIR%%/libQt5WebKitWidgets.la
+%%QT_LIBDIR%%/libQt5WebKitWidgets.prl
+%%QT_LIBDIR%%/libQt5WebKitWidgets.so
+%%QT_LIBDIR%%/libQt5WebKitWidgets.so.5
+%%QT_LIBDIR%%/libQt5WebKitWidgets.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5WebKitWidgets.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5WebKitWidgets.so.%%FULLVER%%.debug
+%%QT_MKSPECDIR%%/modules/qt_lib_webkit.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_webkit_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_webkitwidgets.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_webkitwidgets_private.pri
+%%QT_PLUGINDIR%%/webkit/libplatformplugin.so
+%%QT_QMLDIR%%/QtWebKit/experimental/libqmlwebkitexperimentalplugin.so
+%%QT_QMLDIR%%/QtWebKit/experimental/qmldir
+%%QT_QMLDIR%%/QtWebKit/libqmlwebkitplugin.so
+%%QT_QMLDIR%%/QtWebKit/qmldir
+libdata/pkgconfig/Qt5WebKit.pc
+libdata/pkgconfig/Qt5WebKitWidgets.pc
+%%QT_LIBEXECDIR%%/QtWebPluginProcess
+%%QT_LIBEXECDIR%%/QtWebProcess
+@dirrmtry %%QT_LIBEXECDIR%%
+@dirrm %%QT_QMLDIR%%/QtWebKit/experimental
+@dirrm %%QT_QMLDIR%%/QtWebKit
+@dirrmtry %%QT_QMLDIR%%
+@dirrm %%QT_PLUGINDIR%%/webkit
+@dirrmtry %%QT_PLUGINDIR%%
+@dirrmtry %%QT_MKSPECDIR%%/modules
+@dirrmtry %%QT_MKSPECDIR%%
+@dirrmtry %%QT_ARCHDIR%%
+@dirrm %%QT_LIBDIR%%/cmake/Qt5WebKitWidgets
+@dirrm %%QT_LIBDIR%%/cmake/Qt5WebKit
+@dirrmtry %%QT_LIBDIR%%/cmake
+@dirrm %%QT_INCDIR%%/QtWebKitWidgets/%%FULLVER%%/QtWebKitWidgets/private
+@dirrm %%QT_INCDIR%%/QtWebKitWidgets/%%FULLVER%%/QtWebKitWidgets
+@dirrm %%QT_INCDIR%%/QtWebKitWidgets/%%FULLVER%%
+@dirrm %%QT_INCDIR%%/QtWebKitWidgets
+@dirrm %%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private
+@dirrm %%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit
+@dirrm %%QT_INCDIR%%/QtWebKit/%%FULLVER%%
+@dirrm %%QT_INCDIR%%/QtWebKit
+@dirrmtry %%QT_INCDIR%%