aboutsummaryrefslogtreecommitdiffstats
path: root/www/webreport
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-27 22:21:37 +0800
committermiwi <miwi@FreeBSD.org>2014-06-27 22:21:37 +0800
commit4060703643bc1aaed7ff9da2a3f0d144ca37a64b (patch)
treeb6ec49e0bdc826ba785121736cb0d37d8309ed0a /www/webreport
parentee75600183b13ca7d0141ea4012a5132aebbb7b4 (diff)
downloadfreebsd-ports-gnome-4060703643bc1aaed7ff9da2a3f0d144ca37a64b.tar.gz
freebsd-ports-gnome-4060703643bc1aaed7ff9da2a3f0d144ca37a64b.tar.zst
freebsd-ports-gnome-4060703643bc1aaed7ff9da2a3f0d144ca37a64b.zip
- Stage support
- Fix compile errors on 10X and above PR: 190788
Diffstat (limited to 'www/webreport')
-rw-r--r--www/webreport/Makefile23
-rw-r--r--www/webreport/files/pkg-message.in (renamed from www/webreport/pkg-message)0
2 files changed, 14 insertions, 9 deletions
diff --git a/www/webreport/Makefile b/www/webreport/Makefile
index 98a4de795564..3ced443778c6 100644
--- a/www/webreport/Makefile
+++ b/www/webreport/Makefile
@@ -3,29 +3,34 @@
PORTNAME= webreport
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.inter7.com/webreport/
MAINTAINER= ismail@EnderUNIX.org
COMMENT= WebReport is a web log statistics program for web hosting sites
+SUB_FILES= pkg-message
PORTDOCS= INSTALL
PLIST_FILES= bin/webreport etc/webreport.conf-dist
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
+# silence clang errors on 10.0+
+CFLAGS+= -Wno-return-type
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,ulong,unsigned long,;s,/etc/,${PREFIX}/etc/,' ${WRKSRC}/webreport.h
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/webreport ${PREFIX}/bin
- @${INSTALL_DATA} ${WRKSRC}/webreport.conf ${PREFIX}/etc/webreport.conf-dist
+ @${INSTALL_PROGRAM} ${WRKSRC}/webreport ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/webreport.conf ${STAGEDIR}${PREFIX}/etc/webreport.conf-dist
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_MAN} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
-post-install:
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
-
.include <bsd.port.mk>
diff --git a/www/webreport/pkg-message b/www/webreport/files/pkg-message.in
index b7ddf601fa79..b7ddf601fa79 100644
--- a/www/webreport/pkg-message
+++ b/www/webreport/files/pkg-message.in