aboutsummaryrefslogtreecommitdiffstats
path: root/www/wml
diff options
context:
space:
mode:
authorrodrigo <rodrigo@FreeBSD.org>2014-06-04 18:11:47 +0800
committerrodrigo <rodrigo@FreeBSD.org>2014-06-04 18:11:47 +0800
commit3f7e4506f869ad5926af6e20c78aff8c893970e4 (patch)
treefb7355f6a3f51e874ca56a9f8be9e8baa0427369 /www/wml
parent21baf517cec59c5cec6454cc83bd0422eba91a0c (diff)
downloadfreebsd-ports-gnome-3f7e4506f869ad5926af6e20c78aff8c893970e4.tar.gz
freebsd-ports-gnome-3f7e4506f869ad5926af6e20c78aff8c893970e4.tar.zst
freebsd-ports-gnome-3f7e4506f869ad5926af6e20c78aff8c893970e4.zip
support staging
Submitted by: rodrigo@ (maintainer) Reviewed by: bapt (mentor)
Diffstat (limited to 'www/wml')
-rw-r--r--www/wml/Makefile33
-rw-r--r--www/wml/files/patch-Makefile.in16
-rw-r--r--www/wml/files/patch-wml_include-Makefile.in16
-rw-r--r--www/wml/files/patch-wml_misc-Makefile.in16
-rw-r--r--www/wml/pkg-plist110
5 files changed, 146 insertions, 45 deletions
diff --git a/www/wml/Makefile b/www/wml/Makefile
index 53faff86f899..26b82acdde63 100644
--- a/www/wml/Makefile
+++ b/www/wml/Makefile
@@ -12,7 +12,7 @@ MASTER_SITE_SUBDIR=thewml
MAINTAINER= rodrigo@FreeBSD.org
COMMENT= Website META Language, webdesign toolkit for HTML generation
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
RUN_DEPENDS= \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-Bit-Vector>=5.2:${PORTSDIR}/math/p5-Bit-Vector \
@@ -30,37 +30,6 @@ USE_PERL5= run build patch
CONFIGURE_ARGS= --with-perl=${PERL5} --with-catdir=man \
--prefix=${PREFIX}
-MAN1= wmd.1 wmd_missing.1 wmk.1 wml.1 wmb.1 wmu.1 \
- wml_aux_freetable.1 wml_aux_htmlclean.1 wml_aux_htmlinfo.1 wml_aux_iselect.1 \
- wml_aux_map2html.1 wml_aux_weblint.1 wml_p1_ipp.1 \
- wml_p2_mp4h.1 wml_p3_eperl.1 wml_p5_divert.1 wml_p6_asubst.1 \
- wml_p7_htmlfix.1 wml_p8_htmlstrip.1 wml_p9_slice.1 \
- wml_aux_txt2html.1 wml_aux_tidy.1 wml_p4_gm4.1 \
- wml_aux_linklint.1
-
-MAN3= wml::all.3 wml::des::all.3 wml::des::gfont.3 \
- wml::des::lowsrc.3 wml::des::imgdot.3 wml::des::imgbg.3 \
- wml::des::navbar.3 wml::des::preload.3 wml::des::rollover.3 \
- wml::des::space.3 wml::des::typography.3 wml::fmt::all.3 \
- wml::fmt::isolatin.3 wml::fmt::pod.3 wml::fmt::sdf.3 \
- wml::fmt::text.3 wml::fmt::url.3 wml::fmt::verbatim.3 \
- wml::fmt::xtable.3 wml::imp::all.3 wml::imp::csmap.3 \
- wml::imp::fsview.3 wml::imp::generic.3 wml::std::all.3 \
- wml::std::box.3 wml::std::case.3 wml::std::grid.3 \
- wml::std::label.3 wml::std::href.3 wml::std::lang.3 \
- wml::std::logo.3 wml::std::info.3 wml::std::page.3 \
- wml::std::tags.3 wml::std::toc.3 wml::sup::all.3 \
- wml::sup::hextriple.3 wml::mod::MakeMaker.3 wml::mod::all.3 \
- wml::mod::version.3 wml::sup::path.3 wml::sys::all.3 \
- wml::sys::bootp3.3 wml::sys::bootp4.3 wml::sys::compat1.3
-
-MAN7= wml_barebone.7 \
- wml_std_css1.7 wml_std_css2.7 wml_std_csspos.7 \
- wml_std_html20.7 wml_std_html32.7 wml_std_html40.7 \
- wml_std_html401.7 wml_std_wai10.7 wml_std_xhtml10.7 \
- wml_intro.7 wml_macros.7 wml_tutorial.7 wml_faq.7 wml_tags.7
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
diff --git a/www/wml/files/patch-Makefile.in b/www/wml/files/patch-Makefile.in
new file mode 100644
index 000000000000..e37699a45b70
--- /dev/null
+++ b/www/wml/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig 2014-03-28 22:46:48.828302019 +0000
++++ Makefile.in 2014-03-28 22:50:35.004285184 +0000
+@@ -25,10 +25,10 @@
+
+ prefix = @prefix@
+ exec_prefix = $(prefix)
+-bindir = $(prefix)/bin
++bindir = $(DESTDIR)$(prefix)/bin
+ libsubdir = @libsubdir@
+-libdir = $(prefix)/lib$(libsubdir)
+-mandir = $(prefix)/man
++libdir = $(DESTDIR)$(prefix)/lib$(libsubdir)
++mandir = $(DESTDIR)$(prefix)/man
+ catdir = @catdir@
+ tmpdir = @tmpdir@
+
diff --git a/www/wml/files/patch-wml_include-Makefile.in b/www/wml/files/patch-wml_include-Makefile.in
new file mode 100644
index 000000000000..9ff761ae91ed
--- /dev/null
+++ b/www/wml/files/patch-wml_include-Makefile.in
@@ -0,0 +1,16 @@
+--- wml_include/Makefile.in 2014-03-29 08:59:23.882767625 +0000
++++ wml_include/Makefile.in 2014-03-29 08:58:02.630774437 +0000
+@@ -21,10 +21,10 @@
+
+ prefix = @prefix@
+ exec_prefix = $(prefix)
+-bindir = $(prefix)/bin
++bindir = $(DESTDIR)$(prefix)/bin
+ libsubdir = @libsubdir@
+-libdir = $(prefix)/lib$(libsubdir)
+-mandir = $(prefix)/man
++libdir = $(DESTDIR)$(prefix)/lib$(libsubdir)
++mandir = $(DESTDIR)$(prefix)/man
+
+ INSTALLPRIVLIB = @INSTALLPRIVLIB@
+ INSTALLARCHLIB = @INSTALLARCHLIB@
diff --git a/www/wml/files/patch-wml_misc-Makefile.in b/www/wml/files/patch-wml_misc-Makefile.in
new file mode 100644
index 000000000000..b2f33093643c
--- /dev/null
+++ b/www/wml/files/patch-wml_misc-Makefile.in
@@ -0,0 +1,16 @@
+--- wml_misc/Makefile.in.orig 2014-03-29 09:11:38.024718160 +0000
++++ wml_misc/Makefile.in 2014-03-29 09:08:56.459729579 +0000
+@@ -21,10 +21,10 @@
+
+ prefix = @prefix@
+ exec_prefix = $(prefix)
+-bindir = $(prefix)/bin
++bindir = $(DESTDIR)$(prefix)/bin
+ libsubdir = @libsubdir@
+-libdir = $(prefix)/lib$(libsubdir)
+-mandir = $(prefix)/man
++libdir = $(DESTDIR)$(prefix)/lib$(libsubdir)
++mandir = $(DESTDIR)$(prefix)/man
+
+ # ------------------------------------------------
+ # TARGETS
diff --git a/www/wml/pkg-plist b/www/wml/pkg-plist
index 2e0b77feda67..b6db59402724 100644
--- a/www/wml/pkg-plist
+++ b/www/wml/pkg-plist
@@ -1,7 +1,7 @@
+bin/wmb
+bin/wmd
bin/wmk
bin/wml
-bin/wmd
-bin/wmb
bin/wmu
lib/wml/data/logos/logo-apache.gif
lib/wml/data/logos/logo-apache.info
@@ -39,9 +39,18 @@ lib/wml/data/logos/logo-wml.png
lib/wml/data/logos/logo-xemacs.gif
lib/wml/data/logos/logo-xemacs.info
lib/wml/data/logos/logo-xemacs.png
-lib/wml/data/wmd.txt
lib/wml/data/txt2html.dict
lib/wml/data/weblintrc
+lib/wml/data/wmd.txt
+lib/wml/exec/wml_aux_freetable
+lib/wml/exec/wml_aux_htmlclean
+lib/wml/exec/wml_aux_htmlinfo
+lib/wml/exec/wml_aux_iselect
+lib/wml/exec/wml_aux_linklint
+lib/wml/exec/wml_aux_map2html
+lib/wml/exec/wml_aux_tidy
+lib/wml/exec/wml_aux_txt2html
+lib/wml/exec/wml_aux_weblint
lib/wml/exec/wml_p1_ipp
lib/wml/exec/wml_p2_mp4h
lib/wml/exec/wml_p3_eperl
@@ -51,15 +60,7 @@ lib/wml/exec/wml_p6_asubst
lib/wml/exec/wml_p7_htmlfix
lib/wml/exec/wml_p8_htmlstrip
lib/wml/exec/wml_p9_slice
-lib/wml/exec/wml_aux_htmlclean
-lib/wml/exec/wml_aux_iselect
-lib/wml/exec/wml_aux_map2html
-lib/wml/exec/wml_aux_txt2html
-lib/wml/exec/wml_aux_tidy
-lib/wml/exec/wml_aux_htmlinfo
-lib/wml/exec/wml_aux_linklint
-lib/wml/exec/wml_aux_weblint
-lib/wml/exec/wml_aux_freetable
+lib/wml/include/all.wml
lib/wml/include/des/all.wml
lib/wml/include/des/gfont.wml
lib/wml/include/des/imgbg.wml
@@ -78,7 +79,6 @@ lib/wml/include/fmt/text.wml
lib/wml/include/fmt/url.wml
lib/wml/include/fmt/verbatim.wml
lib/wml/include/fmt/xtable.wml
-lib/wml/include/all.wml
lib/wml/include/imp/all.wml
lib/wml/include/imp/csmap.wml
lib/wml/include/imp/fsview.wml
@@ -105,6 +105,90 @@ lib/wml/include/sys/all.wml
lib/wml/include/sys/bootp3.wml
lib/wml/include/sys/bootp4.wml
lib/wml/include/sys/compat1.wml
+man/man1/wmb.1.gz
+man/man1/wmd.1.gz
+man/man1/wmd_missing.1.gz
+man/man1/wmk.1.gz
+man/man1/wml.1.gz
+man/man1/wml_aux_freetable.1.gz
+man/man1/wml_aux_htmlclean.1.gz
+man/man1/wml_aux_htmlinfo.1.gz
+man/man1/wml_aux_iselect.1.gz
+man/man1/wml_aux_linklint.1.gz
+man/man1/wml_aux_map2html.1.gz
+man/man1/wml_aux_tidy.1.gz
+man/man1/wml_aux_txt2html.1.gz
+man/man1/wml_aux_weblint.1.gz
+man/man1/wml_p1_ipp.1.gz
+man/man1/wml_p2_mp4h.1.gz
+man/man1/wml_p3_eperl.1.gz
+man/man1/wml_p4_gm4.1.gz
+man/man1/wml_p5_divert.1.gz
+man/man1/wml_p6_asubst.1.gz
+man/man1/wml_p7_htmlfix.1.gz
+man/man1/wml_p8_htmlstrip.1.gz
+man/man1/wml_p9_slice.1.gz
+man/man1/wmu.1.gz
+man/man3/wml::all.3.gz
+man/man3/wml::des::all.3.gz
+man/man3/wml::des::gfont.3.gz
+man/man3/wml::des::imgbg.3.gz
+man/man3/wml::des::imgdot.3.gz
+man/man3/wml::des::lowsrc.3.gz
+man/man3/wml::des::navbar.3.gz
+man/man3/wml::des::preload.3.gz
+man/man3/wml::des::rollover.3.gz
+man/man3/wml::des::space.3.gz
+man/man3/wml::des::typography.3.gz
+man/man3/wml::fmt::all.3.gz
+man/man3/wml::fmt::isolatin.3.gz
+man/man3/wml::fmt::pod.3.gz
+man/man3/wml::fmt::sdf.3.gz
+man/man3/wml::fmt::text.3.gz
+man/man3/wml::fmt::url.3.gz
+man/man3/wml::fmt::verbatim.3.gz
+man/man3/wml::fmt::xtable.3.gz
+man/man3/wml::imp::all.3.gz
+man/man3/wml::imp::csmap.3.gz
+man/man3/wml::imp::fsview.3.gz
+man/man3/wml::imp::generic.3.gz
+man/man3/wml::mod::MakeMaker.3.gz
+man/man3/wml::mod::all.3.gz
+man/man3/wml::mod::version.3.gz
+man/man3/wml::std::all.3.gz
+man/man3/wml::std::box.3.gz
+man/man3/wml::std::case.3.gz
+man/man3/wml::std::grid.3.gz
+man/man3/wml::std::href.3.gz
+man/man3/wml::std::info.3.gz
+man/man3/wml::std::label.3.gz
+man/man3/wml::std::lang.3.gz
+man/man3/wml::std::logo.3.gz
+man/man3/wml::std::page.3.gz
+man/man3/wml::std::tags.3.gz
+man/man3/wml::std::toc.3.gz
+man/man3/wml::sup::all.3.gz
+man/man3/wml::sup::hextriple.3.gz
+man/man3/wml::sup::path.3.gz
+man/man3/wml::sys::all.3.gz
+man/man3/wml::sys::bootp3.3.gz
+man/man3/wml::sys::bootp4.3.gz
+man/man3/wml::sys::compat1.3.gz
+man/man7/wml_barebone.7.gz
+man/man7/wml_faq.7.gz
+man/man7/wml_intro.7.gz
+man/man7/wml_macros.7.gz
+man/man7/wml_std_css1.7.gz
+man/man7/wml_std_css2.7.gz
+man/man7/wml_std_csspos.7.gz
+man/man7/wml_std_html20.7.gz
+man/man7/wml_std_html32.7.gz
+man/man7/wml_std_html40.7.gz
+man/man7/wml_std_html401.7.gz
+man/man7/wml_std_wai10.7.gz
+man/man7/wml_std_xhtml10.7.gz
+man/man7/wml_tags.7.gz
+man/man7/wml_tutorial.7.gz
@dirrm lib/wml/perl
@dirrm lib/wml/include/sys
@dirrm lib/wml/include/sup