aboutsummaryrefslogtreecommitdiffstats
path: root/www/wsmake
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-09-15 21:02:02 +0800
committerSimon Barner <barner@FreeBSD.org>2005-09-15 21:02:02 +0800
commit9914ec42f7586b0cd0b5bf83e5fc16b2df37f5cd (patch)
treeb3ca1059f4fbaf4d126c0c1124ff4c62e5e3ff38 /www/wsmake
parent90e8af9d9ce502808f644438aa74986ebdaade96 (diff)
downloadfreebsd-ports-gnome-9914ec42f7586b0cd0b5bf83e5fc16b2df37f5cd.tar.gz
freebsd-ports-gnome-9914ec42f7586b0cd0b5bf83e5fc16b2df37f5cd.tar.zst
freebsd-ports-gnome-9914ec42f7586b0cd0b5bf83e5fc16b2df37f5cd.zip
- Unbreak on !i386
Tested by: submitter (amd64), barner (sparc64, ia64) Submitted by: Johan van Selst <johans@stack.nl> PR: ports/86150
Diffstat (limited to 'www/wsmake')
-rw-r--r--www/wsmake/Makefile8
-rw-r--r--www/wsmake/files/patch-libwsmake_wsUtil.cpp17
-rw-r--r--www/wsmake/files/patch-libwsmake_wsUtil.h11
3 files changed, 30 insertions, 6 deletions
diff --git a/www/wsmake/Makefile b/www/wsmake/Makefile
index 3299be1cfc2e..4b6f56ba5a84 100644
--- a/www/wsmake/Makefile
+++ b/www/wsmake/Makefile
@@ -8,8 +8,8 @@
PORTNAME= wsmake
PORTVERSION= 0.6.4
CATEGORIES= www
-MASTER_SITES= http://www.wsmake.org/dwnlds/stable/ \
- http://www.wsmake.org/docs/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= wsmake
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} examples.tar.gz
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
@@ -27,10 +27,6 @@ DISTFILES+= user-manual-html.tar.gz
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,void\*,char\*,g' ${WRKSRC}/libwsmake/wsUtil.cpp
diff --git a/www/wsmake/files/patch-libwsmake_wsUtil.cpp b/www/wsmake/files/patch-libwsmake_wsUtil.cpp
new file mode 100644
index 000000000000..77ad62ed2db5
--- /dev/null
+++ b/www/wsmake/files/patch-libwsmake_wsUtil.cpp
@@ -0,0 +1,17 @@
+--- libwsmake/wsUtil.cpp.orig Sat Sep 1 20:09:13 2001
++++ libwsmake/wsUtil.cpp Thu Sep 15 12:38:48 2005
+@@ -709,12 +709,12 @@
+ }
+ }
+
+-void std::__wsmake_print_it(FILE *out, const char *output, const va_list *ap)
++void std::__wsmake_print_it(FILE *out, const char *output, va_list *ap)
+ {
+ if(__wsmake_quiet) return;
+
+ vfprintf(out,output,*ap);
+- va_end((void*&)*ap);
++ va_end(*ap);
+ }
+
+ #ifdef DEBUG
diff --git a/www/wsmake/files/patch-libwsmake_wsUtil.h b/www/wsmake/files/patch-libwsmake_wsUtil.h
new file mode 100644
index 000000000000..886da452339c
--- /dev/null
+++ b/www/wsmake/files/patch-libwsmake_wsUtil.h
@@ -0,0 +1,11 @@
+--- libwsmake/wsUtil.h.orig Thu Sep 15 09:39:51 2005
++++ libwsmake/wsUtil.h Thu Sep 15 09:38:34 2005
+@@ -77,7 +77,7 @@ namespace std
+ void __wsmake_print_error(const char *, ...);
+ void __wsmake_print(const char *, ...);
+ void __wsmake_print(int, const char *, ...);
+- void __wsmake_print_it(FILE *, const char *, const va_list *);
++ void __wsmake_print_it(FILE *, const char *, va_list *);
+ }
+
+ #endif /* __WSUTIL_H__ */