aboutsummaryrefslogtreecommitdiffstats
path: root/www/xist
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-10-07 20:02:44 +0800
committerwg <wg@FreeBSD.org>2014-10-07 20:02:44 +0800
commitf5ee240532bb9545acecdcbb58e366f95c7cdbd4 (patch)
treeac297bcbbc11474651fe79f4811a825a3fdd458a /www/xist
parent6e998ab56251384d1bd373d84463b6bf1232618b (diff)
downloadfreebsd-ports-gnome-f5ee240532bb9545acecdcbb58e366f95c7cdbd4.tar.gz
freebsd-ports-gnome-f5ee240532bb9545acecdcbb58e366f95c7cdbd4.tar.zst
freebsd-ports-gnome-f5ee240532bb9545acecdcbb58e366f95c7cdbd4.zip
www/xist: switch from py-imaging to py-pillow
- USES python With hat: python Approved by: portmgr (bdrewery, implicit)
Diffstat (limited to 'www/xist')
-rw-r--r--www/xist/Makefile10
-rw-r--r--www/xist/files/patch-src__ll__url.py11
2 files changed, 15 insertions, 6 deletions
diff --git a/www/xist/Makefile b/www/xist/Makefile
index 8a191a5833c4..24292ef687ed 100644
--- a/www/xist/Makefile
+++ b/www/xist/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xist
PORTVERSION= 3.25
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
http://ftp.livinglogic.de/xist/
@@ -17,13 +17,11 @@ LICENSE= MIT
RUN_DEPENDS= ${PYXML} \
${PYTHON_PKGNAMEPREFIX}ll-core>=1.11.1:${PORTSDIR}/devel/py-ll-core \
- ${PYTHON_PKGNAMEPREFIX}imaging>0:${PORTSDIR}/graphics/py-imaging \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
${PYTHON_PKGNAMEPREFIX}cssutils>=0.9.7:${PORTSDIR}/www/py-cssutils
-USES= tar:bzip2
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2 tar:bzip2
+USE_PYTHON= autoplist distutils
post-patch:
.for conflictswithllcore in __init__ scripts/__init__ ansistyle astyle color \
diff --git a/www/xist/files/patch-src__ll__url.py b/www/xist/files/patch-src__ll__url.py
new file mode 100644
index 000000000000..74cbd98407d2
--- /dev/null
+++ b/www/xist/files/patch-src__ll__url.py
@@ -0,0 +1,11 @@
+--- src/ll/url.py.orig 2014-10-07 12:02:25 UTC
++++ src/ll/url.py
+@@ -57,7 +57,7 @@
+ execnet = None
+
+ try:
+- import Image
++ from PIL import Image
+ except ImportError:
+ pass
+