aboutsummaryrefslogtreecommitdiffstats
path: root/www/yaws
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2012-12-05 06:08:24 +0800
committerolgeni <olgeni@FreeBSD.org>2012-12-05 06:08:24 +0800
commit87796cc9ec0a1bef809f874cc936cd7495ec76de (patch)
tree97e3fa1edb22671e19017c06bf54c3058ee53385 /www/yaws
parent97130f80b8416bd21ca4ce211ef2f9df9088f2b7 (diff)
downloadfreebsd-ports-gnome-87796cc9ec0a1bef809f874cc936cd7495ec76de.tar.gz
freebsd-ports-gnome-87796cc9ec0a1bef809f874cc936cd7495ec76de.tar.zst
freebsd-ports-gnome-87796cc9ec0a1bef809f874cc936cd7495ec76de.zip
Fix handling of source paths containing tilde characters in
yaws_compile.erl. Already patched upstream on github as klacke/yaws/25b8e4c. Feature safe: yes
Diffstat (limited to 'www/yaws')
-rw-r--r--www/yaws/Makefile1
-rw-r--r--www/yaws/files/patch-src_yaws__compile.erl14
2 files changed, 15 insertions, 0 deletions
diff --git a/www/yaws/Makefile b/www/yaws/Makefile
index 920a2eb4400b..01e9587b1990 100644
--- a/www/yaws/Makefile
+++ b/www/yaws/Makefile
@@ -7,6 +7,7 @@
PORTNAME= yaws
PORTVERSION= 1.95
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://yaws.hyber.org/download/
diff --git a/www/yaws/files/patch-src_yaws__compile.erl b/www/yaws/files/patch-src_yaws__compile.erl
new file mode 100644
index 000000000000..e5b426ebb5cb
--- /dev/null
+++ b/www/yaws/files/patch-src_yaws__compile.erl
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/yaws_compile.erl.orig
++++ src/yaws_compile.erl
+@@ -311,7 +311,7 @@
+ ?Debug("Writing outout file~s~n", [OutFile]),
+ {ok, Out} = file:open(OutFile, [write]),
+ ok = io:format(Out, "-module(\'~s\').~n-export([out/1]).~n~n", [Module]),
+- ok = io:format(Out, "-yawsfile('" ++ get(yfile) ++ "').~n",[]),
++ ok = io:format(Out, "-yawsfile(\'~s\').~n",[get(yfile)]),
+ io:format(Out, "%%~n%% code at line ~w from file ~s~n%%~n",
+ [Line, C#comp.infile]),
+ io:format(Out, "-import(yaws_api, [f/2, fl/1, postvar/2, queryvar/2])."