aboutsummaryrefslogtreecommitdiffstats
path: root/www/zope210/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-11-01 10:40:07 +0800
committersteve <steve@FreeBSD.org>1999-11-01 10:40:07 +0800
commit1819e146ae7620c8f0cbe1b93d75c0cf8b6a138a (patch)
tree5546c9bce69c63c20940f68293259cab2f861b2d /www/zope210/Makefile
parenta9cd7fc419d8f547d9d8a83e267e04a4ba8ef00d (diff)
downloadfreebsd-ports-gnome-1819e146ae7620c8f0cbe1b93d75c0cf8b6a138a.tar.gz
freebsd-ports-gnome-1819e146ae7620c8f0cbe1b93d75c0cf8b6a138a.tar.zst
freebsd-ports-gnome-1819e146ae7620c8f0cbe1b93d75c0cf8b6a138a.zip
Initial import of zope version 2.0.0b5.
An object-based web application platform with database access. PR: 13324 Submitted by: Peter Cornelius <pcc@gmx.net>
Diffstat (limited to 'www/zope210/Makefile')
-rw-r--r--www/zope210/Makefile82
1 files changed, 82 insertions, 0 deletions
diff --git a/www/zope210/Makefile b/www/zope210/Makefile
new file mode 100644
index 000000000000..4674d05197f7
--- /dev/null
+++ b/www/zope210/Makefile
@@ -0,0 +1,82 @@
+# New ports collection makefile for: Zope
+# Version required: 2.0.1
+# Date created: Sat 21 Aug 1999
+# Whom: Peter Cornelius <pcc@gmx.net>
+#
+# $FreeBSD$
+
+DISTNAME= Zope-${VERSION}-src
+PKGNAME= zope-${VERSION}
+CATEGORIES= www python
+MASTER_SITES= http://www.zope.org/Products/Zope/${VERSION}/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.ORG
+
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS= apache:${PORTSDIR}/www/apache13-modssl
+
+# Build has to be done in the final location after installing the sources
+# there. It were a major action to fix all paths otherwise.
+do-build: # empty, but needs to be there for the python dependency.
+
+# The web server's "root" directory used to be ${PREFIX}/www, and from
+# then on, data, cgi-bin and such. Thus, I decided that Zope belongs
+# there, too. I don't know whether this still applies to current apache
+# releases, though. I still run 2.2.8-STABLE.
+VERSION= 2.0.0b5
+PLIST_SUB= ZOPEBASEDIR=www/Zope-${VERSION} CGIBINDIR=share/apache/cgi-bin VERSION=${VERSION}
+WEBBASEDIR?= ${PREFIX}/www
+ZOPEBASEDIR?= ${WEBBASEDIR}/Zope-${VERSION}
+CGI_BIN_DIR?= ${PREFIX}/share/apache/cgi-bin
+APACHE_CONFDIR?= ${PREFIX}/etc/apache
+PYTHON15?= ${PREFIX}/bin/python1.5
+CHMOD= /bin/chmod
+
+# I decided to consider the whole souce tree to be part of the package
+# since in there, Zope can live on its own. It does leave some *.o files
+# around (about four), but I can use Zope's own building mechanism.
+do-install: #
+ @if [ -e ${ZOPEBASEDIR}/var/Data.fs ] ; then \
+ ${ECHO} "Saving existing Database to /tmp/Data.fs.BAK." ; \
+ ${MV} ${ZOPEBASEDIR}/var/Data.fs /tmp/Data.fs.BAK ; \
+ fi
+ @( ${MKDIR} ${ZOPEBASEDIR} ; \
+ ${ECHO} "===> Please be patient, some builds need their time." ; \
+ ${ECHO} "===> Copying..." ; \
+ ${CP} -Rp ${WRKSRC}/* ${ZOPEBASEDIR}/ ; \
+ cd ${ZOPEBASEDIR} ; \
+ ${PYTHON15} w_pcgi.py ; \
+ ${PYTHON15} wo_pcgi.py ; \
+ ${MV} Zope.cgi Zope.cgi.orig ; \
+ ${ECHO} "#! ${CGI_BIN_DIR}/pcgi-wrapper" > Zope.cgi ; \
+ ${CAT} Zope.cgi.orig >> Zope.cgi ; \
+ ${INSTALL} -o nobody -m 555 Zope.cgi pcgi/pcgi-wrapper ${CGI_BIN_DIR} ; \
+ ${ECHO} "===> Fixing permissions of Zope's own var directory..." ; \
+ ${CHMOD} ugo+rwt var ; \
+ ${ECHO} "===> Setting user/password to zopemaster/test..." ; \
+ ${PYTHON15} zpasswd.py -u zopemaster -p test -e CLEARTEXT access ; \
+ ${ECHO} "===> Copying Apache config file changes to ${APACHE_CONFDIR}/apache.conf.Zope-${VERSION}-Changes." ; \
+ ${CP} -p ${FILESDIR}/apache.conf.Zope-${VERSION}-Changes ${APACHE_CONFDIR}/ ; \
+ ${ECHO} "===> Please have a look at this file and the instructions" ; \
+ ${ECHO} "===> therein and incorporate them to your apache.conf." ; \
+ ${ECHO} "===> Creating rc startup file for Zope-${VERSION}..." ; \
+ ${ECHO} "#! /bin/sh" > ${PREFIX}/etc/rc.d/zope.sh ; \
+ ${ECHO} "${ZOPEBASEDIR}/start -w '' -f '' -m '' -p ${CGI_BIN_DIR}/Zope.cgi &" >> ${PREFIX}/etc/rc.d/zope.sh ; \
+ ${ECHO} "echo -n \" Zope\"" >> ${PREFIX}/etc/rc.d/zope.sh ; \
+ ${CHMOD} ug+x,o-rwx ${PREFIX}/etc/rc.d/zope.sh ; \
+ ${ECHO} "===> Done with ${PREFIX}/etc/rc.d/zope.sh." ; \
+ ${CAT} ${FILESDIR}/Message ; \
+ ${ECHO} "===> Your Zope base directory is ${ZOPEBASEDIR}." ; \
+ ${ECHO} "===> The Zope license is in ${ZOPEBASEDIR}/LICENSE.txt." ; \
+ ${ECHO} "===> For Apache changes see ${APACHE_CONFDIR}/apache.conf.Zope-${VERSION}-Changes." ; \
+ ${ECHO} "===> Zope.cgi and pcgi-wrapper live in ${CGI_BIN_DIR}." )
+
+#pre-deinstall: # Save Database contents. I expect /tmp to have sufficient
+# # space to hold it for the time being.
+# @if [ -e ${ZOPEBASEDIR}/var/Data.fs ] ; then \
+# ${ECHO} "Saving existing Database to /tmp/Data.fs.bak." ; \
+# ${MV} ${ZOPEBASEDIR}/var/Data.fs /tmp/Data.fs.bak ; \
+# fi
+
+.include <bsd.port.mk>