aboutsummaryrefslogtreecommitdiffstats
path: root/www/zope213/Makefile
diff options
context:
space:
mode:
authorjlaffaye <jlaffaye@FreeBSD.org>2011-07-19 19:00:31 +0800
committerjlaffaye <jlaffaye@FreeBSD.org>2011-07-19 19:00:31 +0800
commita5584e75040a17d213c91d8cc70b2581de533b4c (patch)
treeffcc447e9560f4214f68d3a9ce286370a1167c61 /www/zope213/Makefile
parentb9b8939bf0b339a3941385a280555f5a93c4c505 (diff)
downloadfreebsd-ports-gnome-a5584e75040a17d213c91d8cc70b2581de533b4c.tar.gz
freebsd-ports-gnome-a5584e75040a17d213c91d8cc70b2581de533b4c.tar.zst
freebsd-ports-gnome-a5584e75040a17d213c91d8cc70b2581de533b4c.zip
Update to 2.11.8
PR: ports/158528 Submitted by: Gerhard Schmidt <estartu@augusta.de> (maintainer)
Diffstat (limited to 'www/zope213/Makefile')
-rw-r--r--www/zope213/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/zope213/Makefile b/www/zope213/Makefile
index 77dda74c3708..00797d9e0c66 100644
--- a/www/zope213/Makefile
+++ b/www/zope213/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= zope211
-PORTVERSION= 2.11.6
+PORTVERSION= 2.11.8
CATEGORIES= www python zope
-MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
+MASTER_SITES= http://old.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
EXTRACT_SUFX= .tgz
DIST_SUBDIR= zope
@@ -51,7 +51,7 @@ ISBATCH= ""
.endif
post-patch:
- @${FIND} ${WRKSRC} -name '*.orig' -print0 | ${XARGS} -0 -- ${RM}
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
@${REINPLACE_CMD} \
-e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
-e 's,^\(TARGET="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
@@ -64,9 +64,6 @@ post-configure:
-e 's,^.*LN.*PYTHON.*$$,,g' \
${WRKSRC}/${MAKEFILE}
-post-build:
- -@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/
-
post-install:
${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in \
${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
@@ -75,6 +72,8 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/Products_00readme-freebsd.txt \
${ZOPEBASEDIR}/Products/00readme-freebsd.txt
+ -@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${ZOPEBASEDIR}/
+
.for d in lib bin doc skel Products
${FIND} ${ZOPEBASEDIR}/$d -type f -print0 | ${XARGS} -0 -- ${CHMOD} a-w+r
.endfor