aboutsummaryrefslogtreecommitdiffstats
path: root/www/zope
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2005-12-31 07:37:16 +0800
committergirgen <girgen@FreeBSD.org>2005-12-31 07:37:16 +0800
commit0e4dddae98c2c46c6f6904607b57ce63f387ddaf (patch)
treea436585f3af95370df6c690e98c02762ab07c256 /www/zope
parent92b4bb31dfc16f7a00c011f2c3b314469ab8ccc2 (diff)
downloadfreebsd-ports-gnome-0e4dddae98c2c46c6f6904607b57ce63f387ddaf.tar.gz
freebsd-ports-gnome-0e4dddae98c2c46c6f6904607b57ce63f387ddaf.tar.zst
freebsd-ports-gnome-0e4dddae98c2c46c6f6904607b57ce63f387ddaf.zip
Handle a change in rc.subr. Nowadays, "faststart" is used instead of
"start" when booting, since there's no need to waste time checking for running processes when the OS is starting up. Bumping portrevision. PR: 90904 Approved by: maintainer
Diffstat (limited to 'www/zope')
-rw-r--r--www/zope/Makefile1
-rw-r--r--www/zope/files/zeo.sh34
-rw-r--r--www/zope/files/zope.sh36
3 files changed, 24 insertions, 47 deletions
diff --git a/www/zope/Makefile b/www/zope/Makefile
index efc102a16f56..28ff4424ef9e 100644
--- a/www/zope/Makefile
+++ b/www/zope/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zope
PORTVERSION= 2.7.8
+PORTREVISION= 1
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
diff --git a/www/zope/files/zeo.sh b/www/zope/files/zeo.sh
index f067c06de8db..66057530b549 100644
--- a/www/zope/files/zeo.sh
+++ b/www/zope/files/zeo.sh
@@ -25,29 +25,17 @@ zeo_instances=${zeo_instances:-""} # List of instancehome dirs
name="zeo"
rcvar=`set_rcvar`
load_rc_config $name
+extra_commands="status"
if checkyesno zeo_enable; then
-
- case "$1" in
- start)
- echo "Starting Zeo"
- ;;
- stop)
- echo "Stopping Zeo"
- ;;
- restart)
- echo "Restarting Zeo"
- ;;
- *)
- echo "Unknown action \"$1\""
- ;;
- esac
-
- for instance in $zeo_instances
- do
- if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zeoctl ]; then
- echo -n " Instance ${instance} -> "
- ${instance}/bin/zeoctl $1
- fi
- done
+ for instance in $zeo_instances; do
+ required_files="${instance}/etc/${name}.conf ${instance}/bin/zeoctl"
+ zeo_command="${instance}/bin/zeoctl"
+ start_cmd="${zeo_command} start"
+ stop_cmd="${zeo_command} stop"
+ restart_cmd="${zeo_command} restart"
+ status_cmd="${zeo_command} status"
+ echo -n "Zeo instance ${instance} -> "
+ run_rc_command "$1"
+ done
fi
diff --git a/www/zope/files/zope.sh b/www/zope/files/zope.sh
index d4d2c4e3f785..eb6ec5b70acd 100644
--- a/www/zope/files/zope.sh
+++ b/www/zope/files/zope.sh
@@ -1,7 +1,7 @@
#!/bin/sh
# Start or stop zope
-# $FreeBSD: /tmp/pcvs/ports/www/zope/files/Attic/zope.sh,v 1.5 2005-02-18 16:52:17 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/www/zope/files/Attic/zope.sh,v 1.6 2005-12-30 23:37:16 girgen Exp $
# PROVIDE: zope
# REQUIRE: DAEMON
@@ -25,29 +25,17 @@ zope_instances=${zope_instances:-""} # List of instancehome dirs
name="zope"
rcvar=`set_rcvar`
load_rc_config $name
+extra_commands="status"
if checkyesno zope_enable; then
-
- case "$1" in
- start)
- echo "Starting Zope"
- ;;
- stop)
- echo "Stopping Zope"
- ;;
- restart)
- echo "Restarting Zope"
- ;;
- *)
- echo "Unknown action \"$1\""
- ;;
- esac
-
- for instance in $zope_instances
- do
- if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zopectl ]; then
- echo -n " Instance ${instance} -> "
- ${instance}/bin/zopectl $1
- fi
- done
+ for instance in $zope_instances; do
+ required_files="${instance}/etc/${name}.conf ${instance}/bin/zopectl"
+ zope_command="${instance}/bin/zopectl"
+ start_cmd="${zope_command} start"
+ stop_cmd="${zope_command} stop"
+ restart_cmd="${zope_command} restart"
+ status_cmd="${zope_command} status"
+ echo -n "Zope instance ${instance} -> "
+ run_rc_command "$1"
+ done
fi