aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2016-01-12 20:48:24 +0800
committerAshish SHUKLA <ashish@FreeBSD.org>2016-01-12 20:48:24 +0800
commit00f7eb7979d4cd6a451ccccc3b29ae62af36995f (patch)
tree587df526816ceaac33fdd6cc279acd69490e64b4 /www
parent19eb680d72135f900caa3d34445c18ec5fdaedc5 (diff)
downloadfreebsd-ports-gnome-00f7eb7979d4cd6a451ccccc3b29ae62af36995f.tar.gz
freebsd-ports-gnome-00f7eb7979d4cd6a451ccccc3b29ae62af36995f.tar.zst
freebsd-ports-gnome-00f7eb7979d4cd6a451ccccc3b29ae62af36995f.zip
- Update to latest git revision
- Simplify build handling and respect build flags[1] - Switch to options helpers[1] - Remove unneeded @dir's from plist[1] - Add build dependency on gmake - Fix conkeror script to be PREFIX independent - Update dependency on firefox to be inclusive PR: 205576 Submitted by: amdmi3[1]
Diffstat (limited to 'www')
-rw-r--r--www/xpi-conkeror/Makefile21
-rw-r--r--www/xpi-conkeror/distinfo4
-rw-r--r--www/xpi-conkeror/files/patch-conkeror2
-rw-r--r--www/xpi-conkeror/pkg-plist34
4 files changed, 12 insertions, 49 deletions
diff --git a/www/xpi-conkeror/Makefile b/www/xpi-conkeror/Makefile
index 6193adde17c7..fd889ba7ac1e 100644
--- a/www/xpi-conkeror/Makefile
+++ b/www/xpi-conkeror/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= conkeror
-PORTVERSION= 20140911
+PORTVERSION= 20150730
CATEGORIES= www
MASTER_SITES= http://distfiles.pirateparty.in/ashish/ \
LOCAL/ashish
@@ -19,20 +19,19 @@ FIREFOX_DESC?= Use XULRunner from Firefox port
LIBXUL_DESC?= Use XULRunner from LibXUL port
OPTIONS_DEFAULT+= LIBXUL
-USES= desktop-file-utils tar:xz
+USES= desktop-file-utils tar:xz gmake
LIBXUL_USES= gecko
-FIREFOX_USES= gecko:firefox,32
-
-.include <bsd.port.options.mk>
+FIREFOX_USES= gecko:firefox,32+
+ALL_TARGET= # empty
BUILD_ID= ${ECHO_CMD} -n `whoami`@`hostname`_`date +%s`
post-patch:
cd ${WRKSRC} && \
- ${MV} debian/conkeror.desktop . && \
+ ${MV} contrib/conkeror.desktop . && \
${MV} contrib/man/conkeror.1 . && \
- ${RM} -rf contrib/debian contrib/man debian tests && \
+ ${RM} -rf contrib/debian contrib/dist contrib/man debian tests && \
${RM} -f contrib/build.sh contrib/install.sh contrib/mketags.sh \
contrib/testrun.sh contrib/run-conkeror && \
${MKDIR} share && \
@@ -41,14 +40,12 @@ post-patch:
style share && \
${MV} COPYING CREDITS Info.plist chrome.manifest \
content-policy.manifest share
-.if ${PORT_OPTIONS:MFIREFOX}
+ ${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR},g" ${WRKSRC}/conkeror
+
+post-patch-FIREFOX-on:
${REINPLACE_CMD} -e "s/xulrunner/firefox/g" ${WRKSRC}/conkeror
${REINPLACE_CMD} -e "s/XULRUNNER/FIREFOX/g" ${WRKSRC}/conkeror
${REINPLACE_CMD} -e 's/exec $${FIREFOX}/exec $${FIREFOX} -app/' ${WRKSRC}/conkeror
-.endif
-
-do-build:
- ${MAKE} -C ${WRKSRC}
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/conkeror
diff --git a/www/xpi-conkeror/distinfo b/www/xpi-conkeror/distinfo
index f2902837a7eb..634bebd4d684 100644
--- a/www/xpi-conkeror/distinfo
+++ b/www/xpi-conkeror/distinfo
@@ -1,2 +1,2 @@
-SHA256 (conkeror-20140911.tar.xz) = c5ac96c56ff7695f522162e2a4080e3c8c111a62131b6912718475c6ff2890d8
-SIZE (conkeror-20140911.tar.xz) = 240232
+SHA256 (conkeror-20150730.tar.xz) = 7695fc4e429b2ba6c035ccddc8ecc72cc6a248297999451102c867d8df4c726d
+SIZE (conkeror-20150730.tar.xz) = 242640
diff --git a/www/xpi-conkeror/files/patch-conkeror b/www/xpi-conkeror/files/patch-conkeror
index b3ab89d9c008..5cb5c82bdd74 100644
--- a/www/xpi-conkeror/files/patch-conkeror
+++ b/www/xpi-conkeror/files/patch-conkeror
@@ -10,6 +10,6 @@
+elif [ ! -x "${XULRUNNER}" ]; then
+ echo ${XULRUNNER} is not executable.
+else
-+ exec ${XULRUNNER} /usr/local/share/conkeror/application.ini "$@"
++ exec ${XULRUNNER} %%DATADIR%%/application.ini "$@"
+fi
+
diff --git a/www/xpi-conkeror/pkg-plist b/www/xpi-conkeror/pkg-plist
index 302818ad9125..9888285cc66d 100644
--- a/www/xpi-conkeror/pkg-plist
+++ b/www/xpi-conkeror/pkg-plist
@@ -225,37 +225,3 @@ share/applications/conkeror.desktop
%%DATADIR%%/style/gesso/theme.json
%%DATADIR%%/style/mono/conkeror--mono.css
%%DATADIR%%/style/mono/theme.json
-@dir %%DATADIR%%/style/default
-@dir %%DATADIR%%/style/gesso
-@dir %%DATADIR%%/style/mono
-@dir %%DATADIR%%/style
-@dir %%DATADIR%%/search-engines
-@dir %%DATADIR%%/modules/page-modes
-@dir %%DATADIR%%/modules/extensions
-@dir %%DATADIR%%/modules/compat
-@dir %%DATADIR%%/modules/bindings/default/content-buffer
-@dir %%DATADIR%%/modules/bindings/default
-@dir %%DATADIR%%/modules/bindings
-@dir %%DATADIR%%/modules
-@dir %%DATADIR%%/locale/sv-SE
-@dir %%DATADIR%%/locale/en-US
-@dir %%DATADIR%%/locale
-@dir %%DATADIR%%/help
-@dir %%DATADIR%%/defaults/preferences
-@dir %%DATADIR%%/defaults
-@dir %%DATADIR%%/contrib/art
-@dir %%DATADIR%%/contrib/config
-@dir %%DATADIR%%/contrib/modules
-@dir %%DATADIR%%/contrib/xrev/defaults/preferences
-@dir %%DATADIR%%/contrib/xrev/defaults
-@dir %%DATADIR%%/contrib/xrev/content
-@dir %%DATADIR%%/contrib/xrev/chrome
-@dir %%DATADIR%%/contrib/xrev
-@dir %%DATADIR%%/contrib
-@dir %%DATADIR%%/content
-@dir %%DATADIR%%/components
-@dir %%DATADIR%%/chrome
-@dir %%DATADIR%%/branding/content
-@dir %%DATADIR%%/branding
-@dir %%DATADIR%%
-@dir libexec/conkeror