aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-01-19 18:10:37 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-01-19 18:10:37 +0800
commit018fbb6a8c8c1589c09915af44122ff5ccfdd12a (patch)
tree405085c04713d0ae61c3ef1e0dd026c43c599d14 /www
parente2b212f1a3d086f98a53f996e482ed6e01e41912 (diff)
downloadfreebsd-ports-gnome-018fbb6a8c8c1589c09915af44122ff5ccfdd12a.tar.gz
freebsd-ports-gnome-018fbb6a8c8c1589c09915af44122ff5ccfdd12a.tar.zst
freebsd-ports-gnome-018fbb6a8c8c1589c09915af44122ff5ccfdd12a.zip
HTML::Template::Pro is a fast lightweight C/Perl+XS reimplementation
of HTML::Template (as of 2.9) and HTML::Template::Expr (as of 0.0.7). It is not intended to be a complete replacement, but to be a fast implementation of HTML::Template if you don't need querying, the extended facility of HTML::Template. Designed for heavy upload, resource limitations, abcence of mod_perl. WWW: http://search.cpan.org/dist/HTML-Template-Pro/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Template-Pro/Makefile22
-rw-r--r--www/p5-HTML-Template-Pro/distinfo2
-rw-r--r--www/p5-HTML-Template-Pro/pkg-descr8
-rw-r--r--www/p5-HTML-Template-Pro/pkg-plist13
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f9f1009a7cc8..6b72eac691b5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -954,6 +954,7 @@
SUBDIR += p5-HTML-Template-HashWrapper
SUBDIR += p5-HTML-Template-JIT
SUBDIR += p5-HTML-Template-Pluggable
+ SUBDIR += p5-HTML-Template-Pro
SUBDIR += p5-HTML-Toc
SUBDIR += p5-HTML-TokeParser-Simple
SUBDIR += p5-HTML-Tree
diff --git a/www/p5-HTML-Template-Pro/Makefile b/www/p5-HTML-Template-Pro/Makefile
new file mode 100644
index 000000000000..427ca4b25dd9
--- /dev/null
+++ b/www/p5-HTML-Template-Pro/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= HTML-Template-Pro
+PORTVERSION= 0.9509
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to use HTML Templates from CGI scripts
+
+RUN_DEPENDS= \
+ p5-JSON>=2:${PORTSDIR}/converters/p5-JSON
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Template::PerlInterface.3 \
+ HTML::Template::Pro.3 \
+ HTML::Template::SYNTAX.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Template-Pro/distinfo b/www/p5-HTML-Template-Pro/distinfo
new file mode 100644
index 000000000000..024faca5a56b
--- /dev/null
+++ b/www/p5-HTML-Template-Pro/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTML-Template-Pro-0.9509.tar.gz) = fdeada12da283361ae3986cd13376d3a30f0221c18488cc58b0cff50ee03eba6
+SIZE (HTML-Template-Pro-0.9509.tar.gz) = 171357
diff --git a/www/p5-HTML-Template-Pro/pkg-descr b/www/p5-HTML-Template-Pro/pkg-descr
new file mode 100644
index 000000000000..0301b9f3c674
--- /dev/null
+++ b/www/p5-HTML-Template-Pro/pkg-descr
@@ -0,0 +1,8 @@
+HTML::Template::Pro is a fast lightweight C/Perl+XS reimplementation
+of HTML::Template (as of 2.9) and HTML::Template::Expr (as of
+0.0.7). It is not intended to be a complete replacement, but to be a
+fast implementation of HTML::Template if you don't need querying, the
+extended facility of HTML::Template. Designed for heavy upload,
+resource limitations, abcence of mod_perl.
+
+WWW: http://search.cpan.org/dist/HTML-Template-Pro/
diff --git a/www/p5-HTML-Template-Pro/pkg-plist b/www/p5-HTML-Template-Pro/pkg-plist
new file mode 100644
index 000000000000..52f288e91796
--- /dev/null
+++ b/www/p5-HTML-Template-Pro/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/Pro/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/Pro/Pro.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/Pro/Pro.so
+%%SITE_PERL%%/%%PERL_ARCH%%/HTML/Template/PerlInterface.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/HTML/Template/Pro.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/HTML/Template/Pro/WrapAssociate.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/HTML/Template/SYNTAX.pod
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/HTML/Template/Pro
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/HTML/Template
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/HTML
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/Pro
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML