aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-10-11 02:03:40 +0800
committerswills <swills@FreeBSD.org>2017-10-11 02:03:40 +0800
commit02759eae0062198efd91a270f35132bb86d18116 (patch)
treedc9ab536c3cc566fd06f6085b7b7f07bb2fe3dcb /www
parenta798b20786441a701f33c6826c2b65d9fe00ca19 (diff)
downloadfreebsd-ports-gnome-02759eae0062198efd91a270f35132bb86d18116.tar.gz
freebsd-ports-gnome-02759eae0062198efd91a270f35132bb86d18116.tar.zst
freebsd-ports-gnome-02759eae0062198efd91a270f35132bb86d18116.zip
www/minio: update to RELEASE.2017-09-29T19-16-56Z
While here, disable CGO since it's not needed and this gives a static binary like upstream ships. And remove CC=clang check since we don't use CC any more. Also, shorten the install command for readability. PR: 222886 Submitted by: jhixson@gmail.com (inspired by)
Diffstat (limited to 'www')
-rw-r--r--www/minio/Makefile18
-rw-r--r--www/minio/distinfo6
2 files changed, 10 insertions, 14 deletions
diff --git a/www/minio/Makefile b/www/minio/Makefile
index 295b4a53117a..3d5321aa88ef 100644
--- a/www/minio/Makefile
+++ b/www/minio/Makefile
@@ -14,9 +14,9 @@ BUILD_DEPENDS= go>=1.7:lang/go
USES= compiler
USE_GITHUB= yes
-GH_TAGNAME= RELEASE.2017-05-05T01-14-51Z
+GH_TAGNAME= RELEASE.2017-09-29T19-16-56Z
GH_SUBDIR= src/github.com/${PORTNAME}/${PORTNAME}
-COMMIT_ID= 40985cc4e3eec06b7ea82dc34c8d907fd2e7aa12
+COMMIT_ID= 60cc6184d253efee4a3120683517028342229e21
PLIST_FILES= bin/minio
@@ -29,15 +29,11 @@ SUB_LIST= USER="${USERS}" \
GROUP="${GROUPS}"
do-build:
- cd ${WRKSRC}/${GH_SUBDIR} ; GOPATH=${WRKSRC} go build --ldflags '-X github.com/minio/minio/cmd.Version=${GH_TAGNAME:C/RELEASE\.//:C|(..)-(..)-(..)Z|\1:\2:\3Z|} -X github.com/minio/minio/cmd.ReleaseTag=${GH_TAGNAME} -X github.com/minio/minio/cmd.CommitID=${COMMIT_ID} -X github.com/minio/minio/cmd.GOPATH=${WRKSRC} -s -w' -o ${WRKSRC}/bin/minio
+ @cd ${WRKSRC}/${GH_SUBDIR} ; \
+ ${SETENV} GOPATH=${WRKSRC} CGO_ENABLED=0 go build \
+ --ldflags '-X github.com/minio/minio/cmd.Version=${GH_TAGNAME:C/RELEASE\.//:C|(..)-(..)-(..)Z|\1:\2:\3Z|} -X github.com/minio/minio/cmd.ReleaseTag=${GH_TAGNAME} -X github.com/minio/minio/cmd.CommitID=${COMMIT_ID} -X github.com/minio/minio/cmd.GOPATH=${WRKSRC} -s -w' -o ${WRKSRC}/bin/minio
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == clang
-BUILD_ENV= CC=clang
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/minio/distinfo b/www/minio/distinfo
index 1f2e3667b874..6d82829ccdd1 100644
--- a/www/minio/distinfo
+++ b/www/minio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493952231
-SHA256 (minio-minio-2017.05.05.01.14.51-RELEASE.2017-05-05T01-14-51Z_GH0.tar.gz) = 6f36a82f075ffbaf2a69b0e3f42820d9576a871160aa4484d6323945a6bc84a1
-SIZE (minio-minio-2017.05.05.01.14.51-RELEASE.2017-05-05T01-14-51Z_GH0.tar.gz) = 4576742
+TIMESTAMP = 1507655373
+SHA256 (minio-minio-2017.09.29.19.16.56-RELEASE.2017-09-29T19-16-56Z_GH0.tar.gz) = 9d8bdb8c7cf177bb8ed07b1a4b9f3c1effa789d1446a47a6e905faedfc4302c0
+SIZE (minio-minio-2017.09.29.19.16.56-RELEASE.2017-09-29T19-16-56Z_GH0.tar.gz) = 6977013