aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-11-21 20:15:15 +0800
committertcberner <tcberner@FreeBSD.org>2016-11-21 20:15:15 +0800
commit035e52a0f70a15d9a843e0e8e51064bd8cf03932 (patch)
tree43cd3bf27cc6641fda345647212a32fb176dbec5 /www
parent196366a43a53593e1c6fb268e0325dff1d53e65a (diff)
downloadfreebsd-ports-gnome-035e52a0f70a15d9a843e0e8e51064bd8cf03932.tar.gz
freebsd-ports-gnome-035e52a0f70a15d9a843e0e8e51064bd8cf03932.tar.zst
freebsd-ports-gnome-035e52a0f70a15d9a843e0e8e51064bd8cf03932.zip
www/qupzilla-qt5: Correct the KWALLET option
The KWALLET option had been added based on early plans for KDE5. Now that the KF5 ports are committed, correct the KWALLET option to match the new KF5 ports. Also, convert USE_OPENSSL to USES=ssl and add missing USE_GL and USE_QT5 components identified by stage-QA. PR: 214530 Submitted by: Matthew Rezny <matthew@reztek.cz> (maintainer) Approved by: rakuco (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/qupzilla-qt5/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/www/qupzilla-qt5/Makefile b/www/qupzilla-qt5/Makefile
index 34e3b7ca2b57..461cd19e3681 100644
--- a/www/qupzilla-qt5/Makefile
+++ b/www/qupzilla-qt5/Makefile
@@ -16,12 +16,12 @@ LIB_DEPENDS= libhunspell-1.3.so:textproc/hunspell
CONFLICTS_INSTALL= ${PORTNAME}-qt4*
-USES= desktop-file-utils execinfo pkgconfig qmake tar:xz
-USE_QT5= core concurrent gui network script webkit x11extras xml \
- buildtools_build linguisttools_build \
- imageformats_run sql-sqlite3_run
+USES= desktop-file-utils execinfo pkgconfig qmake ssl tar:xz
+USE_QT5= core concurrent gui network printsupport script sql webkit \
+ widgets x11extras xml imageformats_run sql-sqlite3_run \
+ buildtools_build linguisttools_build
USE_XORG= x11
-USE_OPENSSL= yes
+USE_GL= gl
CONFIGURE_ENV= QUPZILLA_PREFIX=${PREFIX}/
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -37,7 +37,8 @@ DBUS_CONFIGURE_ENV_OFF= DISABLE_DBUS="true"
GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring
GNOMEKEYRING_CONFIGURE_ENV= GNOME_INTEGRATION="true"
-KWALLET_USE= KDE5=wallet
+KWALLET_USES= kde:5
+KWALLET_USE= KDE=wallet
KWALLET_CONFIGURE_ENV= KDE_INTEGRATION="true"
.include <bsd.port.options.mk>