aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-12-02 13:44:22 +0800
committerMichael Johnson <ahze@FreeBSD.org>2005-12-02 13:44:22 +0800
commit0483e4de82b9d4e8e86fb76240be6fa094c0e9b3 (patch)
treeb4cb77d4f21cd2f9291f68366c6a42d866b4b0de /www
parent64a923ea9802fcf2c57c2269c180256206888ac4 (diff)
downloadfreebsd-ports-gnome-0483e4de82b9d4e8e86fb76240be6fa094c0e9b3.tar.gz
freebsd-ports-gnome-0483e4de82b9d4e8e86fb76240be6fa094c0e9b3.tar.zst
freebsd-ports-gnome-0483e4de82b9d4e8e86fb76240be6fa094c0e9b3.zip
- Disable svg support on 5.3 and lower to fix build with a gcc bug.
Reported by: many Tested by: mark@mkproductions.org
Diffstat (limited to 'www')
-rw-r--r--www/firefox-esr/Makefile6
-rw-r--r--www/firefox/Makefile6
-rw-r--r--www/firefox10/Makefile6
-rw-r--r--www/firefox15/Makefile6
-rw-r--r--www/firefox36/Makefile6
-rw-r--r--www/flock/Makefile6
6 files changed, 24 insertions, 12 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 0ed05ba057ec..f2eb5ed038e2 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -31,8 +31,6 @@ USE_GCC= 3.4+
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZ_OPTIONS= --enable-application=browser \
- --enable-svg \
- --enable-svg-renderer=cairo \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas
@@ -50,6 +48,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
IGNORE= core dumps on alpha during post-build
.endif
+.if ${OSVERSION} >= 504101
+MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 0ed05ba057ec..f2eb5ed038e2 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -31,8 +31,6 @@ USE_GCC= 3.4+
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZ_OPTIONS= --enable-application=browser \
- --enable-svg \
- --enable-svg-renderer=cairo \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas
@@ -50,6 +48,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
IGNORE= core dumps on alpha during post-build
.endif
+.if ${OSVERSION} >= 504101
+MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index 0ed05ba057ec..f2eb5ed038e2 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -31,8 +31,6 @@ USE_GCC= 3.4+
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZ_OPTIONS= --enable-application=browser \
- --enable-svg \
- --enable-svg-renderer=cairo \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas
@@ -50,6 +48,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
IGNORE= core dumps on alpha during post-build
.endif
+.if ${OSVERSION} >= 504101
+MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index 0ed05ba057ec..f2eb5ed038e2 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -31,8 +31,6 @@ USE_GCC= 3.4+
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZ_OPTIONS= --enable-application=browser \
- --enable-svg \
- --enable-svg-renderer=cairo \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas
@@ -50,6 +48,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
IGNORE= core dumps on alpha during post-build
.endif
+.if ${OSVERSION} >= 504101
+MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 0ed05ba057ec..f2eb5ed038e2 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -31,8 +31,6 @@ USE_GCC= 3.4+
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZ_OPTIONS= --enable-application=browser \
- --enable-svg \
- --enable-svg-renderer=cairo \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas
@@ -50,6 +48,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
IGNORE= core dumps on alpha during post-build
.endif
+.if ${OSVERSION} >= 504101
+MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/www/flock/Makefile b/www/flock/Makefile
index 0ed05ba057ec..f2eb5ed038e2 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -31,8 +31,6 @@ USE_GCC= 3.4+
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZ_OPTIONS= --enable-application=browser \
- --enable-svg \
- --enable-svg-renderer=cairo \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas
@@ -50,6 +48,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
IGNORE= core dumps on alpha during post-build
.endif
+.if ${OSVERSION} >= 504101
+MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif