aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-03-08 15:28:36 +0800
committerasami <asami@FreeBSD.org>1999-03-08 15:28:36 +0800
commit04f6beab8f8083412efad3eadf4e32bffa85bbe2 (patch)
tree907e6a967f7d00919c4dc13b6a581739f386e7ef /www
parent755e63021c52f5292b5284c5d10c05274df15811 (diff)
downloadfreebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.tar.gz
freebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.tar.zst
freebsd-ports-gnome-04f6beab8f8083412efad3eadf4e32bffa85bbe2.zip
Fix to make ports work with bsd.port.mk rev. 1.306.
${MACHINE_ARCH}--freebsd${OSREL} is now passed to CONFIGURE_ARGS if GNU_CONFIGURE is defined. Take the target out of CONFIGURE_ARGS of some ports that added it explicitly; define it as ${MACHINE_ARCH}--freebsd if the port doesn't like the ${OSREL} part; define it as something else (such as ${MACHINE_ARCH}--freebsdelf if the port requires that; define it as an empty string if the port doesn't like it at all. The last might be a sign that a GNU_CONFIGURE port actually doesn't use GNU's version of configure at all; but I don't have time to go look at them all, we'll fix them as time goes on. At least we've got much fewer "-unknown-"s in the tree as the result. :)
Diffstat (limited to 'www')
-rw-r--r--www/apache13/Makefile5
-rw-r--r--www/apache2/Makefile5
-rw-r--r--www/apache20/Makefile5
-rw-r--r--www/apache21/Makefile5
-rw-r--r--www/apache22/Makefile5
-rw-r--r--www/mod_php3/Makefile5
-rw-r--r--www/mod_php4/Makefile5
-rw-r--r--www/mod_php5/Makefile5
8 files changed, 24 insertions, 16 deletions
diff --git a/www/apache13/Makefile b/www/apache13/Makefile
index a56e33bf00a3..1c1eed113c9c 100644
--- a/www/apache13/Makefile
+++ b/www/apache13/Makefile
@@ -3,7 +3,7 @@
# Date created: Fri Aug 25 16:42:36 CDT 1995
# Whom: ache@nagual.pp.ru
#
-# $Id: Makefile,v 1.65 1999/01/15 00:26:19 ache Exp $
+# $Id: Makefile,v 1.66 1999/03/07 18:34:56 ache Exp $
#
DISTNAME= apache_1.3.4
@@ -19,8 +19,9 @@ Y2K= http://www.apache.org/docs/misc/FAQ.html#year2000
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
+ --prefix=${PREFIX} \
--with-layout=GNU \
--sysconfdir=${PREFIX}/etc/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index a56e33bf00a3..1c1eed113c9c 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -3,7 +3,7 @@
# Date created: Fri Aug 25 16:42:36 CDT 1995
# Whom: ache@nagual.pp.ru
#
-# $Id: Makefile,v 1.65 1999/01/15 00:26:19 ache Exp $
+# $Id: Makefile,v 1.66 1999/03/07 18:34:56 ache Exp $
#
DISTNAME= apache_1.3.4
@@ -19,8 +19,9 @@ Y2K= http://www.apache.org/docs/misc/FAQ.html#year2000
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
+ --prefix=${PREFIX} \
--with-layout=GNU \
--sysconfdir=${PREFIX}/etc/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index a56e33bf00a3..1c1eed113c9c 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -3,7 +3,7 @@
# Date created: Fri Aug 25 16:42:36 CDT 1995
# Whom: ache@nagual.pp.ru
#
-# $Id: Makefile,v 1.65 1999/01/15 00:26:19 ache Exp $
+# $Id: Makefile,v 1.66 1999/03/07 18:34:56 ache Exp $
#
DISTNAME= apache_1.3.4
@@ -19,8 +19,9 @@ Y2K= http://www.apache.org/docs/misc/FAQ.html#year2000
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
+ --prefix=${PREFIX} \
--with-layout=GNU \
--sysconfdir=${PREFIX}/etc/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/apache21/Makefile b/www/apache21/Makefile
index a56e33bf00a3..1c1eed113c9c 100644
--- a/www/apache21/Makefile
+++ b/www/apache21/Makefile
@@ -3,7 +3,7 @@
# Date created: Fri Aug 25 16:42:36 CDT 1995
# Whom: ache@nagual.pp.ru
#
-# $Id: Makefile,v 1.65 1999/01/15 00:26:19 ache Exp $
+# $Id: Makefile,v 1.66 1999/03/07 18:34:56 ache Exp $
#
DISTNAME= apache_1.3.4
@@ -19,8 +19,9 @@ Y2K= http://www.apache.org/docs/misc/FAQ.html#year2000
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
+ --prefix=${PREFIX} \
--with-layout=GNU \
--sysconfdir=${PREFIX}/etc/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index a56e33bf00a3..1c1eed113c9c 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -3,7 +3,7 @@
# Date created: Fri Aug 25 16:42:36 CDT 1995
# Whom: ache@nagual.pp.ru
#
-# $Id: Makefile,v 1.65 1999/01/15 00:26:19 ache Exp $
+# $Id: Makefile,v 1.66 1999/03/07 18:34:56 ache Exp $
#
DISTNAME= apache_1.3.4
@@ -19,8 +19,9 @@ Y2K= http://www.apache.org/docs/misc/FAQ.html#year2000
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
+ --prefix=${PREFIX} \
--with-layout=GNU \
--sysconfdir=${PREFIX}/etc/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index b26e89a9d681..6c07074549ed 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -3,7 +3,7 @@
# Date created: So 21 Jun 1998 16:09:39 CEST
# Whom: Stefan Herrmann <stefan@asterix.webaffairs.net>
#
-# $Id: Makefile,v 1.64 1999/01/08 17:22:06 dirk Exp $
+# $Id: Makefile,v 1.66 1999/01/13 17:31:09 dirk Exp $
#
DISTNAME= apache_${VERSION_APACHE}
@@ -29,8 +29,9 @@ VERSION_PHP3= 3.0.6
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
+ --prefix=${PREFIX} \
--with-layout=GNU \
--sysconfdir=${PREFIX}/etc/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index b26e89a9d681..6c07074549ed 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -3,7 +3,7 @@
# Date created: So 21 Jun 1998 16:09:39 CEST
# Whom: Stefan Herrmann <stefan@asterix.webaffairs.net>
#
-# $Id: Makefile,v 1.64 1999/01/08 17:22:06 dirk Exp $
+# $Id: Makefile,v 1.66 1999/01/13 17:31:09 dirk Exp $
#
DISTNAME= apache_${VERSION_APACHE}
@@ -29,8 +29,9 @@ VERSION_PHP3= 3.0.6
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
+ --prefix=${PREFIX} \
--with-layout=GNU \
--sysconfdir=${PREFIX}/etc/apache \
--includedir=${PREFIX}/include/apache \
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index b26e89a9d681..6c07074549ed 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -3,7 +3,7 @@
# Date created: So 21 Jun 1998 16:09:39 CEST
# Whom: Stefan Herrmann <stefan@asterix.webaffairs.net>
#
-# $Id: Makefile,v 1.64 1999/01/08 17:22:06 dirk Exp $
+# $Id: Makefile,v 1.66 1999/01/13 17:31:09 dirk Exp $
#
DISTNAME= apache_${VERSION_APACHE}
@@ -29,8 +29,9 @@ VERSION_PHP3= 3.0.6
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
+ --prefix=${PREFIX} \
--with-layout=GNU \
--sysconfdir=${PREFIX}/etc/apache \
--includedir=${PREFIX}/include/apache \