aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-02-18 22:47:05 +0800
committermiwi <miwi@FreeBSD.org>2016-02-18 22:47:05 +0800
commit0605c2e30fd40378d7d04ab8d5fa3016d20395bd (patch)
treee69b03665ccb6cfc03028cfd2ad64ba204ed3d0f /www
parentc3ce6a8b5508bdf420f83160811e90504704c834 (diff)
downloadfreebsd-ports-gnome-0605c2e30fd40378d7d04ab8d5fa3016d20395bd.tar.gz
freebsd-ports-gnome-0605c2e30fd40378d7d04ab8d5fa3016d20395bd.tar.zst
freebsd-ports-gnome-0605c2e30fd40378d7d04ab8d5fa3016d20395bd.zip
- Ignore php70
- While here remove old php gruft
Diffstat (limited to 'www')
-rw-r--r--www/pecl-APC/Makefile2
-rw-r--r--www/pecl-amfext/Makefile1
-rw-r--r--www/pecl-http1/Makefile2
-rw-r--r--www/pecl-solr/Makefile1
-rw-r--r--www/pecl-sphinx/Makefile1
-rw-r--r--www/pecl-swish/Makefile1
-rw-r--r--www/pecl-twig/Makefile1
-rw-r--r--www/pecl-yaf/Makefile1
-rw-r--r--www/pecl-yar/Makefile1
9 files changed, 9 insertions, 2 deletions
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index 4c30ba7078c5..609acc9d89c8 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -27,7 +27,7 @@ SPINLOCKS_DESC= Spinlocks (experimental)
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --enable-apc
-IGNORE_WITH_PHP=55 56
+IGNORE_WITH_PHP=55 56 70
PHP_MODNAME= ${PORTNAME:tl}
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
diff --git a/www/pecl-amfext/Makefile b/www/pecl-amfext/Makefile
index f843172f57ce..d314255fba5e 100644
--- a/www/pecl-amfext/Makefile
+++ b/www/pecl-amfext/Makefile
@@ -18,6 +18,7 @@ USES= dos2unix libtool tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= amf
+IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --with-amf
diff --git a/www/pecl-http1/Makefile b/www/pecl-http1/Makefile
index 69e16d1b1192..a0a533364e2e 100644
--- a/www/pecl-http1/Makefile
+++ b/www/pecl-http1/Makefile
@@ -21,7 +21,7 @@ USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= http
-IGNORE_WITH_PHP= 56
+IGNORE_WITH_PHP= 56 70
CONFLICTS= pecl-http-*
CONFIGURE_ARGS+= --with-http-curl-requests \
diff --git a/www/pecl-solr/Makefile b/www/pecl-solr/Makefile
index f6d103477cf5..4d9e8b99201d 100644
--- a/www/pecl-solr/Makefile
+++ b/www/pecl-solr/Makefile
@@ -18,5 +18,6 @@ USE_PHP= json
USE_PHPEXT= yes
USE_PHPIZE= yes
USE_PHP_BUILD= yes
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/www/pecl-sphinx/Makefile b/www/pecl-sphinx/Makefile
index 609fd7c0c03d..f25302847237 100644
--- a/www/pecl-sphinx/Makefile
+++ b/www/pecl-sphinx/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libsphinxclient.so:${PORTSDIR}/textproc/libsphinxclient
USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/www/pecl-swish/Makefile b/www/pecl-swish/Makefile
index cdd5e4e03a78..9876e7e376b2 100644
--- a/www/pecl-swish/Makefile
+++ b/www/pecl-swish/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS:= swish-config:${PORTSDIR}/www/swish-e
USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-swish --with-swish=${LOCALBASE}/bin
diff --git a/www/pecl-twig/Makefile b/www/pecl-twig/Makefile
index b6d6ab38399a..e4388666d61a 100644
--- a/www/pecl-twig/Makefile
+++ b/www/pecl-twig/Makefile
@@ -17,5 +17,6 @@ USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
USES= tar:tgz
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/www/pecl-yaf/Makefile b/www/pecl-yaf/Makefile
index e02fbfe7c796..ec88a200aff6 100644
--- a/www/pecl-yaf/Makefile
+++ b/www/pecl-yaf/Makefile
@@ -23,5 +23,6 @@ PHP_MODNAME= ${PORTNAME:tl}
USE_PHP= yes
USE_PHPEXT= yes
USE_PHPIZE= yes
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/www/pecl-yar/Makefile b/www/pecl-yar/Makefile
index 6bb059ea524d..865e6738e7d5 100644
--- a/www/pecl-yar/Makefile
+++ b/www/pecl-yar/Makefile
@@ -19,6 +19,7 @@ USE_PHP= json curl
USE_PHPEXT= yes
USE_PHPIZE= yes
USE_PHP_BUILD= yes
+IGNORE_WITH_PHP= 70
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --with-php-config=${PREFIX}/bin/php-config