aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2015-08-24 06:57:56 +0800
committerkuriyama <kuriyama@FreeBSD.org>2015-08-24 06:57:56 +0800
commit08141d647a0dc6de03846f2eca8e28906b25527f (patch)
treeec7270773aa46e9df4a3343cdee236f8b05052e9 /www
parenta21dd83483814d8cd786f697c40a206a310629d6 (diff)
downloadfreebsd-ports-gnome-08141d647a0dc6de03846f2eca8e28906b25527f.tar.gz
freebsd-ports-gnome-08141d647a0dc6de03846f2eca8e28906b25527f.tar.zst
freebsd-ports-gnome-08141d647a0dc6de03846f2eca8e28906b25527f.zip
LWP tracing and debugging.
WWW: http://search.cpan.org/dist/LWP-ConsoleLogger/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-LWP-ConsoleLogger/Makefile40
-rw-r--r--www/p5-LWP-ConsoleLogger/distinfo2
-rw-r--r--www/p5-LWP-ConsoleLogger/pkg-descr3
-rw-r--r--www/p5-LWP-ConsoleLogger/pkg-plist4
5 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a13232d62e4b..6b655d72490d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1046,6 +1046,7 @@
SUBDIR += p5-LWP-Authen-OAuth
SUBDIR += p5-LWP-Authen-Wsse
SUBDIR += p5-LWP-ConnCache-MaxKeepAliveRequests
+ SUBDIR += p5-LWP-ConsoleLogger
SUBDIR += p5-LWP-MediaTypes
SUBDIR += p5-LWP-Online
SUBDIR += p5-LWP-Protocol-PSGI
diff --git a/www/p5-LWP-ConsoleLogger/Makefile b/www/p5-LWP-ConsoleLogger/Makefile
new file mode 100644
index 000000000000..ff74166c3e5e
--- /dev/null
+++ b/www/p5-LWP-ConsoleLogger/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= LWP-ConsoleLogger
+PORTVERSION= 0.000020
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for LWP tracing and debugging
+
+LICENSE= ART20
+
+RUN_DEPENDS= \
+ p5-Data-Printer>0:${PORTSDIR}/devel/p5-Data-Printer \
+ p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime \
+ p5-HTML-Restrict>=0:${PORTSDIR}/www/p5-HTML-Restrict \
+ p5-HTTP-Body>0:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-HTTP-CookieMonster>=0:${PORTSDIR}/www/p5-HTTP-CookieMonster \
+ p5-JSON-MaybeXS>0:${PORTSDIR}/converters/p5-JSON-MaybeXS \
+ p5-Log-Dispatch>0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Moo>0:${PORTSDIR}/devel/p5-Moo \
+ p5-MooX-StrictConstructor>0:${PORTSDIR}/devel/p5-MooX-StrictConstructor \
+ p5-Parse-MIME>=0:${PORTSDIR}/mail/p5-Parse-MIME \
+ p5-String-Trim>=0:${PORTSDIR}/textproc/p5-String-Trim \
+ p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-Term-Size-Any>0:${PORTSDIR}/devel/p5-Term-Size-Any \
+ p5-Text-SimpleTable-AutoWidth>=0.09:${PORTSDIR}/textproc/p5-Text-SimpleTable-AutoWidth \
+ p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-Type-Tiny>0:${PORTSDIR}/devel/p5-Type-Tiny \
+ p5-URI-Query>0:${PORTSDIR}/net/p5-URI-Query \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH= YES
+
+.include <bsd.port.mk>
diff --git a/www/p5-LWP-ConsoleLogger/distinfo b/www/p5-LWP-ConsoleLogger/distinfo
new file mode 100644
index 000000000000..eb0d1d56cc63
--- /dev/null
+++ b/www/p5-LWP-ConsoleLogger/distinfo
@@ -0,0 +1,2 @@
+SHA256 (LWP-ConsoleLogger-0.000020.tar.gz) = 129eb12575982c1cd0deb5e58d73e6b2f1e63b752e72fa668f149a14230031e1
+SIZE (LWP-ConsoleLogger-0.000020.tar.gz) = 21841
diff --git a/www/p5-LWP-ConsoleLogger/pkg-descr b/www/p5-LWP-ConsoleLogger/pkg-descr
new file mode 100644
index 000000000000..62fd59eb8d8b
--- /dev/null
+++ b/www/p5-LWP-ConsoleLogger/pkg-descr
@@ -0,0 +1,3 @@
+LWP tracing and debugging.
+
+WWW: http://search.cpan.org/dist/LWP-ConsoleLogger/
diff --git a/www/p5-LWP-ConsoleLogger/pkg-plist b/www/p5-LWP-ConsoleLogger/pkg-plist
new file mode 100644
index 000000000000..5f04defece60
--- /dev/null
+++ b/www/p5-LWP-ConsoleLogger/pkg-plist
@@ -0,0 +1,4 @@
+%%PERL5_MAN3%%/LWP::ConsoleLogger.3.gz
+%%PERL5_MAN3%%/LWP::ConsoleLogger::Easy.3.gz
+%%SITE_PERL%%/LWP/ConsoleLogger.pm
+%%SITE_PERL%%/LWP/ConsoleLogger/Easy.pm