aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortmseck <tmseck@FreeBSD.org>2013-08-05 03:40:27 +0800
committertmseck <tmseck@FreeBSD.org>2013-08-05 03:40:27 +0800
commit086ab0eb5e03092cd597b2f342a64e35b67a082c (patch)
tree60993ce9186d47e891cdc61fd02a7009891b6f16 /www
parentf59372fa9d793cc3770e4685be081e87d45772c0 (diff)
downloadfreebsd-ports-gnome-086ab0eb5e03092cd597b2f342a64e35b67a082c.tar.gz
freebsd-ports-gnome-086ab0eb5e03092cd597b2f342a64e35b67a082c.tar.zst
freebsd-ports-gnome-086ab0eb5e03092cd597b2f342a64e35b67a082c.zip
- Update rc script to fix squid_fib handling [1]
- Add patchsets 12594-12601 from upstream Approved by: crees (mentor) Obtained from: kib [1], hrs [1]
Diffstat (limited to 'www')
-rw-r--r--www/squid33/Makefile9
-rw-r--r--www/squid33/distinfo16
-rw-r--r--www/squid33/files/squid.in63
3 files changed, 61 insertions, 27 deletions
diff --git a/www/squid33/Makefile b/www/squid33/Makefile
index 8656cb5f8ad8..e3013aad8122 100644
--- a/www/squid33/Makefile
+++ b/www/squid33/Makefile
@@ -39,6 +39,7 @@
PORTNAME= squid
PORTVERSION= 3.3.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://mirrors.ccs.neu.edu/Squid/ \
@@ -67,6 +68,14 @@ PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www1.jp.squid-cache.org/%SUBDIR%/ \
http://www2.tw.squid-cache.org/%SUBDIR%/
PATCH_SITE_SUBDIR= Versions/v3/${PORTVERSION:R}/changesets
+PATCHFILES= squid-3.3-12594.patch \
+ squid-3.3-12595.patch \
+ squid-3.3-12596.patch \
+ squid-3.3-12597.patch \
+ squid-3.3-12598.patch \
+ squid-3.3-12599.patch \
+ squid-3.3-12600.patch \
+ squid-3.3-12601.patch
MAINTAINER= tmseck@FreeBSD.org
COMMENT= HTTP Caching Proxy
diff --git a/www/squid33/distinfo b/www/squid33/distinfo
index 1e3c278bb090..7ddc637d14b0 100644
--- a/www/squid33/distinfo
+++ b/www/squid33/distinfo
@@ -1,2 +1,18 @@
SHA256 (squid3.3/squid-3.3.8.tar.bz2) = 6411f344510e780f9e579851151278e1d02d8fe06a56abb1d97b1c53c61326a1
SIZE (squid3.3/squid-3.3.8.tar.bz2) = 2992708
+SHA256 (squid3.3/squid-3.3-12594.patch) = 1279f40a7112349ad9a15d4e36fa37cf45281b163cb755c48fac7c8b1e194d36
+SIZE (squid3.3/squid-3.3-12594.patch) = 1460
+SHA256 (squid3.3/squid-3.3-12595.patch) = 0fb56c7f6a6d0418cc7c2e6cab65c16d3e7907e29d54bd1405842bea72b1cb7c
+SIZE (squid3.3/squid-3.3-12595.patch) = 1357
+SHA256 (squid3.3/squid-3.3-12596.patch) = a3f8ead6ef488fc128f0335922b66d704918e681c610deaf69f045d6b7647c10
+SIZE (squid3.3/squid-3.3-12596.patch) = 2012
+SHA256 (squid3.3/squid-3.3-12597.patch) = 2a601f8f2c78e5109f0510261319da3449f528cdc2d89de2b4d590ace866b452
+SIZE (squid3.3/squid-3.3-12597.patch) = 6390
+SHA256 (squid3.3/squid-3.3-12598.patch) = fc6119be8240b237b9d56ec9540c57ee975045d3e989669a50619c92b1c532fa
+SIZE (squid3.3/squid-3.3-12598.patch) = 1753
+SHA256 (squid3.3/squid-3.3-12599.patch) = 99033e54ea190f9f58c5854a95b1d79760d7108432196c729d04788ed7ae0ed9
+SIZE (squid3.3/squid-3.3-12599.patch) = 2067
+SHA256 (squid3.3/squid-3.3-12600.patch) = 771d1fb0e409cbc028922b7cc3b43fceeebcbfea015afb7589141cf1d3c51f18
+SIZE (squid3.3/squid-3.3-12600.patch) = 1477
+SHA256 (squid3.3/squid-3.3-12601.patch) = 31174b5b24700b3ed11086197d8a2290b583522b8fdabcff6b26804c8be8be94
+SIZE (squid3.3/squid-3.3-12601.patch) = 1630
diff --git a/www/squid33/files/squid.in b/www/squid33/files/squid.in
index 1976474cfc7b..45b262dc31dd 100644
--- a/www/squid33/files/squid.in
+++ b/www/squid33/files/squid.in
@@ -45,38 +45,37 @@
name=squid
rcvar=squid_enable
-load_rc_config ${name}
-
-: ${squid_chdir:=/var/squid}
-: ${squid_conf:=%%PREFIX%%/etc/squid/squid.conf}
-: ${squid_enable:=NO}
-: ${squid_pidfile:=/var/run/squid/squid.pid}
-: ${squid_user:=squid}
-
-squid_command="%%PREFIX%%/sbin/squid"
-
# Make sure that we invoke squid with "-f ${squid_conf}"; define this
# variable early so reload_cmd and stop_precmd pick it up:
-required_args="-f ${squid_conf}"
extra_commands=reload
-reload_cmd="${squid_command} ${required_args} ${squid_flags} -k reconfigure"
+reload_cmd=squid_reload
start_precmd=squid_prestart
-start_cmd="${squid_command} ${required_args} ${squid_flags}"
start_postcmd=squid_getpid
-stop_precmd="${squid_command} ${required_args} ${squid_flags} -k check 2>/dev/null"
-stop_cmd=squid_stop
-
-pidfile=${squid_pidfile}
-procname="?squid-*"
-required_dirs=${squid_chdir}
-state_dir=/var/run/squid
+stop_precmd=squid_prestop
+stop_postcmd=squid_poststop
# squid(8) will not start if ${squid_conf} is not present so try
# to catch that beforehand via ${required_files} rather than make
# squid(8) crash.
-required_files=${squid_conf}
+squid_load_rc_config()
+{
+ : ${squid_chdir:=/var/squid}
+ : ${squid_conf:=%%PREFIX%%/etc/squid/squid.conf}
+ : ${squid_enable:=NO}
+ : ${squid_program:=%%PREFIX%%/sbin/squid}
+ : ${squid_pidfile:=/var/run/squid/squid.pid}
+ : ${squid_user:=squid}
+
+ required_args="-f ${squid_conf}"
+ required_dirs=$chdir
+ required_files=$squid_conf
+ command_args="${required_args} ${squid_flags}"
+ procname="?squid-*"
+ pidfile=$squid_pidfile
+ state_dir=/var/run/squid
+}
squid_prestart()
{
@@ -93,12 +92,18 @@ squid_prestart()
squid_fib=${squid_fib:-"NONE"}
if [ "${squid_fib}" != "NONE" ]; then
- start_cmd="setfib -F ${squid_fib} ${squid_command} ${required_args} ${squid_flags}"
+ command="setfib -F $squid_fib $command"
else
return 0
fi
}
+squid_reload()
+{
+
+ $command $required_args $squid_flags -k reconfigure
+}
+
squid_getpid()
{
# retrieve the PID of the Squid master process explicitly here
@@ -114,13 +119,17 @@ squid_getpid()
fi
}
-squid_stop()
+squid_prestop()
+{
+ command_args="$command_args -k shutdown"
+ $command $required_args $squid_flags -k check 2>/dev/null
+}
+
+squid_poststop()
{
- squid_getpid
- echo "Stopping ${name}."
- ${squid_command} ${required_args} ${squid_flags} -k shutdown
- run_rc_command poll
rm -rf ${state_dir}
}
+load_rc_config $name
+squid_load_rc_config
run_rc_command $1