aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-09-01 05:59:13 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-09-01 05:59:13 +0800
commit089fa0a2b7c254694cc59bb868216fb617f74cb4 (patch)
tree7aa1bd220f83c66097c8a5c9a85363c927302fac /www
parent91afa8662e7ac46ea8f6cbbfc1639ef164c4444b (diff)
downloadfreebsd-ports-gnome-089fa0a2b7c254694cc59bb868216fb617f74cb4.tar.gz
freebsd-ports-gnome-089fa0a2b7c254694cc59bb868216fb617f74cb4.tar.zst
freebsd-ports-gnome-089fa0a2b7c254694cc59bb868216fb617f74cb4.zip
Update version requirement of RUN_DEPENDS
- Update pkg-descr
Diffstat (limited to 'www')
-rw-r--r--www/rubygem-actionpack50/Makefile6
-rw-r--r--www/rubygem-actionpack50/pkg-descr27
2 files changed, 22 insertions, 11 deletions
diff --git a/www/rubygem-actionpack50/Makefile b/www/rubygem-actionpack50/Makefile
index 57057435fb03..9466fffa8fba 100644
--- a/www/rubygem-actionpack50/Makefile
+++ b/www/rubygem-actionpack50/Makefile
@@ -16,10 +16,10 @@ LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
RUN_DEPENDS= rubygem-actionview50>=${PORTVERSION}:devel/rubygem-actionview50 \
rubygem-activesupport50>=${PORTVERSION}:devel/rubygem-activesupport50 \
- rubygem-rack>=2.0:www/rubygem-rack \
+ rubygem-rack>=2.0,3<3,3:www/rubygem-rack \
rubygem-rack-test>=0.6.3:www/rubygem-rack-test \
- rubygem-rails-dom-testing-rails50>=2.0:textproc/rubygem-rails-dom-testing-rails50 \
- rubygem-rails-html-sanitizer>=1.0.2:textproc/rubygem-rails-html-sanitizer
+ rubygem-rails-dom-testing-rails50>=2.0<3:textproc/rubygem-rails-dom-testing-rails50 \
+ rubygem-rails-html-sanitizer>=1.0.2<2:textproc/rubygem-rails-html-sanitizer
USES= gem
USE_RUBY= yes
diff --git a/www/rubygem-actionpack50/pkg-descr b/www/rubygem-actionpack50/pkg-descr
index 8c1a1f7feac7..f424cc62f012 100644
--- a/www/rubygem-actionpack50/pkg-descr
+++ b/www/rubygem-actionpack50/pkg-descr
@@ -1,12 +1,23 @@
-Action Pack
+Action Pack is a framework for handling and responding to web requests. It
+provides mechanisms for routing (mapping request URLs to actions), defining
+controllers that implement actions, and generating responses by rendering views,
+which are templates of various formats. In short, Action Pack provides the view
+and controller layers in the MVC paradigm.
-The controller and view of the RubyOnRails MVC-Framework is handled
-by the Action Pack, which handles both layers by its two parts:
-Action View and Action Controller. These two layers are bundled
-in a single package due to their heavy interdependence. This is unlike
-the relationship between the Active Record and Action Pack that is
-much more separate.
+It consists of several modules:
+- Action Dispatch, which parses information about the web request, handles
+ routing as defined by the user, and does advanced processing related to HTTP
+ such as MIME-type negotiation, decoding parameters in POST, PATCH, or PUT
+ bodies, handling HTTP caching logic, cookies and sessions.
+- Action Controller, which provides a base controller class that can be
+ subclassed to implement filters and actions to handle requests. The result of
+ an action is typically content generated from views.
-Each of these packages can be used independently outside of Rails.
+With the Ruby on Rails framework, users only directly interface with the Action
+Controller module. Necessary Action Dispatch functionality is activated by
+default and Action View rendering is implicitly triggered by Action Controller.
+However, these modules are designed to function on their own and can be used
+outside of Rails.
WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/actionpack