aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-06-27 20:54:11 +0800
committerolgeni <olgeni@FreeBSD.org>2015-06-27 20:54:11 +0800
commit099bcd87401dc59b42fe814c1e7701fe95242f03 (patch)
tree7d61b3e1ed0576b122e72f1a7f9244ea99379aba /www
parent2b760f8d8b19c5aa1a076e10629d275bfeab0425 (diff)
downloadfreebsd-ports-gnome-099bcd87401dc59b42fe814c1e7701fe95242f03.tar.gz
freebsd-ports-gnome-099bcd87401dc59b42fe814c1e7701fe95242f03.tar.zst
freebsd-ports-gnome-099bcd87401dc59b42fe814c1e7701fe95242f03.zip
Sorting out some Erlang stuff:
- Rename a few Erlang-related ports using the erlang- prefix; it will avoid confusion with elixir- ports. - Remove DOCS and EXAMPLES where not actually useful. - Simplify RUN_DEPENDS where possible. - Move textproc/exmpp to devel/erlang-exmpp. - Add missing R18 compatibility fix for devel/erlang-oserl. - Upgrade erlang-cuttlefish to 2.0.3. The idea is that libraries ("deps") have the "erlang-" prefix, while larger projects (rabbitmq, yaws, couchdb, etc) keep their usual names.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile8
-rw-r--r--www/erlang-cowboy/Makefile (renamed from www/cowboy/Makefile)7
-rw-r--r--www/erlang-cowboy/distinfo (renamed from www/cowboy/distinfo)0
-rw-r--r--www/erlang-cowboy/files/patch-Makefile (renamed from www/cowboy/files/patch-Makefile)0
-rw-r--r--www/erlang-cowboy/pkg-descr (renamed from www/cowboy/pkg-descr)0
-rw-r--r--www/erlang-cowboy/pkg-plist (renamed from www/cowboy/pkg-plist)0
-rw-r--r--www/erlang-mochiweb-basho/Makefile (renamed from www/mochiweb-basho/Makefile)7
-rw-r--r--www/erlang-mochiweb-basho/distinfo (renamed from www/mochiweb-basho/distinfo)0
-rw-r--r--www/erlang-mochiweb-basho/pkg-descr (renamed from www/mochiweb-basho/pkg-descr)0
-rw-r--r--www/erlang-mochiweb-basho/pkg-plist (renamed from www/mochiweb-basho/pkg-plist)0
-rw-r--r--www/erlang-mochiweb/Makefile (renamed from www/mochiweb/Makefile)7
-rw-r--r--www/erlang-mochiweb/distinfo (renamed from www/mochiweb/distinfo)0
-rw-r--r--www/erlang-mochiweb/pkg-descr (renamed from www/mochiweb/pkg-descr)0
-rw-r--r--www/erlang-mochiweb/pkg-plist (renamed from www/mochiweb/pkg-plist)0
-rw-r--r--www/erlang-webmachine/Makefile (renamed from www/webmachine/Makefile)9
-rw-r--r--www/erlang-webmachine/distinfo (renamed from www/webmachine/distinfo)0
-rw-r--r--www/erlang-webmachine/files/patch-Makefile (renamed from www/webmachine/files/patch-Makefile)0
-rw-r--r--www/erlang-webmachine/files/patch-rebar.config (renamed from www/webmachine/files/patch-rebar.config)0
-rw-r--r--www/erlang-webmachine/pkg-descr (renamed from www/webmachine/pkg-descr)0
-rw-r--r--www/erlang-webmachine/pkg-plist (renamed from www/webmachine/pkg-plist)0
20 files changed, 12 insertions, 26 deletions
diff --git a/www/Makefile b/www/Makefile
index 8ab3af52f7b0..e4bde93dc945 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -94,7 +94,6 @@
SUBDIR += cocoon
SUBDIR += codeigniter
SUBDIR += coppermine
- SUBDIR += cowboy
SUBDIR += cplanet
SUBDIR += cppcms
SUBDIR += crawl
@@ -167,6 +166,10 @@
SUBDIR += entrans
SUBDIR += ephemera
SUBDIR += epiphany
+ SUBDIR += erlang-cowboy
+ SUBDIR += erlang-mochiweb
+ SUBDIR += erlang-mochiweb-basho
+ SUBDIR += erlang-webmachine
SUBDIR += erwn
SUBDIR += eventum
SUBDIR += extjs
@@ -417,8 +420,6 @@
SUBDIR += mkapachepw
SUBDIR += mknmz-wwwoffle
SUBDIR += mnogosearch
- SUBDIR += mochiweb
- SUBDIR += mochiweb-basho
SUBDIR += mod_amazon_proxy
SUBDIR += mod_antiloris
SUBDIR += mod_asn
@@ -2196,7 +2197,6 @@
SUBDIR += webkit2-gtk3
SUBDIR += weblint
SUBDIR += weblint++
- SUBDIR += webmachine
SUBDIR += webpy
SUBDIR += webreport
SUBDIR += webresolve
diff --git a/www/cowboy/Makefile b/www/erlang-cowboy/Makefile
index e547887c62f0..7389c3aed28d 100644
--- a/www/cowboy/Makefile
+++ b/www/erlang-cowboy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cowboy
PORTVERSION= 1.0.1
CATEGORIES= www
+PKGNAMEPREFIX= erlang-
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Small, fast and modular HTTP server written in Erlang
@@ -10,10 +11,10 @@ COMMENT= Small, fast and modular HTTP server written in Erlang
LICENSE= ISCL
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
- cowlib>=1.0.0:${PORTSDIR}/devel/cowlib
+ erlang-cowlib>=1.0.0:${PORTSDIR}/devel/erlang-cowlib
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
- cowlib>=1.0.0:${PORTSDIR}/devel/cowlib \
- ranch>=1.0.0:${PORTSDIR}/net/ranch
+ erlang-cowlib>=1.0.0:${PORTSDIR}/devel/erlang-cowlib \
+ erlang-ranch>=1.0.0:${PORTSDIR}/net/erlang-ranch
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/www/cowboy/distinfo b/www/erlang-cowboy/distinfo
index 2804a6522755..2804a6522755 100644
--- a/www/cowboy/distinfo
+++ b/www/erlang-cowboy/distinfo
diff --git a/www/cowboy/files/patch-Makefile b/www/erlang-cowboy/files/patch-Makefile
index 4cef4226c791..4cef4226c791 100644
--- a/www/cowboy/files/patch-Makefile
+++ b/www/erlang-cowboy/files/patch-Makefile
diff --git a/www/cowboy/pkg-descr b/www/erlang-cowboy/pkg-descr
index 927858cc6268..927858cc6268 100644
--- a/www/cowboy/pkg-descr
+++ b/www/erlang-cowboy/pkg-descr
diff --git a/www/cowboy/pkg-plist b/www/erlang-cowboy/pkg-plist
index bc6bdb062817..bc6bdb062817 100644
--- a/www/cowboy/pkg-plist
+++ b/www/erlang-cowboy/pkg-plist
diff --git a/www/mochiweb-basho/Makefile b/www/erlang-mochiweb-basho/Makefile
index 70f448669a6e..b58188677c31 100644
--- a/www/mochiweb-basho/Makefile
+++ b/www/erlang-mochiweb-basho/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mochiweb
PORTVERSION= 2.9.0p1
CATEGORIES= www devel
+PKGNAMEPREFIX= erlang-
PKGNAMESUFFIX= -basho
MAINTAINER= olgeni@FreeBSD.org
@@ -21,19 +22,13 @@ USE_GITHUB= yes
GH_ACCOUNT= basho
GH_TAGNAME= ade2a9b # required
-.include <bsd.port.options.mk>
-
do-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
for FILE in CHANGES.md README.md; do \
${INSTALL_DATA} ${WRKSRC}/$${FILE} ${STAGEDIR}${DOCSDIR}; \
done
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
-.endif
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
diff --git a/www/mochiweb-basho/distinfo b/www/erlang-mochiweb-basho/distinfo
index 0b1fbab89d22..0b1fbab89d22 100644
--- a/www/mochiweb-basho/distinfo
+++ b/www/erlang-mochiweb-basho/distinfo
diff --git a/www/mochiweb-basho/pkg-descr b/www/erlang-mochiweb-basho/pkg-descr
index 6143fd5821e6..6143fd5821e6 100644
--- a/www/mochiweb-basho/pkg-descr
+++ b/www/erlang-mochiweb-basho/pkg-descr
diff --git a/www/mochiweb-basho/pkg-plist b/www/erlang-mochiweb-basho/pkg-plist
index 3a7eb6b8f5ac..3a7eb6b8f5ac 100644
--- a/www/mochiweb-basho/pkg-plist
+++ b/www/erlang-mochiweb-basho/pkg-plist
diff --git a/www/mochiweb/Makefile b/www/erlang-mochiweb/Makefile
index 9b467e7b44a7..6b9117b22f3d 100644
--- a/www/mochiweb/Makefile
+++ b/www/erlang-mochiweb/Makefile
@@ -4,6 +4,7 @@ PORTNAME= mochiweb
PORTVERSION= 2.12.2
DISTVERSIONPREFIX= v
CATEGORIES= www devel
+PKGNAMEPREFIX= erlang-
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Erlang library for building lightweight HTTP servers
@@ -23,19 +24,13 @@ PLIST_SUB= VERSION="${PORTVERSION}"
USE_GITHUB= yes
GH_ACCOUNT= mochi
-.include <bsd.port.options.mk>
-
do-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
for FILE in CHANGES.md README; do \
${INSTALL_DATA} ${WRKSRC}/$${FILE} ${STAGEDIR}${DOCSDIR}; \
done
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
-.endif
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
diff --git a/www/mochiweb/distinfo b/www/erlang-mochiweb/distinfo
index 7213a33822e9..7213a33822e9 100644
--- a/www/mochiweb/distinfo
+++ b/www/erlang-mochiweb/distinfo
diff --git a/www/mochiweb/pkg-descr b/www/erlang-mochiweb/pkg-descr
index 5323a5663f62..5323a5663f62 100644
--- a/www/mochiweb/pkg-descr
+++ b/www/erlang-mochiweb/pkg-descr
diff --git a/www/mochiweb/pkg-plist b/www/erlang-mochiweb/pkg-plist
index 19dc5154a621..19dc5154a621 100644
--- a/www/mochiweb/pkg-plist
+++ b/www/erlang-mochiweb/pkg-plist
diff --git a/www/webmachine/Makefile b/www/erlang-webmachine/Makefile
index ef3ba062b8b2..5b806286fa54 100644
--- a/www/webmachine/Makefile
+++ b/www/erlang-webmachine/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webmachine
PORTVERSION= 1.10.8
CATEGORIES= www devel
+PKGNAMEPREFIX= erlang-
MAINTAINER= olgeni@FreeBSD.org
COMMENT= HTTP semantic awareness on top mochiweb
@@ -10,7 +11,7 @@ COMMENT= HTTP semantic awareness on top mochiweb
LICENSE= APACHE20
BUILD_DEPENDS= erl:${PORTSDIR}/lang/erlang \
- mochiweb-basho>=2.9.0p1:${PORTSDIR}/www/mochiweb-basho
+ erlang-mochiweb-basho>=2.9.0p1:${PORTSDIR}/www/erlang-mochiweb-basho
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= VERSION="${PORTVERSION}"
@@ -19,24 +20,18 @@ USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= basho
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e "s/{vsn, git}/{vsn,\"${PORTVERSION}\"}/" ${WRKSRC}/src/webmachine.app.src
@${RM} ${WRKSRC}/src/*.bak
@${RM} ${WRKSRC}/demo/priv/www/uploads/.gitignore
do-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
for FILE in README.org; do \
${INSTALL_DATA} ${WRKSRC}/$${FILE} ${STAGEDIR}${DOCSDIR}; \
done
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/demo && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
-.endif
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
diff --git a/www/webmachine/distinfo b/www/erlang-webmachine/distinfo
index ad8f28c01c71..ad8f28c01c71 100644
--- a/www/webmachine/distinfo
+++ b/www/erlang-webmachine/distinfo
diff --git a/www/webmachine/files/patch-Makefile b/www/erlang-webmachine/files/patch-Makefile
index 009e42c69809..009e42c69809 100644
--- a/www/webmachine/files/patch-Makefile
+++ b/www/erlang-webmachine/files/patch-Makefile
diff --git a/www/webmachine/files/patch-rebar.config b/www/erlang-webmachine/files/patch-rebar.config
index 685fc7dd2520..685fc7dd2520 100644
--- a/www/webmachine/files/patch-rebar.config
+++ b/www/erlang-webmachine/files/patch-rebar.config
diff --git a/www/webmachine/pkg-descr b/www/erlang-webmachine/pkg-descr
index e9c2819609fd..e9c2819609fd 100644
--- a/www/webmachine/pkg-descr
+++ b/www/erlang-webmachine/pkg-descr
diff --git a/www/webmachine/pkg-plist b/www/erlang-webmachine/pkg-plist
index e561a741dd72..e561a741dd72 100644
--- a/www/webmachine/pkg-plist
+++ b/www/erlang-webmachine/pkg-plist