aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-10-01 21:58:11 +0800
committerjhale <jhale@FreeBSD.org>2014-10-01 21:58:11 +0800
commit09f1ddbd3c65dfb2e62100dac6a096b6010144de (patch)
tree40f3d1f7c137b3124955fc82bc4d5a010276522b /www
parent04ce358bd2a8660f9c0d6e69137003af3f1df9b2 (diff)
downloadfreebsd-ports-gnome-09f1ddbd3c65dfb2e62100dac6a096b6010144de.tar.gz
freebsd-ports-gnome-09f1ddbd3c65dfb2e62100dac6a096b6010144de.tar.zst
freebsd-ports-gnome-09f1ddbd3c65dfb2e62100dac6a096b6010144de.zip
- Update to 2014.09.29.2 [1][2]
PR: 193562 [1], 193713 [2] (based on) Submitted by: <neel@neelc.org> [1], <never@nevermind.kiev.ua> [2] Approved by: araujo (maintainer timeout, 3 weeks)
Diffstat (limited to 'www')
-rw-r--r--www/youtube_dl/Makefile5
-rw-r--r--www/youtube_dl/distinfo4
-rw-r--r--www/youtube_dl/files/patch-Makefile12
-rw-r--r--www/youtube_dl/files/patch-youtube_dl____init__.py24
-rw-r--r--www/youtube_dl/files/patch-youtube_dl__options.py11
5 files changed, 28 insertions, 28 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index fc716d11ffd4..e3890aa2d69d 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= youtube_dl
-PORTVERSION= 2014.08.10
-PORTREVISION= 1
+PORTVERSION= 2014.09.29.2
CATEGORIES= www
MASTER_SITES= https://yt-dl.org/downloads/${PORTVERSION}/
DISTNAME= youtube-dl-${PORTVERSION}
@@ -44,7 +43,7 @@ post-extract:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/youtube-dl ${STAGEDIR}${PREFIX}/bin/youtube-dl
- ${INSTALL_DATA} ${WRKSRC}/youtube-dl.1 ${STAGEDIR}${PREFIX}/man/man1/
+ ${INSTALL_DATA} ${WRKSRC}/youtube-dl.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MBASH}
${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
${INSTALL_DATA} ${WRKSRC}/youtube-dl.bash-completion \
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
index e43267a9b973..44da9f3613d3 100644
--- a/www/youtube_dl/distinfo
+++ b/www/youtube_dl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (youtube-dl-2014.08.10.tar.gz) = a1131ff8aa636b6e99baf1b6226dab137500cd0a5cdeb4d76db102be4138caa9
-SIZE (youtube-dl-2014.08.10.tar.gz) = 931916
+SHA256 (youtube-dl-2014.09.29.2.tar.gz) = 4192ad648e21e8ab1a4e9b4fe130e47623834407737fd40a0197c61fe38b50f1
+SIZE (youtube-dl-2014.09.29.2.tar.gz) = 1072137
diff --git a/www/youtube_dl/files/patch-Makefile b/www/youtube_dl/files/patch-Makefile
index c384d05cca6b..f62e13876cb4 100644
--- a/www/youtube_dl/files/patch-Makefile
+++ b/www/youtube_dl/files/patch-Makefile
@@ -1,9 +1,9 @@
---- Makefile.orig 2013-10-17 06:55:06.000000000 +0800
-+++ Makefile 2013-10-26 18:28:59.588795031 +0800
+--- Makefile.orig 2014-09-14 14:48:07 UTC
++++ Makefile
@@ -10,17 +10,7 @@
- BINDIR=$(PREFIX)/bin
- MANDIR=$(PREFIX)/man
- PYTHON=/usr/bin/env python
+ BINDIR ?= $(PREFIX)/bin
+ MANDIR ?= $(PREFIX)/man
+ PYTHON ?= /usr/bin/env python
-
-# set SYSCONFDIR to /etc if PREFIX=/usr or PREFIX=/usr/local
-ifeq ($(PREFIX),/usr)
@@ -15,7 +15,7 @@
- SYSCONFDIR=$(PREFIX)/etc
- endif
-endif
-+SYSCONFDIR=/etc
++SYSCONFDIR ?= /etc
install: youtube-dl youtube-dl.1 youtube-dl.bash-completion
install -d $(DESTDIR)$(BINDIR)
diff --git a/www/youtube_dl/files/patch-youtube_dl____init__.py b/www/youtube_dl/files/patch-youtube_dl____init__.py
index 3682fe111d35..8797417a4558 100644
--- a/www/youtube_dl/files/patch-youtube_dl____init__.py
+++ b/www/youtube_dl/files/patch-youtube_dl____init__.py
@@ -1,6 +1,6 @@
---- youtube_dl/__init__.py.orig 2014-07-29 23:18:51.000000000 +0800
-+++ youtube_dl/__init__.py 2014-07-31 01:10:45.923443081 +0800
-@@ -97,7 +97,6 @@
+--- youtube_dl/__init__.py.orig 2014-09-27 21:51:19 UTC
++++ youtube_dl/__init__.py
+@@ -108,7 +108,6 @@
std_headers,
write_string,
)
@@ -8,18 +8,9 @@
from .downloader import (
FileDownloader,
)
-@@ -230,8 +229,6 @@
- action='help', help='print this help text and exit')
- general.add_option('-v', '--version',
- action='version', help='print program version and exit')
-- general.add_option('-U', '--update',
-- action='store_true', dest='update_self', help='update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
- general.add_option('-i', '--ignore-errors',
- action='store_true', dest='ignoreerrors', help='continue on download errors, for example to skip unavailable videos in a playlist', default=False)
- general.add_option('--abort-on-error',
-@@ -844,10 +841,6 @@
- ydl.add_post_processor(FFmpegAudioFixPP())
- ydl.add_post_processor(AtomicParsleyPP())
+@@ -399,17 +398,13 @@
+ ydl.add_post_processor(ExecAfterDownloadPP(
+ verboseOutput=opts.verbose, exec_cmd=opts.exec_cmd))
- # Update version
- if opts.update_self:
@@ -27,8 +18,7 @@
-
# Remove cache dir
if opts.rm_cachedir:
- if opts.cachedir is None:
-@@ -867,7 +860,7 @@
+ ydl.cache.remove()
# Maybe do nothing
if (len(all_urls) < 1) and (opts.load_info_filename is None):
diff --git a/www/youtube_dl/files/patch-youtube_dl__options.py b/www/youtube_dl/files/patch-youtube_dl__options.py
new file mode 100644
index 000000000000..c09c76974a4d
--- /dev/null
+++ b/www/youtube_dl/files/patch-youtube_dl__options.py
@@ -0,0 +1,11 @@
+--- youtube_dl/options.py.orig 2014-10-01 13:10:09 UTC
++++ youtube_dl/options.py
+@@ -127,8 +127,6 @@
+ action='help', help='print this help text and exit')
+ general.add_option('-v', '--version',
+ action='version', help='print program version and exit')
+- general.add_option('-U', '--update',
+- action='store_true', dest='update_self', help='update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
+ general.add_option('-i', '--ignore-errors',
+ action='store_true', dest='ignoreerrors', help='continue on download errors, for example to skip unavailable videos in a playlist', default=False)
+ general.add_option('--abort-on-error',