aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-12-16 02:31:09 +0800
committermnag <mnag@FreeBSD.org>2005-12-16 02:31:09 +0800
commit129451ae1a2d7a3d39ee23ab478bb5402d0f60e9 (patch)
treec2214df467da416b74523ccdff94507cbb2716e1 /www
parentf6c2625dffdc3d728d831d5c4fd6d07841e27c1d (diff)
downloadfreebsd-ports-gnome-129451ae1a2d7a3d39ee23ab478bb5402d0f60e9.tar.gz
freebsd-ports-gnome-129451ae1a2d7a3d39ee23ab478bb5402d0f60e9.tar.zst
freebsd-ports-gnome-129451ae1a2d7a3d39ee23ab478bb5402d0f60e9.zip
Correct way to check WITH_PHP4_OPT and ${PHP_VER} == 4
Diffstat (limited to 'www')
-rw-r--r--www/pecl-APC-devel/Makefile6
-rw-r--r--www/pecl-APC/Makefile6
2 files changed, 8 insertions, 4 deletions
diff --git a/www/pecl-APC-devel/Makefile b/www/pecl-APC-devel/Makefile
index c20e57522845..6101cae14856 100644
--- a/www/pecl-APC-devel/Makefile
+++ b/www/pecl-APC-devel/Makefile
@@ -42,7 +42,8 @@ CONFIGURE_ARGS+= --enable-apc-mmap
CONFIGURE_ARGS+= --enable-apc-sem
.endif
-.if defined(WITH_PHP4_OPT) && ${PHP_VER} == 4
+.if defined(WITH_PHP4_OPT)
+.if ${PHP_VER} == 4
.if exists(${LOCALBASE}/include/apache/httpd.h)
CFLAGS+= -I${LOCALBASE}/include/apache -DAPC_PHP4_STAT
.elif exists(${LOCALBASE}/include/apache2/httpd.h)
@@ -53,13 +54,14 @@ CFLAGS+= -I${LOCALBASE}/include/apache21 -DAPC_PHP4_STAT
CFLAGS+= -I${LOCALBASE}/include/apache22 -DAPC_PHP4_STAT
.endif
.else
-pre-extract:
+pre-configure:
@${ECHO_CMD}
@${ECHO_CMD} "*** WARNING ***"
@${ECHO_CMD} "This optimization is only for PHP4. PHP5 or newer does not need it"
@${ECHO_CMD} "I will continue instalation..."
@${ECHO_CMD}
.endif
+.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index c20e57522845..6101cae14856 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -42,7 +42,8 @@ CONFIGURE_ARGS+= --enable-apc-mmap
CONFIGURE_ARGS+= --enable-apc-sem
.endif
-.if defined(WITH_PHP4_OPT) && ${PHP_VER} == 4
+.if defined(WITH_PHP4_OPT)
+.if ${PHP_VER} == 4
.if exists(${LOCALBASE}/include/apache/httpd.h)
CFLAGS+= -I${LOCALBASE}/include/apache -DAPC_PHP4_STAT
.elif exists(${LOCALBASE}/include/apache2/httpd.h)
@@ -53,13 +54,14 @@ CFLAGS+= -I${LOCALBASE}/include/apache21 -DAPC_PHP4_STAT
CFLAGS+= -I${LOCALBASE}/include/apache22 -DAPC_PHP4_STAT
.endif
.else
-pre-extract:
+pre-configure:
@${ECHO_CMD}
@${ECHO_CMD} "*** WARNING ***"
@${ECHO_CMD} "This optimization is only for PHP4. PHP5 or newer does not need it"
@${ECHO_CMD} "I will continue instalation..."
@${ECHO_CMD}
.endif
+.endif
post-install:
.if !defined(NOPORTDOCS)