aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-04-29 09:40:25 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-04-29 09:40:25 +0800
commit12a8691c7dc685e40356c32c05073b83bcb74d30 (patch)
treead617263765511ab8e853ed494c6d2fdc46530b4 /www
parentea8a0c39ba80e1d0561e96d7d00085067754bca3 (diff)
downloadfreebsd-ports-gnome-12a8691c7dc685e40356c32c05073b83bcb74d30.tar.gz
freebsd-ports-gnome-12a8691c7dc685e40356c32c05073b83bcb74d30.tar.zst
freebsd-ports-gnome-12a8691c7dc685e40356c32c05073b83bcb74d30.zip
- USE_APACHE=yes is deprecated
- WITH_APACHE2 is deprecated - Convert to AP_FAST_BUILD/AP_GENPLIST (MODULE_NAME -> MODULENAME) - Use SUB_FILES for pkg-message - Wrap pkg-descr at 78 chars - Add WWW: to pkg-descr - Pet Portlint - Bump PORTREVISION PR: ports/133682 Approved by: maintainer timeout (2 weeks) Submitted by: me
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_mysql41_ap2/Makefile30
-rw-r--r--www/mod_auth_mysql41_ap2/files/pkg-message.in (renamed from www/mod_auth_mysql41_ap2/pkg-message)2
-rw-r--r--www/mod_auth_mysql41_ap2/pkg-descr10
-rw-r--r--www/mod_auth_mysql41_ap2/pkg-plist3
4 files changed, 25 insertions, 20 deletions
diff --git a/www/mod_auth_mysql41_ap2/Makefile b/www/mod_auth_mysql41_ap2/Makefile
index 97bec649d0f8..16f513f39169 100644
--- a/www/mod_auth_mysql41_ap2/Makefile
+++ b/www/mod_auth_mysql41_ap2/Makefile
@@ -7,33 +7,35 @@
PORTNAME= mod_auth_mysql41_ap2
PORTVERSION= 1.00
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.maske.org/pub/FreeBSD/distfiles/
DISTNAME= ${PORTNAME}_${PORTVERSION}
-DISTFILES= ${DISTNAME}.tar.gz
MAINTAINER= maske@maske.org
COMMENT= MySQL 4.1 and Apache 2 port of mod_auth_mysql
-USE_APACHE= YES
-WITH_APACHE2= YES
-
USE_MYSQL= YES
WANT_MYSQL_VER= 41
-MYSQL_INC?= ${LOCALBASE}/include/mysql
-MYSQL_LIB?= ${LOCALBASE}/lib/mysql -lmysqlclient
-MODULE_NAME= mod_auth_mysql
-PORTDOCS= README
+USE_APACHE= 2.0
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+
+AP_INC= ${LOCALBASE}/include/mysql
+AP_LIB= ${LOCALBASE}/lib/mysql -lmysqlclient
+AP_EXTRAS= -DAPACHE2
-do-build:
- @(cd ${WRKSRC} && ${APXS} -D APACHE2 -I ${MYSQL_INC} -L ${MYSQL_LIB} -c ${MODULE_NAME}.c)
+MODULENAME= mod_auth_mysql
+
+SUB_FILES+= pkg-message
+
+PORTDOCS= README
-do-install:
- @(cd ${WRKSRC} && ${APXS} -i -A -n ${MODULE_NAME:S/mod_//} ${MODULE_NAME}.la)
+post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/www/mod_auth_mysql41_ap2/pkg-message b/www/mod_auth_mysql41_ap2/files/pkg-message.in
index 0d443aee1001..907450c51f03 100644
--- a/www/mod_auth_mysql41_ap2/pkg-message
+++ b/www/mod_auth_mysql41_ap2/files/pkg-message.in
@@ -18,7 +18,7 @@ AuthMySQLUserTable YOURUSERTABLENAME
AuthMySQLNameField USERNAMEFIELD
AuthMySQLPasswordField PASSWORDFIELD
-For .htaccess options, view /usr/local/share/doc/mod_auth_mysql41_ap2/README
+For .htaccess options, view %%DOCSDIR%%/README
For more information visit http://www.maske.org
diff --git a/www/mod_auth_mysql41_ap2/pkg-descr b/www/mod_auth_mysql41_ap2/pkg-descr
index f4699abd8d9b..01875206ce3d 100644
--- a/www/mod_auth_mysql41_ap2/pkg-descr
+++ b/www/mod_auth_mysql41_ap2/pkg-descr
@@ -1,5 +1,11 @@
-mod_auth_mysql41_ap2 is an Apache module that allows authentication using user and group data stored in MySQL databases. Originally by Vivek Khera for Apache1, now also includes a version for Apache 2. This version has been modified from the version by Sam Brauer <sbrauer@users.sourceforge.net> at http://sourceforge.net/projects/modauthmysql to support MySQL 4.1 with Apache 2. Group Authentication has not been implemented yet.
+mod_auth_mysql41_ap2 is an Apache module that allows authentication using
+user and group data stored in MySQL databases. Originally by Vivek Khera
+for Apache1, now also includes a version for Apache 2. This version has
+been modified from the version by Sam Brauer
+<sbrauer@users.sourceforge.net> at
+http://sourceforge.net/projects/modauthmysql to support MySQL 4.1
+with Apache 2. Group Authentication has not been implemented yet.
Douglas A. Maske
maske@maske.org
-http://www.maske.org
+WWW: http://www.maske.org
diff --git a/www/mod_auth_mysql41_ap2/pkg-plist b/www/mod_auth_mysql41_ap2/pkg-plist
deleted file mode 100644
index 648d6e410b13..000000000000
--- a/www/mod_auth_mysql41_ap2/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-libexec/apache2/mod_auth_mysql.so
-@exec %D/sbin/apxs -e -a -n mysql_auth %D/%f
-@unexec %D/sbin/apxs -e -A -n mysql_auth %D/%f