aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-01-02 03:21:08 +0800
committerdanilo <danilo@FreeBSD.org>2014-01-02 03:21:08 +0800
commit12f9baaa57fd6d530bf744cf2a5b28df4cd23d2b (patch)
treebcce458ba94462c4b91fddfccbba90e44a36e5c1 /www
parent9804c278a56433227e13c3f3ee2e8d692ee335cf (diff)
downloadfreebsd-ports-gnome-12f9baaa57fd6d530bf744cf2a5b28df4cd23d2b.tar.gz
freebsd-ports-gnome-12f9baaa57fd6d530bf744cf2a5b28df4cd23d2b.tar.zst
freebsd-ports-gnome-12f9baaa57fd6d530bf744cf2a5b28df4cd23d2b.zip
- Update from 9.2 to 9.3.1 [1]
- Add stage support - Convert all "if's" in options helpers PR: ports/185254 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> (maintaier) [1]
Diffstat (limited to 'www')
-rw-r--r--www/hiawatha/Makefile116
-rw-r--r--www/hiawatha/distinfo4
-rw-r--r--www/hiawatha/pkg-plist9
3 files changed, 42 insertions, 87 deletions
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index 528bab5b2842..3bb191c26488 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hiawatha
-PORTVERSION= 9.2
+PORTVERSION= 9.3.1
CATEGORIES= www
MASTER_SITES= http://www.hiawatha-webserver.org/files/ \
http://www.c-s.li/ports/
@@ -16,8 +16,6 @@ PORTDOCS= ChangeLog README.md
CONFIG_FILES= hiawatha.conf mimetype.conf cgi-wrapper.conf toolkit.conf \
index.xslt
-MAN1= cgi-wrapper.1 hiawatha.1 ssi-cgi.1 wigwam.1
-
SUB_FILES= pkg-message
USES= cmake
USE_LDCONFIG= yes
@@ -34,17 +32,9 @@ CMAKE_ARGS+= -DCMAKE_INSTALL_BINDIR=${PREFIX}/bin \
-DLOG_DIR=/var/log/hiawatha \
-DPID_DIR=/var/run
-OPTIONS_DEFINE= CACHE \
- DOCS \
- IPV6 \
- MONITOR \
- RPROXY \
- SSL \
- TOMAHAWK \
- TOOLKIT \
- XSLT
+OPTIONS_DEFINE= CACHE DOCS IPV6 MONITOR RPROXY SSL TOMAHAWK TOOLKIT XSLT
-OPTIONS_DEFAULT=CACHE IPV6 RPROXY SSL TOOLKIT XSLT DOCS
+OPTIONS_DEFAULT= CACHE IPV6 RPROXY SSL TOOLKIT XSLT DOCS
CACHE_DESC= Enable cache support
MONITOR_DESC= Enable Hiawatha Monitor
@@ -53,61 +43,32 @@ TOMAHAWK_DESC= Enable Tomahawk command channel
TOOLKIT_DESC= Enable URL toolkit
XSLT_DESC= Enable XSLT support
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCACHE}
-CMAKE_ARGS+= -DENABLE_CACHE=on
-.else
-CMAKE_ARGS+= -DENABLE_CACHE=off
-.endif
-
-.if ${PORT_OPTIONS:MTOMAHAWK}
-CMAKE_ARGS+= -DENABLE_TOMAHAWK=on
-.else
-CMAKE_ARGS+= -DENABLE_TOMAHAWK=off
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-CMAKE_ARGS+= -DENABLE_IPV6=on
-.else
-CMAKE_ARGS+= -DENABLE_IPV6=off
-.endif
-
-.if ${PORT_OPTIONS:MMONITOR}
-CMAKE_ARGS+= -DENABLE_MONITOR=on
-.else
-CMAKE_ARGS+= -DENABLE_MONITOR=off
-.endif
-
-.if ${PORT_OPTIONS:MRPROXY}
-CMAKE_ARGS+= -DENABLE_RPROXY=on
-.else
-CMAKE_ARGS+= -DENABLE_RPROXY=off
-.endif
-
-.if ${PORT_OPTIONS:MSSL}
-CMAKE_ARGS+= -DENABLE_SSL=on
-.else
-CMAKE_ARGS+= -DENABLE_SSL=off
-.endif
-
-.if ${PORT_OPTIONS:MTOOLKIT}
-CMAKE_ARGS+= -DENABLE_TOOLKIT=on
-.else
-CMAKE_ARGS+= -DENABLE_TOOLKIT=off
-.endif
-
-.if ${PORT_OPTIONS:MXSLT}
-USE_GNOME+= libxslt
-CMAKE_ARGS+= -DENABLE_XSLT=on
-.else
-CMAKE_ARGS+= -DENABLE_XSLT=off
-.endif
+CACHE_CMAKE_ON= -DENABLE_CACHE=on
+CACHE_CMAKE_OFF= -DENABLE_CACHE=off
-PLIST_SUB+= ECHO_MSG=${ECHO_MSG}
+TOMAHAWK_CMAKE_ON= -DENABLE_TOMAHAWK=on
+TOMAHAWK_CMAKE_OFF= -DENABLE_TOMAHAWK=off
+
+IPV6_CMAKE_ON= -DENABLE_IPV6=on
+IPV6_CMAKE_OFF= -DENABLE_IPV6=off
+
+MONITOR_CMAKE_ON= -DENABLE_MONITOR=on
+MONITOR_CMAKE_OFF= -DENABLE_MONITOR=off
+
+RPROXY_CMAKE_ON= -DENABLE_RPROXY=on
+RPROXY_CMAKE_OFF= -DENABLE_RPROXY=off
-.include <bsd.port.pre.mk>
+SSL_CMAKE_ON= -DENABLE_SSL=on
+SSL_CMAKE_OFF= -DENABLE_SSL=off
+
+TOOLKIT_CMAKE_ON= -DENABLE_TOOLKIT=on
+TOOLKIT_CMAKE_OFF= -DENABLE_TOOLKIT=off
+
+XSLT_USE= GNOME=libxslt
+XSLT_CMAKE_ON= -DENABLE_XSLT=on
+XSLT_CMAKE_OFF= -DENABLE_XSLT=off
+
+PLIST_SUB+= ECHO_MSG=${ECHO_MSG}
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
@@ -118,25 +79,14 @@ post-patch:
${WRKSRC}/man/hiawatha.1.in ${WRKSRC}/man/cgi-wrapper.1.in
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.for FILE in ${CONFIG_FILES}
- @${INSTALL_DATA} ${WRKSRC}/config/${FILE} ${PREFIX}/etc/hiawatha/${FILE}.sample
- @if [ ! -f ${PREFIX}/etc/hiawatha/${FILE} ]; then \
- ${CP} -p ${WRKSRC}/config/${FILE} ${PREFIX}/etc/hiawatha/${FILE} ; \
- fi
+ @${INSTALL_DATA} ${WRKSRC}/config/${FILE} ${STAGEDIR}${PREFIX}/etc/hiawatha/${FILE}.sample
.endfor
- @if [ ! -d ${WWWDIR} ]; then \
- @${MKDIR} ${WWWDIR} ; \
- fi
- @${CP} ${WRKSRC}/extra/index.html ${WWWDIR}/index.hiawatha.html
- @if [ ! -f ${WWWDIR}/index.html ] ; then \
- ${CP} ${WRKSRC}/extra/index.html ${WWWDIR}/ ; \
- fi
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${WWWDIR} ; \
+ ${CP} ${WRKSRC}/extra/index.html ${STAGEDIR}${WWWDIR}/index.hiawatha.html
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/hiawatha/distinfo b/www/hiawatha/distinfo
index 62c1c81902a3..3933cf1ad555 100644
--- a/www/hiawatha/distinfo
+++ b/www/hiawatha/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hiawatha-9.2.tar.gz) = 5d9cdec51c618bb3efab747030e593d9bd49dfaf3236254c8e0cb60715716dbf
-SIZE (hiawatha-9.2.tar.gz) = 680564
+SHA256 (hiawatha-9.3.1.tar.gz) = 2fb5a7bf2004cb55511c3e165563e6b2119e863ec2cad773cbe79e75e3c0775a
+SIZE (hiawatha-9.3.1.tar.gz) = 793782
diff --git a/www/hiawatha/pkg-plist b/www/hiawatha/pkg-plist
index b99bd14a5f84..0706efaa6b98 100644
--- a/www/hiawatha/pkg-plist
+++ b/www/hiawatha/pkg-plist
@@ -2,6 +2,10 @@ bin/ssi-cgi
sbin/cgi-wrapper
sbin/hiawatha
sbin/wigwam
+man/man1/cgi-wrapper.1.gz
+man/man1/hiawatha.1.gz
+man/man1/ssi-cgi.1.gz
+man/man1/wigwam.1.gz
@unexec if cmp -s %D/etc/hiawatha/cgi-wrapper.conf.sample %D/etc/hiawatha/cgi-wrapper.conf ; then rm -f %D/etc/hiawatha/cgi-wrapper.conf; fi
%%ETCDIR%%/cgi-wrapper.conf.sample
@exec if [ ! -f %D/etc/hiawatha/cgi-wrapper.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/cgi-wrapper.conf; fi
@@ -18,12 +22,13 @@ sbin/wigwam
%%ETCDIR%%/toolkit.conf.sample
@exec if [ ! -f %D/etc/hiawatha/toolkit.conf.sample ] ; then cp -p %D/%F %%ETCDIR%%/toolkit.conf; fi
@unexec t=`/bin/ls %D/etc/hiawatha`; if [ -z "$t" ]; then %%ECHO_MSG%% "===> Configuration directory is empty, removing it."; rmdir %D/etc/hiawatha; fi;
+@exec if [ ! -d /var/log/hiawatha ] ; then mkdir /var/log/hiawatha ; fi
@unexec t=`/bin/ls /var/log/hiawatha`; if [ -z "$t" ]; then %%ECHO_MSG%% "===> Log directory is empty, removing it."; rmdir /var/log/hiawatha; fi;
@unexec if cmp -s %D/www/hiawatha/index.html %D/www/hiawatha/index.hiawatha.html ; then rm -f %D/www/hiawatha/index.html; fi
%%WWWDIR%%/index.hiawatha.html
@exec if [ ! -f %D/www/hiawatha/index.html ] ; then cp -p %D/%F %%WWWDIR%%/index.html; fi
@unexec t=`/bin/ls %D/www/hiawatha`; if [ -z "$t" ]; then %%ECHO_MSG%% "===> WWW directory is empty, removing it."; rmdir %D/www/hiawatha; fi;
lib/hiawatha/libpolarssl.so
-lib/hiawatha/libpolarssl.so.2
-lib/hiawatha/libpolarssl.so.1.2.8
+lib/hiawatha/libpolarssl.so.5
+lib/hiawatha/libpolarssl.so.1.3.2
@dirrm lib/hiawatha