aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-04-23 12:25:26 +0800
committervanilla <vanilla@FreeBSD.org>2001-04-23 12:25:26 +0800
commit1563f1a86260f0f786401c988a342804fc700751 (patch)
tree2eb996c116b6bbb98744de93ca2c7d8ddd3f8eda /www
parentf0bde28cbd12dbce14f4e10b79c5d304da933fcf (diff)
downloadfreebsd-ports-gnome-1563f1a86260f0f786401c988a342804fc700751.tar.gz
freebsd-ports-gnome-1563f1a86260f0f786401c988a342804fc700751.tar.zst
freebsd-ports-gnome-1563f1a86260f0f786401c988a342804fc700751.zip
Fix postgresql7's new layout & include file problem.
PR: ports/26755 Submitted by: Palle Girgensohn <girgen@partitur.se>
Diffstat (limited to 'www')
-rw-r--r--www/mod_php4/Makefile2
-rw-r--r--www/mod_php4/files/patch-pgsql10
-rw-r--r--www/mod_php4/scripts/configure.php11
-rw-r--r--www/mod_php5/Makefile2
-rw-r--r--www/mod_php5/files/patch-pgsql10
-rw-r--r--www/mod_php5/scripts/configure.php11
6 files changed, 40 insertions, 6 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 4b90f6599955..587afd607611 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.0.4pl1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php4/files/patch-pgsql b/www/mod_php4/files/patch-pgsql
new file mode 100644
index 000000000000..7d9ccaa04ce0
--- /dev/null
+++ b/www/mod_php4/files/patch-pgsql
@@ -0,0 +1,10 @@
+--- ext/pgsql/php_pgsql.h~ Wed Sep 13 06:13:36 2000
++++ ext/pgsql/php_pgsql.h Sat Apr 21 20:26:21 2001
+@@ -29,7 +29,6 @@
+
+ #ifdef PHP_PGSQL_PRIVATE
+ #undef SOCKET_SIZE_TYPE
+-#include <postgres.h>
+ #include <libpq-fe.h>
+
+ #ifdef PHP_WIN32
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 585fb91eee0e..1f731e1745f4 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -113,8 +113,15 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
- echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}"
- if /usr/bin/ldd ${PREFIX}/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
+ if [ -x ${PREFIX}/pgsql/bin/postgres -a ! -x ${PREFIX}/bin/postgres ]; then
+ PGPREFIX=${PREFIX}/pgsql
+ else
+ PGPREFIX=${PREFIX}
+ echo "CFLAGS+=-I\${PREFIX}/include/pgsql"
+ fi
+ echo "PGPREFIX=${PGPREFIX}"
+ echo "CONFIGURE_ARGS+=--with-pgsql=\${PGPREFIX}"
+ if /usr/bin/ldd ${PGPREFIX}/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
echo "USE_OPENSSL= yes"
LIBS="${LIBS} -L\${OPENSSLBASE}/lib -lcrypto -lssl"
fi
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 4b90f6599955..587afd607611 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.0.4pl1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php5/files/patch-pgsql b/www/mod_php5/files/patch-pgsql
new file mode 100644
index 000000000000..7d9ccaa04ce0
--- /dev/null
+++ b/www/mod_php5/files/patch-pgsql
@@ -0,0 +1,10 @@
+--- ext/pgsql/php_pgsql.h~ Wed Sep 13 06:13:36 2000
++++ ext/pgsql/php_pgsql.h Sat Apr 21 20:26:21 2001
+@@ -29,7 +29,6 @@
+
+ #ifdef PHP_PGSQL_PRIVATE
+ #undef SOCKET_SIZE_TYPE
+-#include <postgres.h>
+ #include <libpq-fe.h>
+
+ #ifdef PHP_WIN32
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 585fb91eee0e..1f731e1745f4 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -113,8 +113,15 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
- echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}"
- if /usr/bin/ldd ${PREFIX}/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
+ if [ -x ${PREFIX}/pgsql/bin/postgres -a ! -x ${PREFIX}/bin/postgres ]; then
+ PGPREFIX=${PREFIX}/pgsql
+ else
+ PGPREFIX=${PREFIX}
+ echo "CFLAGS+=-I\${PREFIX}/include/pgsql"
+ fi
+ echo "PGPREFIX=${PGPREFIX}"
+ echo "CONFIGURE_ARGS+=--with-pgsql=\${PGPREFIX}"
+ if /usr/bin/ldd ${PGPREFIX}/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
echo "USE_OPENSSL= yes"
LIBS="${LIBS} -L\${OPENSSLBASE}/lib -lcrypto -lssl"
fi