aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2014-03-28 00:09:37 +0800
committerale <ale@FreeBSD.org>2014-03-28 00:09:37 +0800
commit175a3f2444f87b998b1645d3ecd4b5cf41800b41 (patch)
tree6970182b052dcd21d44da9340f0a1e62db6af5fb /www
parent1bab394e6b3d2c0be04c4f895b2973d0d77d6c55 (diff)
downloadfreebsd-ports-gnome-175a3f2444f87b998b1645d3ecd4b5cf41800b41.tar.gz
freebsd-ports-gnome-175a3f2444f87b998b1645d3ecd4b5cf41800b41.tar.zst
freebsd-ports-gnome-175a3f2444f87b998b1645d3ecd4b5cf41800b41.zip
Welcome the new mod_php ports, in order to have default packages for
Apache PHP modules. Submitted by: marcus Reworked by: ale (me) Requested by: many, too many
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/mod_php5/Makefile15
-rw-r--r--www/mod_php55/Makefile15
3 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 600c9eefacb3..bf222f960c20 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -512,6 +512,8 @@
SUBDIR += mod_ntlm2
SUBDIR += mod_pagespeed
SUBDIR += mod_perl2
+ SUBDIR += mod_php5
+ SUBDIR += mod_php55
SUBDIR += mod_proctitle
SUBDIR += mod_proxy_html
SUBDIR += mod_proxy_uwsgi
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
new file mode 100644
index 000000000000..9df10828f554
--- /dev/null
+++ b/www/mod_php5/Makefile
@@ -0,0 +1,15 @@
+# Created by: marcus@FreeBSD.org
+# $FreeBSD$
+
+PKGNAMEPREFIX= mod_
+
+MAINTAINER= ale@FreeBSD.org
+
+PHP_PORT= lang/php5
+MASTERDIR= ${.CURDIR}/../../${PHP_PORT}
+
+OPTIONS_DEFINE= AP2FILTER
+AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+OPTIONS_EXCLUDE= CGI CLI FPM EMBED
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/mod_php55/Makefile b/www/mod_php55/Makefile
new file mode 100644
index 000000000000..b7c47f39c4e4
--- /dev/null
+++ b/www/mod_php55/Makefile
@@ -0,0 +1,15 @@
+# Created by: marcus@FreeBSD.org
+# $FreeBSD$
+
+PKGNAMEPREFIX= mod_
+
+MAINTAINER= ale@FreeBSD.org
+
+PHP_PORT= lang/php55
+MASTERDIR= ${.CURDIR}/../../${PHP_PORT}
+
+OPTIONS_DEFINE= AP2FILTER
+AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+OPTIONS_EXCLUDE= CGI CLI FPM EMBED
+
+.include "${MASTERDIR}/Makefile"