aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2016-01-10 23:59:19 +0800
committerjunovitch <junovitch@FreeBSD.org>2016-01-10 23:59:19 +0800
commit1a3a99034434dae334c0857a3ff70d248294be5c (patch)
treec65e1016cb5278ce0fc620841028b6328d582951 /www
parentcbb8d54bfd85de654324e196d84eb6609bce6db0 (diff)
downloadfreebsd-ports-gnome-1a3a99034434dae334c0857a3ff70d248294be5c.tar.gz
freebsd-ports-gnome-1a3a99034434dae334c0857a3ff70d248294be5c.tar.zst
freebsd-ports-gnome-1a3a99034434dae334c0857a3ff70d248294be5c.zip
www/h2o: update 1.6.0 -> 1.6.1 and add LibreSSL option
- OPTIONS: Add bundled LIBRESSL option and set as default - HTTP/2 support requires TLS ALPN extension missing in base OpenSSL - Upstream expectation is the bundled LibreSSL is used to support HTTP/2 - Enables ChaCha20-Poly1305 ciphers as a bonus - Update sample configuration file Changes: https://github.com/h2o/h2o/releases/tag/v1.6.1 PR: 205946 Submitted by: Dave Cottlehuber <dch@skunkwerks.at> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/h2o/Makefile15
-rw-r--r--www/h2o/distinfo4
-rw-r--r--www/h2o/files/h2o.conf.sample8
3 files changed, 20 insertions, 7 deletions
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index 5e52d2ecc031..8153146d84f1 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= h2o
-PORTVERSION= 1.6.0
+PORTVERSION= 1.6.1
DISTVERSIONPREFIX= v
CATEGORIES= www
@@ -35,10 +35,21 @@ H2O_LOGDIR= /var/log/${PORTNAME}/
USE_RC_SUBR= ${PORTNAME}
+OPTIONS_DEFINE= LIBRESSL
+LIBRESSL_DESC= Build with bundled LibreSSL instead of OpenSSL
+OPTIONS_DEFAULT= LIBRESSL
+
+CMAKE_ARGS+= -DEXTRA_LIBRARIES=OFF -DWITHOUT_LIBS=ON
+
.include <bsd.port.options.mk>
-CMAKE_ARGS+= -DWITH_BUNDLED_SSL=OFF -DEXTRA_LIBRARIES=OFF -DWITHOUT_LIBS=ON
+.if ${PORT_OPTIONS:MLIBRESSL}
+CMAKE_ARGS+= -DWITH_BUNDLED_SSL=ON
+USE_OPENSSL_PORT= no
+.else
+CMAKE_ARGS+= -DWITH_BUNDLED_SSL=OFF
USE_OPENSSL_PORT= yes
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|exec perl|exec ${LOCALBASE}/bin/perl|' \
diff --git a/www/h2o/distinfo b/www/h2o/distinfo
index 8f88c2411a53..b64d048d4503 100644
--- a/www/h2o/distinfo
+++ b/www/h2o/distinfo
@@ -1,2 +1,2 @@
-SHA256 (h2o-h2o-v1.6.0_GH0.tar.gz) = 5c8b96ac9e930fbd563359323413e3e08057fe850e515eb41c3bfff896a78593
-SIZE (h2o-h2o-v1.6.0_GH0.tar.gz) = 6279605
+SHA256 (h2o-h2o-v1.6.1_GH0.tar.gz) = b9ffb59ecce6c35ea55cc95c71c7d85e91ac5fc888ada264da7c77f1d8e655f0
+SIZE (h2o-h2o-v1.6.1_GH0.tar.gz) = 6304959
diff --git a/www/h2o/files/h2o.conf.sample b/www/h2o/files/h2o.conf.sample
index a55801d321af..80b77c6beaa3 100644
--- a/www/h2o/files/h2o.conf.sample
+++ b/www/h2o/files/h2o.conf.sample
@@ -1,5 +1,6 @@
# vi: ft=yaml
-# to find out the configuration commands, run: h2o --help
+# see https://h2o.examp1e.net/ for detailed documentation
+# see h2o --help for command-line options and settings
user: www
pid-file: /var/run/h2o.pid
access-log: /var/log/h2o/h2o-access.log
@@ -12,7 +13,8 @@ listen:
# generate your own certificates
certificate-file: /usr/local/etc/h2o/server.crt
key-file: /usr/local/etc/h2o/server.key
-file.dirlisting: on
+# enable Apache-style directory listings
+# file.dirlisting: on
# per-host configuration
hosts:
my.example.org:
@@ -25,6 +27,6 @@ hosts:
"/poudriere":
file.dir: "/usr/local/poudriere/data/logs/bulk"
"/FreeBSD:10:amd64":
- file.dir: "/usr/local/poudriere/data/packages/10_1_amd64-default/"
+ file.dir: "/usr/local/poudriere/data/packages/10_2_amd64-default/"
"/FreeBSD:11:amd64":
file.dir: "/usr/local/poudriere/data/packages/current_amd64-default/"