aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2016-03-01 22:29:34 +0800
committerdemon <demon@FreeBSD.org>2016-03-01 22:29:34 +0800
commit1abd4fd0e284b9ef680aab140b3f1fa610e6234d (patch)
treec235d4d15f99c29b7abe9af6e809d70eb0fcaef4 /www
parentb998e28eb601fd64a18bb7082869aef01f10a14e (diff)
downloadfreebsd-ports-gnome-1abd4fd0e284b9ef680aab140b3f1fa610e6234d.tar.gz
freebsd-ports-gnome-1abd4fd0e284b9ef680aab140b3f1fa610e6234d.tar.zst
freebsd-ports-gnome-1abd4fd0e284b9ef680aab140b3f1fa610e6234d.zip
New port: py-django-htmlmin
django-html is an HTML minifier for Python, with full support for HTML 5. It supports Django, Flask and many other Python web frameworks. It also provides a command line tool, that can be used for static websites or deployment scripts. WWW: https://pypi.python.org/pypi/django-htmlmin
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-htmlmin/Makefile20
-rw-r--r--www/py-django-htmlmin/distinfo2
-rw-r--r--www/py-django-htmlmin/pkg-descr6
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d85073034c5a..a8b78718ca89 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1540,6 +1540,7 @@
SUBDIR += py-django-formtools
SUBDIR += py-django-happenings
SUBDIR += py-django-haystack
+ SUBDIR += py-django-htmlmin
SUBDIR += py-django-json-rpc
SUBDIR += py-django-keyedcache
SUBDIR += py-django-ldapdb
diff --git a/www/py-django-htmlmin/Makefile b/www/py-django-htmlmin/Makefile
new file mode 100644
index 000000000000..b9a70b965981
--- /dev/null
+++ b/www/py-django-htmlmin/Makefile
@@ -0,0 +1,20 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+# $FreeBSD$
+
+PORTNAME= django-htmlmin
+PORTVERSION= 0.9.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= HTML minifier for Python
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/bs4/element.py:${PORTSDIR}/www/py-beautifulsoup \
+ ${PYTHON_SITELIBDIR}/html5lib/html5parser.py:${PORTSDIR}/www/py-html5lib
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-htmlmin/distinfo b/www/py-django-htmlmin/distinfo
new file mode 100644
index 000000000000..61a6168936c5
--- /dev/null
+++ b/www/py-django-htmlmin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-htmlmin-0.9.0.tar.gz) = 34f1ca19674a85ce8be99bc3a80ea53b282a9e743e275f68cb3f02ae8d9d0f91
+SIZE (django-htmlmin-0.9.0.tar.gz) = 6579
diff --git a/www/py-django-htmlmin/pkg-descr b/www/py-django-htmlmin/pkg-descr
new file mode 100644
index 000000000000..18b64c44c80b
--- /dev/null
+++ b/www/py-django-htmlmin/pkg-descr
@@ -0,0 +1,6 @@
+django-html is an HTML minifier for Python, with full support for HTML 5.
+It supports Django, Flask and many other Python web frameworks. It also
+provides a command line tool, that can be used for static websites or
+deployment scripts.
+
+WWW: https://pypi.python.org/pypi/django-htmlmin