aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-02-19 18:52:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-02-19 18:52:38 +0800
commit1c8b97018f3fff39a2d04255280ecc4ddea91305 (patch)
tree9821223fea434944467faa6a57c6c69d1b4c14fe /www
parentf731b7dbb9c4cf1217601fc0c874f7aa95f0f133 (diff)
downloadfreebsd-ports-gnome-1c8b97018f3fff39a2d04255280ecc4ddea91305.tar.gz
freebsd-ports-gnome-1c8b97018f3fff39a2d04255280ecc4ddea91305.tar.zst
freebsd-ports-gnome-1c8b97018f3fff39a2d04255280ecc4ddea91305.zip
- Fix *_DEPENDS
- Bump PORTREVISION for dependency change
Diffstat (limited to 'www')
-rw-r--r--www/p5-HTTP-Message/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/www/p5-HTTP-Message/Makefile b/www/p5-HTTP-Message/Makefile
index 731df8e34408..6627bb27079a 100644
--- a/www/p5-HTTP-Message/Makefile
+++ b/www/p5-HTTP-Message/Makefile
@@ -7,6 +7,7 @@
PORTNAME= HTTP-Message
PORTVERSION= 6.03
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,14 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Representation of HTTP style messages
-RUN_DEPENDS= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
- p5-Encode-Locale>=1:${PORTSDIR}/converters/p5-Encode-Locale \
+BUILD_DEPENDS= p5-Encode-Locale>=1:${PORTSDIR}/converters/p5-Encode-Locale \
p5-HTML-Parser>=3.33:${PORTSDIR}/www/p5-HTML-Parser \
p5-HTTP-Date>=6:${PORTSDIR}/www/p5-HTTP-Date \
- p5-IO-Compress>=2.021:${PORTSDIR}/archivers/p5-IO-Compress \
p5-LWP-MediaTypes>=6:${PORTSDIR}/www/p5-LWP-MediaTypes \
p5-URI>=1.10:${PORTSDIR}/net/p5-URI
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= p5-libwww-5*
@@ -36,4 +35,16 @@ MAN3= HTTP::Config.3 \
HTTP::Response.3 \
HTTP::Status.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib
+RUN_DEPENDS+= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-IO-Compress>=2.021:${PORTSDIR}/archivers/p5-IO-Compress
+RUN_DEPENDS+= p5-IO-Compress>=2.021:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>