aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
commit1ca518c98321627ea34bdaae84c439a2f0df0cdf (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /www
parent81215f7fb03620d52b441a5714e6af1fb655c743 (diff)
downloadfreebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.gz
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.zst
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Diffstat (limited to 'www')
-rw-r--r--www/cadaver/Makefile2
-rw-r--r--www/cgi-lib.pl/Makefile2
-rw-r--r--www/jmeter/Makefile2
-rw-r--r--www/qt4-webkit/Makefile1
-rw-r--r--www/ump/Makefile2
5 files changed, 5 insertions, 4 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index d48948f479ac..73d4f25248a4 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -29,7 +29,7 @@ PLIST_FILES= bin/cadaver
# script breaks if it can not find the Makefile* in them. Exclude
# them to be sure, a stray .h is not included instead of what's
# found under PREFIX (installed by the neon port):
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - \
+EXTRACT_AFTER_ARGS= \
--exclude '${PORTNAME}-${PORTVERSION}/lib/expat/*.[ch]' \
--exclude '${PORTNAME}-${PORTVERSION}/lib/intl/*.[ch]' \
--exclude '${PORTNAME}-${PORTVERSION}/lib/neon/*.[ch]' \
diff --git a/www/cgi-lib.pl/Makefile b/www/cgi-lib.pl/Makefile
index da299730aba1..74465b6b03d0 100644
--- a/www/cgi-lib.pl/Makefile
+++ b/www/cgi-lib.pl/Makefile
@@ -20,6 +20,8 @@ USE_PERL5= YES
NO_BUILD= YES
NO_WRKSUBDIR= YES
PLIST_FILES= %%SITE_PERL%%/cgi-lib.pl
+EXTRACT_CMD= ${GZCAT}
+EXTRACT_BEFORE_ARGS= #
EXTRACT_AFTER_ARGS= > cgi-lib.pl
INSTALL_BASE= ${SITE_PERL_REL}
diff --git a/www/jmeter/Makefile b/www/jmeter/Makefile
index 1e5f842ed4dd..93d2850b1940 100644
--- a/www/jmeter/Makefile
+++ b/www/jmeter/Makefile
@@ -48,7 +48,7 @@ SUB_FILES= jmeter.sh
DATAFILES= bin extras lib
# Do not even extract the MS-DOS files nor the JARs,
# that are already provided by other ports:
-EXTRACT_AFTER_ARGS= |${TAR} -xpf - --exclude '*.bat' --exclude '*.cmd' \
+EXTRACT_AFTER_ARGS= --exclude '*.bat' --exclude '*.cmd' \
${RUN_DEPENDS:M*.jar*:C|.*/(.+).jar:.*|--exclude '\1-*.jar'|} \
--exclude 'oro-*.jar'
diff --git a/www/qt4-webkit/Makefile b/www/qt4-webkit/Makefile
index a638e85e8dc0..aca1dbe13d98 100644
--- a/www/qt4-webkit/Makefile
+++ b/www/qt4-webkit/Makefile
@@ -33,7 +33,6 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
src/testlib src/tools src/winmain src/3rdparty/clucene \
src/3rdparty/freetype src/3rdparty/libjpeg src/3rdparty/libmng \
src/3rdparty/libpng src/3rdparty/libtiff
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
diff --git a/www/ump/Makefile b/www/ump/Makefile
index 5b390b71fb7a..a39970e91c73 100644
--- a/www/ump/Makefile
+++ b/www/ump/Makefile
@@ -45,7 +45,7 @@ EXTRA_PATCHES= ${PORTSDIR}/audio/timidity++/files/*
PKGDIR= ${.CURDIR}
WRKSRC= ${WRKDIR}/TiMidity++-${TIMIDITY_VERSION}
BUILD_WRKSRC= ${WRKSRC}/ump
-EXTRACT_AFTER_ARGS= | ${TAR} -xpf - --exclude '*/libarc/*' \
+EXTRACT_AFTER_ARGS= --exclude '*/libarc/*' \
--exclude '*/utils/mblock.h' --exclude '*/utils/memb.h'
ALL_TARGET= ump