aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2016-05-31 18:44:59 +0800
committerdemon <demon@FreeBSD.org>2016-05-31 18:44:59 +0800
commit1d8c44aa9cf9f121408ae4b1c3821611ed1eaa12 (patch)
treed86b06e5c66d0227570dac600030dc405770554f /www
parentee6680ba82b463602126916954b3950c0960937f (diff)
downloadfreebsd-ports-gnome-1d8c44aa9cf9f121408ae4b1c3821611ed1eaa12.tar.gz
freebsd-ports-gnome-1d8c44aa9cf9f121408ae4b1c3821611ed1eaa12.tar.zst
freebsd-ports-gnome-1d8c44aa9cf9f121408ae4b1c3821611ed1eaa12.zip
Switch xml implementation to libxml2, because it supports embedding pythin
code to CDATA elements (expat doesn't). Submitted by: Eric Masson <emss@free.fr>
Diffstat (limited to 'www')
-rw-r--r--www/uwsgi/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/www/uwsgi/Makefile b/www/uwsgi/Makefile
index 93b1f36e5c4d..079653a24b7e 100644
--- a/www/uwsgi/Makefile
+++ b/www/uwsgi/Makefile
@@ -22,7 +22,7 @@ OPTIONS_DEFINE= DEBUG JSON PCRE XML
DEBUG_VARS= PYDISTUTILS_BUILDARGS+=--debug
JSON_LIB_DEPENDS= libjansson.so:devel/jansson
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
-XML_LIB_DEPENDS= libexpat.so:textproc/expat2
+XML_LIB_DEPENDS= libxml2.so:textproc/libxml2
.include <bsd.port.options.mk>
@@ -39,8 +39,7 @@ O_PCRE= false
.endif
.if ${PORT_OPTIONS:MXML}
-O_XML= expat
-CFLAGS+= "-I${LOCALBASE}/include"
+O_XML= libxml2
.else
O_XML= false
.endif