aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-11 07:09:06 +0800
committermiwi <miwi@FreeBSD.org>2006-12-11 07:09:06 +0800
commit1e4f4a6607f83f0ded2ac1604856df820de448b0 (patch)
treed5088e47b423cb98506e63e045f3de426db248ff /www
parent7ca84238345acd59db07c9d5ca525f0d2c643edb (diff)
downloadfreebsd-ports-gnome-1e4f4a6607f83f0ded2ac1604856df820de448b0.tar.gz
freebsd-ports-gnome-1e4f4a6607f83f0ded2ac1604856df820de448b0.tar.zst
freebsd-ports-gnome-1e4f4a6607f83f0ded2ac1604856df820de448b0.zip
- Add PostgreSQL support
PR: ports/106559 Submitted by: Gerrit Beine<gerrit.beine@gmx.de> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/mediawiki17/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/www/mediawiki17/Makefile b/www/mediawiki17/Makefile
index c4581fd6665c..83291d4e192a 100644
--- a/www/mediawiki17/Makefile
+++ b/www/mediawiki17/Makefile
@@ -16,18 +16,27 @@ COMMENT= The wiki engine used by Wikipedia
CONFLICTS= mediawiki-1.[0-68-9].*
+NO_LATEST_LINK= yes
+
NO_BUILD= yes
USE_MYSQL= yes
IGNORE_WITH_MYSQL= 323
-USE_PHP= iconv mbstring pcre session xml zlib readline mysql
+USE_PHP= iconv mbstring pcre session xml zlib readline
IGNORE_WITH_PHP= 4
WANT_PHP_WEB= yes
MEDIAWIKIDIR?= www/mediawiki
-OPTIONS= LDAP "Use LDAP authentication" off
+OPTIONS= PGSQL "Use PostgreSQL instead of MySQL (not funtional)" off \
+ LDAP "Use LDAP authentication" off
.include <bsd.port.pre.mk>
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.else
+USE_PHP+= mysql
+.endif
+
.if defined(WITH_LDAP)
USE_PHP+= ldap
.endif