aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-02-07 16:32:02 +0800
committerwen <wen@FreeBSD.org>2012-02-07 16:32:02 +0800
commit202c03e471b369ad8fdf43e57ed6891be8e84600 (patch)
tree75fe16bdd9edbd2fbf515f780a33ef892bae4a34 /www
parent077a6445aa39bcaf8cb60fa77230dbbeb3095e1f (diff)
downloadfreebsd-ports-gnome-202c03e471b369ad8fdf43e57ed6891be8e84600.tar.gz
freebsd-ports-gnome-202c03e471b369ad8fdf43e57ed6891be8e84600.tar.zst
freebsd-ports-gnome-202c03e471b369ad8fdf43e57ed6891be8e84600.zip
Mongrel2 is an application, language, and network architecture
agnostic web server that focuses on web applications using modern browser technologies. WWW: http://mongrel2.org/ PR: ports/163256 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mongrel2/Makefile54
-rw-r--r--www/mongrel2/distinfo2
-rw-r--r--www/mongrel2/files/patch-Makefile9
-rw-r--r--www/mongrel2/pkg-descr5
-rw-r--r--www/mongrel2/pkg-plist146
6 files changed, 217 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9a6a3d5d4e69..44e77be62d4e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -498,6 +498,7 @@
SUBDIR += moinmoin
SUBDIR += momspider
SUBDIR += monast
+ SUBDIR += mongrel2
SUBDIR += moodle
SUBDIR += moodle2
SUBDIR += moonshine
diff --git a/www/mongrel2/Makefile b/www/mongrel2/Makefile
new file mode 100644
index 000000000000..649ecf4deb44
--- /dev/null
+++ b/www/mongrel2/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: mongrel2
+# Date created: 2011-09-28
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mongrel2
+PORTVERSION= 1.7.5
+CATEGORIES= www
+MASTER_SITES= http://mongrel2.org/static/downloads/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Is an application, language, and network arch
+
+LIB_DEPENDS= zmq.1:${PORTSDIR}/devel/zmq \
+ sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+USE_GMAKE= yes
+USE_BZIP2= yes
+MAKE_FLAGS= freebsd
+EXAMPLES_LIST= bbs \
+ chat \
+ configs \
+ http_0mq \
+ kegogi \
+ mp3stream \
+ procer \
+ python \
+ tornado \
+ zcov
+
+OPTIONS= EXAMPLES "Install examplse" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_EXAMPLES)
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/Makefile
+
+post-install:
+.if defined(WITH_EXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for examples in ${EXAMPLES_LIST}
+ @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} ${examples} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/mongrel2/distinfo b/www/mongrel2/distinfo
new file mode 100644
index 000000000000..5a96affa525a
--- /dev/null
+++ b/www/mongrel2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mongrel2-1.7.5.tar.bz2) = 48e4b3ba8959be001e5bac75e0a3fee628c917b08f115be08bcd5348ac663b01
+SIZE (mongrel2-1.7.5.tar.bz2) = 745357
diff --git a/www/mongrel2/files/patch-Makefile b/www/mongrel2/files/patch-Makefile
new file mode 100644
index 000000000000..8cf5a23b7cec
--- /dev/null
+++ b/www/mongrel2/files/patch-Makefile
@@ -0,0 +1,9 @@
+--- Makefile.orig 2011-09-28 11:50:28.876409429 +0400
++++ Makefile 2011-09-28 11:50:41.723014235 +0400
+@@ -1,5 +1,5 @@
+ CFLAGS=-g -O2 -Wall -Wextra -Isrc -pthread -rdynamic -DNDEBUG $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
+-LIBS=-lzmq -ldl -lsqlite3 $(OPTLIBS)
++LIBS=-lzmq -lsqlite3 $(OPTLIBS)
+ PREFIX?=/usr/local
+
+ get_objs = $(addsuffix .o,$(basename $(wildcard $(1))))
diff --git a/www/mongrel2/pkg-descr b/www/mongrel2/pkg-descr
new file mode 100644
index 000000000000..fe782e0f7da1
--- /dev/null
+++ b/www/mongrel2/pkg-descr
@@ -0,0 +1,5 @@
+Mongrel2 is an application, language, and network architecture
+agnostic web server that focuses on web applications using modern
+browser technologies.
+
+WWW: http://mongrel2.org/
diff --git a/www/mongrel2/pkg-plist b/www/mongrel2/pkg-plist
new file mode 100644
index 000000000000..9d2f0a7b957d
--- /dev/null
+++ b/www/mongrel2/pkg-plist
@@ -0,0 +1,146 @@
+bin/mongrel2
+bin/m2sh
+lib/mongrel2/config_modules/null.so
+lib/mongrel2/config_modules/zmq.so
+lib/mongrel2/filters/null.so
+%%EXAMPLES%%%%EXAMPLESDIR%%/procer/procer.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/procer/Makefile
+%%EXAMPLES%%%%EXAMPLESDIR%%/procer/rampart.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/procer/profile.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/procer/procer.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/site.css
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/app.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/text.css
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/bbs.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/js/jsonStringify.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/js/jsSocket.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/fsm.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/index.html
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/reset.css
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/flash/jsSocket.as
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/flash/jsSocket.swf
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/flash/JsSocket.hx
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/flash/Makefile
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/html/flash/jsSocket2.swf
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/db.lua
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/bbs.lua
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/engine.lua
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/config.lua
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/client.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/ui.lua
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/mongrel2.conf
+%%EXAMPLES%%%%EXAMPLESDIR%%/bbs/strict.lua
+%%EXAMPLES%%%%EXAMPLESDIR%%/http_0mq/http.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/http_0mq/xml.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/http_0mq/upload.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/setup.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/handler.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/request.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/control.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/__init__.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/config/__init__.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/config/model.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/config/args.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/config/rc.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/config/commands.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/tnetstrings.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/mongrel2/sql/config.sql
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/tests/__init__.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/tests/sample_conf.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/tests/two_servers.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/tests/composite_conf.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/tests/mongrel2_org.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/python/bin/m2shpy
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/lempar.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/lemon.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi_lexer.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/httpclient.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/param.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi_tokens.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi_parser.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi_parser.y
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi_lexer.rl
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/fuzzrnd.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi_parser.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi_tokens.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/param.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/httpclient.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/kegogi_parser_extra.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/src/fuzzrnd.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/Makefile
+%%EXAMPLES%%%%EXAMPLESDIR%%/kegogi/tests/googletest.txt
+%%EXAMPLES%%%%EXAMPLESDIR%%/configs/multi.conf
+%%EXAMPLES%%%%EXAMPLESDIR%%/configs/sample.conf
+%%EXAMPLES%%%%EXAMPLESDIR%%/configs/mongrel2.conf
+%%EXAMPLES%%%%EXAMPLESDIR%%/configs/multi_handler.conf
+%%EXAMPLES%%%%EXAMPLESDIR%%/configs/any.conf
+%%EXAMPLES%%%%EXAMPLESDIR%%/configs/complex.conf
+%%EXAMPLES%%%%EXAMPLESDIR%%/tornado/auth_demo.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/tornado/README
+%%EXAMPLES%%%%EXAMPLESDIR%%/tornado/authdemo.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/site.css
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/fsm.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/flash/jsSocket.swf
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/flash/JsSocket.hx
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/flash/jsSocket2.swf
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/flash/jsSocket.as
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/flash/Makefile
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/text.css
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/960.css
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/index.html
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/js/jsonStringify.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/js/jsSocket.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/reset.css
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/app.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/static/chat.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/www.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/idiots
+%%EXAMPLES%%%%EXAMPLESDIR%%/chat/chat.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/mp3stream/handler.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/mp3stream/mp3stream.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/mp3stream/stream_conf.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/setup.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/README.txt
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/zcov/data/style.css
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/zcov/data/js/sourceview.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/zcov/data/js/sorttable.js
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/zcov/GCovParser.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/zcov/GCovGroup.py
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/bin/zcov-merge
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/bin/zcov-summarize
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/bin/zcov-scan
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/bin/zcov-genhtml
+%%EXAMPLES%%%%EXAMPLESDIR%%/zcov/LICENSE.txt
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/zcov/zcov/data/js
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/zcov/zcov/data
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/zcov/zcov
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/zcov/bin
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/zcov
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/tornado
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/python/tests
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/python/mongrel2/sql
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/python/mongrel2/config
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/python/mongrel2
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/python/bin
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/python
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/procer
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/mp3stream
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/kegogi/tests
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/kegogi/src
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/kegogi
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/http_0mq
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/configs
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/chat/static/js
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/chat/static/flash
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/chat/static
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/chat
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/bbs/html/js
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/bbs/html/flash
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/bbs/html
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/bbs
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm lib/mongrel2/filters
+@dirrm lib/mongrel2/config_modules
+@dirrm lib/mongrel2