aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2008-04-15 09:46:17 +0800
committerclsung <clsung@FreeBSD.org>2008-04-15 09:46:17 +0800
commit20afd3cc7bd229edb66dc7732ce09ae417c6bb1e (patch)
treed6373fe39b0b8a6c6eed954bd8c400daeb8bc306 /www
parentece15a160e12e6db7755caf5a88c9ac7e943a492 (diff)
downloadfreebsd-ports-gnome-20afd3cc7bd229edb66dc7732ce09ae417c6bb1e.tar.gz
freebsd-ports-gnome-20afd3cc7bd229edb66dc7732ce09ae417c6bb1e.tar.zst
freebsd-ports-gnome-20afd3cc7bd229edb66dc7732ce09ae417c6bb1e.zip
HTTP::MobileAttribute is Plaggable version of HTTP::MobileAgent.
WWW: http://search.cpan.org/dist/HTTP-MobileAttribute/ PR: ports/122746 Submitted by: Tomoyuki Sakurai <cherry at trombik.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-MobileAttribute/Makefile39
-rw-r--r--www/p5-HTTP-MobileAttribute/distinfo3
-rw-r--r--www/p5-HTTP-MobileAttribute/pkg-descr3
-rw-r--r--www/p5-HTTP-MobileAttribute/pkg-plist36
5 files changed, 82 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a2ab97250d67..91b079afa082 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -827,6 +827,7 @@
SUBDIR += p5-HTTP-Lite
SUBDIR += p5-HTTP-MHTTP
SUBDIR += p5-HTTP-MobileAgent
+ SUBDIR += p5-HTTP-MobileAttribute
SUBDIR += p5-HTTP-Parser
SUBDIR += p5-HTTP-Proxy
SUBDIR += p5-HTTP-Recorder
diff --git a/www/p5-HTTP-MobileAttribute/Makefile b/www/p5-HTTP-MobileAttribute/Makefile
new file mode 100644
index 000000000000..1bd88712ff25
--- /dev/null
+++ b/www/p5-HTTP-MobileAttribute/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-HTTP-MobileAttribute
+# Date created: Fri Apr 11 16:32:54 2008
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-MobileAttribute
+PORTVERSION= 0.11.1
+CATEGORIES= www
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/T/TO/TOKUHIROM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cherry@trombik.org
+COMMENT= Yet Another HTTP::MobileAgent
+
+BUILD_DEPENDS= p5-Test-Warn>0:${PORTSDIR}/devel/p5-Test-Warn
+RUN_DEPENDS= p5-Class-Component>=0.15:${PORTSDIR}/devel/p5-Class-Component
+
+MAN3= HTTP::MobileAttribute::Plugin::Encoding.3 \
+ HTTP::MobileAttribute::Plugin::IS::DoCoMo.3 \
+ HTTP::MobileAttribute::Plugin::CarrierLetter.3 \
+ HTTP::MobileAttribute::Plugin::CIDR.3 \
+ HTTP::MobileAttribute::Attribute::CarrierMethod.3 \
+ HTTP::MobileAttribute::CarrierDetector.3 \
+ HTTP::MobileAttribute::Plugin::IS.3 \
+ HTTP::MobileAttribute::Plugin::UserID.3 \
+ HTTP::MobileAttribute::Plugin::XHTMLCompliant.3 \
+ HTTP::MobileAttribute.3 \
+ HTTP::MobileAttribute::Plugin::IS::ThirdForce.3 \
+ HTTP::MobileAttribute::Plugin::IS::EZweb.3 \
+ HTTP::MobileAttribute::Agent::Base.3 \
+ HTTP::MobileAttribute::Plugin::Display.3
+
+PERL_CONFIGURE= Yes
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-MobileAttribute/distinfo b/www/p5-HTTP-MobileAttribute/distinfo
new file mode 100644
index 000000000000..66283917ab76
--- /dev/null
+++ b/www/p5-HTTP-MobileAttribute/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-MobileAttribute-0.11.1.tar.gz) = 1b7eef7b0c650d735d48e60eaab30d54
+SHA256 (HTTP-MobileAttribute-0.11.1.tar.gz) = e7ede20347e6ed53377d16b3083e48822593e7fefe3498a868b651eabbeb3338
+SIZE (HTTP-MobileAttribute-0.11.1.tar.gz) = 58226
diff --git a/www/p5-HTTP-MobileAttribute/pkg-descr b/www/p5-HTTP-MobileAttribute/pkg-descr
new file mode 100644
index 000000000000..49852c7c54e5
--- /dev/null
+++ b/www/p5-HTTP-MobileAttribute/pkg-descr
@@ -0,0 +1,3 @@
+HTTP::MobileAttribute is Plaggable version of HTTP::MobileAgent.
+
+WWW: http://search.cpan.org/dist/HTTP-MobileAttribute/
diff --git a/www/p5-HTTP-MobileAttribute/pkg-plist b/www/p5-HTTP-MobileAttribute/pkg-plist
new file mode 100644
index 000000000000..98da253f3841
--- /dev/null
+++ b/www/p5-HTTP-MobileAttribute/pkg-plist
@@ -0,0 +1,36 @@
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/DoCoMo.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/AirHPhone.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/EZweb.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/Base.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/ThirdForce.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/NonMobile.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Attribute/CarrierMethod.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/DoCoMo.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/ThirdForce.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/EZweb.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Encoding.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/CIDR.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Core.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/CarrierLetter.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/XHTMLCompliant.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/UserID.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/GPS.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Display.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Request/HTTPHeaders.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Request/Apache.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Request/Env.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/CarrierDetector.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Request.pm
+%%SITE_PERL%%/HTTP/MobileAttribute.pm
+%%SITE_PERL%%/mach/auto/HTTP/MobileAttribute/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/HTTP/MobileAttribute
+@dirrmtry %%SITE_PERL%%/mach/auto/HTTP
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Request
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Attribute
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Agent
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute
+@dirrmtry %%SITE_PERL%%/HTTP