aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2016-11-16 08:35:56 +0800
committerlinimon <linimon@FreeBSD.org>2016-11-16 08:35:56 +0800
commit20f436cc1e949f8a9b2ece6df4cf9adc4e2e7a66 (patch)
tree41ae757bdae0cc285f896987daa114cece7d9870 /www
parentfc96d103f75456568f63819df288941f757eed90 (diff)
downloadfreebsd-ports-gnome-20f436cc1e949f8a9b2ece6df4cf9adc4e2e7a66.tar.gz
freebsd-ports-gnome-20f436cc1e949f8a9b2ece6df4cf9adc4e2e7a66.tar.zst
freebsd-ports-gnome-20f436cc1e949f8a9b2ece6df4cf9adc4e2e7a66.zip
Mark as broken on various tier-2 archs.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'www')
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/libxul/Makefile2
-rw-r--r--www/mohawk/Makefile5
-rw-r--r--www/seamonkey/Makefile2
5 files changed, 10 insertions, 3 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index bec51bf65778..51f20cdf51d0 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -42,6 +42,8 @@ MOZILLA_NAME= Firefox
USE_GL= gl
USES= tar:xz
+BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
+
FIREFOX_ICON= ${MOZILLA}.png
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png
MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 6858a4aa5146..1b32c65d8ee5 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -40,6 +40,8 @@ MOZILLA_NAME= Firefox
USE_GL= gl
USES= tar:xz
+BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
+
FIREFOX_ICON= ${MOZILLA}.png
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png
MOZ_OPTIONS= --enable-application=browser \
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 8808ee9ea477..3c809e3b0ff6 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -39,6 +39,8 @@ MAKE_ENV= SKIP_GRE_REGISTRATION=1 mozappdir=${PREFIX}/lib/${MOZILLA}
LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
USE_LDCONFIG= ${PREFIX}/lib/${MOZILLA}
+BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
+
MOZ_OPTIONS?= --enable-application=xulrunner
USE_GECKO= gecko
CPE_PRODUCT= firefox_esr
diff --git a/www/mohawk/Makefile b/www/mohawk/Makefile
index cf2f4f1c7e32..c978dd51b6c0 100644
--- a/www/mohawk/Makefile
+++ b/www/mohawk/Makefile
@@ -12,8 +12,6 @@ COMMENT= Simple and lightweight HTTP daemon
LICENSE= BSD2CLAUSE
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libevent.so:devel/libevent2
PLIST_FILES+= bin/mhtpasswd \
@@ -32,6 +30,9 @@ OPTIONS_DEFINE= EXAMPLES
USES= uidfix
+BROKEN_aarch64= Fails to compile: error: comparison of constant -1 with expression of type char is always true
+BROKEN_powerpc64= Does not build
+
.include <bsd.port.options.mk>
post-install:
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 35713e2f628b..3af7ac8c8ad0 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -48,7 +48,7 @@ MOZ_OPTIONS+= --program-transform-name='s/seamonkey/${MOZILLA}/' \
USE_MOZILLA= # empty
MOZ_PKGCONFIG_FILES=
-NOT_FOR_ARCHS= ia64
+BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
OPTIONS_DEFINE= CHATZILLA COMPOSER ENIGMAIL LDAP LIGHTNING MAILNEWS RUST
OPTIONS_SINGLE= TOOLKIT