aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-10-12 02:34:45 +0800
committerdinoex <dinoex@FreeBSD.org>2009-10-12 02:34:45 +0800
commit2272bb36954cf1705360682e70c56bb19ded3bf9 (patch)
tree1f063a60f7a95d4831cb2a1adf0ea1d4e647ac9d /www
parent17da02a371f356d71979c7a2bb90f98e7b71bb80 (diff)
downloadfreebsd-ports-gnome-2272bb36954cf1705360682e70c56bb19ded3bf9.tar.gz
freebsd-ports-gnome-2272bb36954cf1705360682e70c56bb19ded3bf9.tar.zst
freebsd-ports-gnome-2272bb36954cf1705360682e70c56bb19ded3bf9.zip
- add mod_accel patch for amd64
Submitted by: Sergey Smitienko
Diffstat (limited to 'www')
-rw-r--r--www/apache13-modssl/Makefile1
-rw-r--r--www/apache13-modssl/files/mod_accel-ap_ext_accel.patch36
2 files changed, 37 insertions, 0 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index 5a523b4ce2b8..fc5909e0d24f 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -238,6 +238,7 @@ CONFIGURE_ARGS+= --activate-module=src/modules/extra/mod_randban.o \
--activate-module=src/modules/accel/libaccel.a \
--enable-shared=accel
EXTRA_PATCHES+= ${FILESDIR}/mod_accel-preservehost.patch ${FILESDIR}/mod_accel-Makefile.tmpl.patch
+EXTRA_PATCHES+= ${FILESDIR}/mod_accel-ap_ext_accel.patch
PLIST_FILES+= libexec/apache/libaccel.so \
libexec/apache/mod_freeze.so \
libexec/apache/mod_randban.so \
diff --git a/www/apache13-modssl/files/mod_accel-ap_ext_accel.patch b/www/apache13-modssl/files/mod_accel-ap_ext_accel.patch
new file mode 100644
index 000000000000..43932fc162aa
--- /dev/null
+++ b/www/apache13-modssl/files/mod_accel-ap_ext_accel.patch
@@ -0,0 +1,36 @@
+--- src/modules/accel/ap_ext_accel.h~ 2009-10-05 22:57:34.000000000 +0400
++++ src/modules/accel/ap_ext_accel.h 2009-10-05 22:58:10.000000000 +0400
+@@ -8,10 +8,10 @@
+
+
+ API_EXPORT_NONSTD(const char *) ap_set_integer_slot(cmd_parms *cmd,
+- char *struct_ptr, int arg);
++ char *struct_ptr, const char * arg);
+
+ API_EXPORT_NONSTD(const char *) ap_set_kilobytes_slot(cmd_parms *cmd,
+- char *struct_ptr, int arg);
++ char *struct_ptr, const char * arg);
+
+ #ifdef NO_SETPROCTITLE
+ #define ap_setproctitle(title)
+--- src/modules/accel/ap_ext_accel.c~ 2009-10-05 22:57:33.000000000 +0400
++++ src/modules/accel/ap_ext_accel.c 2009-10-05 22:58:32.000000000 +0400
+@@ -5,7 +5,7 @@
+ #include "ap_ext_accel.h"
+
+ API_EXPORT_NONSTD(const char *) ap_set_integer_slot(cmd_parms *cmd,
+- char *struct_ptr, int arg)
++ char *struct_ptr, const char* arg)
+ {
+ int offset = (int) (long) cmd->info;
+ int size = atoi((char *)arg);
+@@ -19,7 +19,7 @@
+ }
+
+ API_EXPORT_NONSTD(const char *) ap_set_kilobytes_slot(cmd_parms *cmd,
+- char *struct_ptr, int arg)
++ char *struct_ptr, const char* arg)
+ {
+ int offset = (int) (long) cmd->info;
+ int size = atoi(arg);
+