aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1997-03-09 06:02:40 +0800
committerobrien <obrien@FreeBSD.org>1997-03-09 06:02:40 +0800
commit23595c1be784a378fb2849b1a96d8a873e3d9205 (patch)
treec8fbdfabe0acb3824e2e538d775a800f690e05fc /www
parente75935808a4c26b81707f1fca7ccf0f21be710bf (diff)
downloadfreebsd-ports-gnome-23595c1be784a378fb2849b1a96d8a873e3d9205.tar.gz
freebsd-ports-gnome-23595c1be784a378fb2849b1a96d8a873e3d9205.tar.zst
freebsd-ports-gnome-23595c1be784a378fb2849b1a96d8a873e3d9205.zip
Add patch for MD5 encrypted passwords
Closes-PR: ports/2669 Submitted by: Sergei Vnotchenko <sergey@ns.extech.msk.su>
Diffstat (limited to 'www')
-rw-r--r--www/w3c-httpd/Makefile29
1 files changed, 23 insertions, 6 deletions
diff --git a/www/w3c-httpd/Makefile b/www/w3c-httpd/Makefile
index 9cdca61b44b5..c6130a5fa064 100644
--- a/www/w3c-httpd/Makefile
+++ b/www/w3c-httpd/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: pst
#
-# $Id: Makefile,v 1.14 1997/01/09 03:07:41 asami Exp $
+# $Id: Makefile,v 1.15 1997/01/10 07:34:35 asami Exp $
#
DISTNAME= w3c-httpd-3.0A
@@ -16,14 +16,31 @@ NO_WRKSUBDIR= yes
WWW_ROOT= ${PREFIX}/www
+pre-configure:
+.if !defined(MD5_PW)
+ @echo ""
+ @echo "Defaulting to DES encrypted passwords."
+ @echo "Set the environment variable MD5_PW if you want MD5 encrypted passwords."
+ @echo ""
+.else
+ @echo "CFLAGS += -DMD5_PW" >> ${WRKDIR}/All/${OSNAME}/Makefile.include
+.endif
+
do-install:
${MKDIR} ${WWW_ROOT}/data ${WWW_ROOT}/cgi-bin ${WWW_ROOT}/htbin
${CP} -R ${WRKSRC}/server_root/icons $(WWW_ROOT)
${CP} ${WRKSRC}/server_root/config/*.conf $(PREFIX)/etc
- ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/freebsd/httpd ${PREFIX}/libexec
- ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/freebsd/htadm ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/freebsd/htimage ${WWW_ROOT}/htbin
- ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/freebsd/cgiparse ${WWW_ROOT}/cgi-bin
- ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/freebsd/cgiutils ${WWW_ROOT}/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/${OSNAME}/httpd ${PREFIX}/libexec
+ ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/${OSNAME}/htadm ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/${OSNAME}/htimage ${WWW_ROOT}/htbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/${OSNAME}/cgiparse ${WWW_ROOT}/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/Daemon/${OSNAME}/cgiutils ${WWW_ROOT}/cgi-bin
.include <bsd.port.mk>
+
+.if (${OPSYS} == "FreeBSD")
+OSNAME= freebsd
+.else
+# covers OpenBSD too
+OSNAME= netbsd
+.endif