aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-08-17 00:14:35 +0800
committerpawel <pawel@FreeBSD.org>2016-08-17 00:14:35 +0800
commit23cda9af5e655b19a833404ac50d5e6b45e54d25 (patch)
treec9e2ccfb305a7b0cbec2de8f9a56523347ccac8a /www
parent35c3c9f075593758d6f71a64d642ae55b6cd65de (diff)
downloadfreebsd-ports-gnome-23cda9af5e655b19a833404ac50d5e6b45e54d25.tar.gz
freebsd-ports-gnome-23cda9af5e655b19a833404ac50d5e6b45e54d25.tar.zst
freebsd-ports-gnome-23cda9af5e655b19a833404ac50d5e6b45e54d25.zip
- Update to version 7.50 [1]
- Convert to USES=php:web - Simplify do-install target by using COPYTREE_SHARE PR: 211803 [1] Submitted by: Jochen Neumeister [1]
Diffstat (limited to 'www')
-rw-r--r--www/drupal7/Makefile38
-rw-r--r--www/drupal7/distinfo6
-rw-r--r--www/drupal7/pkg-plist2
3 files changed, 16 insertions, 30 deletions
diff --git a/www/drupal7/Makefile b/www/drupal7/Makefile
index 494db0263ca8..f6210cdce323 100644
--- a/www/drupal7/Makefile
+++ b/www/drupal7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= drupal7
-PORTVERSION= 7.44
+PORTVERSION= 7.50
CATEGORIES= www
MASTER_SITES= http://ftp.drupal.org/files/projects/
DISTNAME= drupal-${PORTVERSION}
@@ -13,11 +13,9 @@ COMMENT= Database driven web content management system (CMS)
LICENSE= GPLv2+
-USES= drupal:7 shebangfix
-SHEBANG_FILES= scripts/password-hash.sh
-
+USES= drupal:7 php:web shebangfix
USE_PHP= dom filter gd hash json mbstring pcre pdo session simplexml xml
-WANT_PHP_WEB= yes
+SHEBANG_FILES= scripts/password-hash.sh
NO_ARCH= yes
NO_BUILD= yes
@@ -38,29 +36,15 @@ MYSQL_USES= mysql
MYSQL_USE= PHP=pdo_mysql
do-install:
- @${MKDIR} ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/.htaccess ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/cron.php ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/authorize.php ${STAGEDIR}${DRUPAL_DIR}
- ${CP} -R ${WRKSRC}/includes ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/index.php ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/install.php ${STAGEDIR}${DRUPAL_DIR}
- ${CP} -R ${WRKSRC}/misc ${STAGEDIR}${DRUPAL_DIR}
- ${CP} -R ${WRKSRC}/modules ${STAGEDIR}${DRUPAL_DIR}
- ${CP} -R ${WRKSRC}/profiles ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/robots.txt ${STAGEDIR}${DRUPAL_DIR}
- ${CP} -R ${WRKSRC}/scripts ${STAGEDIR}${DRUPAL_DIR}
- @${MKDIR} ${STAGEDIR}${DRUPAL_DIR}/sites/all
- @${MKDIR} ${STAGEDIR}${DRUPAL_DIR}/sites/all/libraries
- ${CP} ${WRKSRC}/sites/example.sites.php ${STAGEDIR}${DRUPAL_DIR}/sites/
- ${CP} -R ${WRKSRC}/sites/all ${STAGEDIR}${DRUPAL_DIR}/sites/
- @${MKDIR} ${STAGEDIR}${DRUPAL_DIR}/sites/default
@${MKDIR} ${STAGEDIR}${DRUPAL_DIR}/sites/default/files
- ${CP} ${WRKSRC}/sites/default/default.settings.php ${STAGEDIR}${DRUPAL_DIR}/sites/default/default.settings.php.sample
- ${CP} -R ${WRKSRC}/themes ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/update.php ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/web.config ${STAGEDIR}${DRUPAL_DIR}
- ${CP} ${WRKSRC}/xmlrpc.php ${STAGEDIR}${DRUPAL_DIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} ".htaccess cron.php authorize.php \
+ includes index.php install.php misc modules profiles \
+ robots.txt scripts themes update.php web.config xmlrpc.php" \
+ ${STAGEDIR}${DRUPAL_DIR})
+ (cd ${WRKSRC}/sites && ${COPYTREE_SHARE} "example.sites.php all" \
+ ${STAGEDIR}${DRUPAL_DIR}/sites)
+ ${INSTALL_DATA} ${WRKSRC}/sites/default/default.settings.php \
+ ${STAGEDIR}${DRUPAL_DIR}/sites/default/default.settings.php.sample
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/www/drupal7/distinfo b/www/drupal7/distinfo
index a2ad6136b022..f8a7586f7877 100644
--- a/www/drupal7/distinfo
+++ b/www/drupal7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1466072639
-SHA256 (drupal/drupal-7.44.tar.gz) = a62971d20edd4ffd4c6dd03eb5fe3d213777d3807f48b7399bb73688dfd4bc5a
-SIZE (drupal/drupal-7.44.tar.gz) = 3265819
+TIMESTAMP = 1471063072
+SHA256 (drupal/drupal-7.50.tar.gz) = 82041716e1790269d09ec4a1c4cca8899d0221509471d53ac793a320143e0cf0
+SIZE (drupal/drupal-7.50.tar.gz) = 3286826
diff --git a/www/drupal7/pkg-plist b/www/drupal7/pkg-plist
index 0c344d0889c2..91954fd3665a 100644
--- a/www/drupal7/pkg-plist
+++ b/www/drupal7/pkg-plist
@@ -605,6 +605,7 @@
%%DRUPAL_BASE%%/modules/simpletest/files/html-2.html
%%DRUPAL_BASE%%/modules/simpletest/files/image-1.png
%%DRUPAL_BASE%%/modules/simpletest/files/image-2.jpg
+%%DRUPAL_BASE%%/modules/simpletest/files/image-test-no-transparency.gif
%%DRUPAL_BASE%%/modules/simpletest/files/image-test-transparent-out-of-range.gif
%%DRUPAL_BASE%%/modules/simpletest/files/image-test.gif
%%DRUPAL_BASE%%/modules/simpletest/files/image-test.jpg
@@ -744,6 +745,7 @@
%%DRUPAL_BASE%%/modules/simpletest/tests/system_project_namespace_test.info
%%DRUPAL_BASE%%/modules/simpletest/tests/system_project_namespace_test.module
%%DRUPAL_BASE%%/modules/simpletest/tests/system_test.info
+%%DRUPAL_BASE%%/modules/simpletest/tests/system_test.install
%%DRUPAL_BASE%%/modules/simpletest/tests/system_test.module
%%DRUPAL_BASE%%/modules/simpletest/tests/tablesort.test
%%DRUPAL_BASE%%/modules/simpletest/tests/taxonomy_test.info