aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-06-18 03:00:47 +0800
committerrm <rm@FreeBSD.org>2012-06-18 03:00:47 +0800
commit2b90c1eb19ab0800388a1d64718f22f596f745b0 (patch)
treeefa17973df82c06b5d865ab68bacf446328c22f9 /www
parent39af61b8d11b4c917c94d8f1000a4978b8a36b43 (diff)
downloadfreebsd-ports-gnome-2b90c1eb19ab0800388a1d64718f22f596f745b0.tar.gz
freebsd-ports-gnome-2b90c1eb19ab0800388a1d64718f22f596f745b0.tar.zst
freebsd-ports-gnome-2b90c1eb19ab0800388a1d64718f22f596f745b0.zip
rackspace-monitoring is a Python client library for Rackspace Cloud Monitoring
built on top of Apache Libcloud. WWW: https://github.com/racker/rackspace-monitoring PR: ports/168562 Submitted by: koobs <koobs.freebsd@gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-rackspace-monitoring/Makefile25
-rw-r--r--www/py-rackspace-monitoring/distinfo2
-rw-r--r--www/py-rackspace-monitoring/pkg-descr4
-rw-r--r--www/py-rackspace-monitoring/pkg-plist24
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e9ee1e1e131e..b9418d08f3fa 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1582,6 +1582,7 @@
SUBDIR += py-qp
SUBDIR += py-qpy
SUBDIR += py-qt4-webkit
+ SUBDIR += py-rackspace-monitoring
SUBDIR += py-recaptcha
SUBDIR += py-requests
SUBDIR += py-requests-oauth-hook
diff --git a/www/py-rackspace-monitoring/Makefile b/www/py-rackspace-monitoring/Makefile
new file mode 100644
index 000000000000..fae48ff994ca
--- /dev/null
+++ b/www/py-rackspace-monitoring/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-rackspace-monitoring
+# Date created: 2012-06-17
+# Whom: koobs <koobs.freebsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rackspace-monitoring
+PORTVERSION= 0.2.9
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs.freebsd@gmail.com
+COMMENT= Python client library for Rackspace Cloud Monitoring
+
+LICENSE= AL2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libcloud>0:${PORTSDIR}/net/py-libcloud
+
+# Python3 ready
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/www/py-rackspace-monitoring/distinfo b/www/py-rackspace-monitoring/distinfo
new file mode 100644
index 000000000000..da2986605ab1
--- /dev/null
+++ b/www/py-rackspace-monitoring/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rackspace-monitoring-0.2.9.tar.gz) = d77ab0648a8cb5b0cc73e90f6ca67d8f54faf1f5ca0a1ee9115efaae290422da
+SIZE (rackspace-monitoring-0.2.9.tar.gz) = 19150
diff --git a/www/py-rackspace-monitoring/pkg-descr b/www/py-rackspace-monitoring/pkg-descr
new file mode 100644
index 000000000000..4dcd08ac9fd0
--- /dev/null
+++ b/www/py-rackspace-monitoring/pkg-descr
@@ -0,0 +1,4 @@
+rackspace-monitoring is a Python client library for Rackspace Cloud Monitoring
+built on top of Apache Libcloud.
+
+WWW: https://github.com/racker/rackspace-monitoring
diff --git a/www/py-rackspace-monitoring/pkg-plist b/www/py-rackspace-monitoring/pkg-plist
new file mode 100644
index 000000000000..500011ed621b
--- /dev/null
+++ b/www/py-rackspace-monitoring/pkg-plist
@@ -0,0 +1,24 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/__init__.py
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/__init__.pyc
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/__init__.pyo
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/base.py
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/base.pyc
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/base.pyo
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/drivers/__init__.py
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/drivers/__init__.pyc
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/drivers/__init__.pyo
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/drivers/rackspace.py
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/drivers/rackspace.pyc
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/drivers/rackspace.pyo
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/providers.py
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/providers.pyc
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/providers.pyo
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/types.py
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/types.pyc
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/types.pyo
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/utils.py
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/utils.pyc
+%%PYTHON_SITELIBDIR%%/rackspace_monitoring/utils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/rackspace_monitoring/drivers
+@dirrm %%PYTHON_SITELIBDIR%%/rackspace_monitoring