aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsbz <sbz@FreeBSD.org>2011-07-12 13:47:17 +0800
committersbz <sbz@FreeBSD.org>2011-07-12 13:47:17 +0800
commit2dbbe48b3d936a7d610c83946916594372ed8d02 (patch)
tree1bb68025775441946765a9d6c58bbc1d1791d60a /www
parentfab4aa73e8608df31a8b88c6a6cbf7f5c1ec1a36 (diff)
downloadfreebsd-ports-gnome-2dbbe48b3d936a7d610c83946916594372ed8d02.tar.gz
freebsd-ports-gnome-2dbbe48b3d936a7d610c83946916594372ed8d02.tar.zst
freebsd-ports-gnome-2dbbe48b3d936a7d610c83946916594372ed8d02.zip
- Fix NLS OPTIONS
- Bump PORTREVISION Reported by: jlaffaye@ Approved by: miwi@ (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/roundup/Makefile5
-rw-r--r--www/roundup/files/patch-setup.py15
2 files changed, 13 insertions, 7 deletions
diff --git a/www/roundup/Makefile b/www/roundup/Makefile
index f6ecd05c3455..bf966dbf18df 100644
--- a/www/roundup/Makefile
+++ b/www/roundup/Makefile
@@ -7,6 +7,7 @@
PORTNAME= roundup
PORTVERSION= 1.4.18
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
@@ -16,6 +17,7 @@ COMMENT= An Issue-Tracking System for Knowledge Workers
LICENSE= PSFL
LICENSE_FILE= ${WRKSRC}/COPYING.txt
+USE_GETTEXT= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
@@ -43,10 +45,9 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
.endif
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
-PLIST_SUB+= NLS="@comment"
+PLIST_SUB+= NLS="@comment "
.endif
.if !defined(NO_INSTALL_MANPAGES)
diff --git a/www/roundup/files/patch-setup.py b/www/roundup/files/patch-setup.py
index f080424bd82f..04058d3fcec8 100644
--- a/www/roundup/files/patch-setup.py
+++ b/www/roundup/files/patch-setup.py
@@ -1,5 +1,5 @@
---- ./setup.py.orig 2009-03-18 04:35:22.000000000 +0100
-+++ ./setup.py 2009-05-14 22:29:50.000000000 +0200
+--- ./setup.py.orig 2011-05-13 11:20:33.000000000 +0200
++++ ./setup.py 2011-07-11 23:52:17.000000000 +0200
@@ -71,9 +71,6 @@
data_files = [
('share/roundup/cgi-bin', ['frontends/roundup.cgi']),
@@ -10,10 +10,15 @@
# add the templates to the data files lists
from roundup.init import listTemplates
-@@ -88,9 +85,6 @@
- data_files.append((os.path.dirname(_mo_file),
- [os.path.join("build", _mo_file)]))
+@@ -83,14 +80,6 @@
+ for idir in '. detectors extensions html'.split():
+ data_files.append(include(os.path.join(tdir, idir), '*'))
+- # add message files
+- for (_dist_file, _mo_file) in list_message_files():
+- data_files.append((os.path.dirname(_mo_file),
+- [os.path.join("build", _mo_file)]))
+-
- # add docs
- data_files.append(include('share/doc/roundup/html', '*'))
-