aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-12 02:09:00 +0800
committerdanfe <danfe@FreeBSD.org>2018-01-12 02:09:00 +0800
commit2e405a4390a09190d0b4db047144387da96bdbb8 (patch)
tree9cac7f5ea213c17593d4d5a8c733bc92daf9a6ef /www
parentc832c456a9ad5522763decae70b3fd7c69676940 (diff)
downloadfreebsd-ports-gnome-2e405a4390a09190d0b4db047144387da96bdbb8.tar.gz
freebsd-ports-gnome-2e405a4390a09190d0b4db047144387da96bdbb8.tar.zst
freebsd-ports-gnome-2e405a4390a09190d0b4db047144387da96bdbb8.zip
- Convert to option helper install target (add OPTIONS_DEFINE=DOCS
when it was missing) - Invoke INSTALL_DATA where appropriate instead of INSTALL_MAN - Fix some whitespace and formatting bugs along the way
Diffstat (limited to 'www')
-rw-r--r--www/tidy/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/tidy/Makefile b/www/tidy/Makefile
index 18ec163a3f22..97ff2b55deee 100644
--- a/www/tidy/Makefile
+++ b/www/tidy/Makefile
@@ -25,10 +25,11 @@ do-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tidy ${STAGEDIR}${PREFIX}/bin/tidy4
- ${INSTALL_MAN} ${WRKSRC}/man_page.txt ${STAGEDIR}${PREFIX}/man/man1/tidy4.1
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for docfile in ${DOCFILES}
- ${INSTALL_MAN} ${WRKSRC}/${docfile} ${STAGEDIR}${DOCSDIR}/
-.endfor
+ ${INSTALL_MAN} ${WRKSRC}/man_page.txt \
+ ${STAGEDIR}${PREFIX}/man/man1/tidy4.1
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>