aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-12-28 00:12:35 +0800
committerhq <hq@FreeBSD.org>2005-12-28 00:12:35 +0800
commit2f52399939840d17e939b5bad20fe949a4daa662 (patch)
tree8f6e13c93eaf2a7d3111d691fec8a0610c22315b /www
parent7ae624755f1424ed689c41ee4bed76502375ca19 (diff)
downloadfreebsd-ports-gnome-2f52399939840d17e939b5bad20fe949a4daa662.tar.gz
freebsd-ports-gnome-2f52399939840d17e939b5bad20fe949a4daa662.tar.zst
freebsd-ports-gnome-2f52399939840d17e939b5bad20fe949a4daa662.zip
Fix build when using Java 1.4: the compatibility distfile was wrong
PR: 90913 Submitted by: maintainer, lesi Reported by: Yamamoto Takao <takao@oakat.org>, Ion-Mihai Tetcu <itetcu@people.tecnik93.com>
Diffstat (limited to 'www')
-rw-r--r--www/jakarta-tomcat55/Makefile4
-rw-r--r--www/tomcat55/Makefile4
-rw-r--r--www/tomcat6/Makefile4
-rw-r--r--www/tomcat7/Makefile4
4 files changed, 8 insertions, 8 deletions
diff --git a/www/jakarta-tomcat55/Makefile b/www/jakarta-tomcat55/Makefile
index 82d47b2d0ba0..0f57d1a27cd3 100644
--- a/www/jakarta-tomcat55/Makefile
+++ b/www/jakarta-tomcat55/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 5.5.12
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
-DISTNAME= apache-tomcat-${PORTVERSION}
+DISTFILES= apache-tomcat-${PORTVERSION}.tar.gz
MAINTAINER= liukang@cn.freebsd.org
COMMENT= Open-source Java web server by Apache, 5.5.x branch
@@ -74,7 +74,7 @@ PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
.include <bsd.port.pre.mk>
.if ${JAVA_PORT_VERSION:C/^([0-9])\.([0-9])(.*)$/\1.\2/} == "1.4"
-DISTFILES+= ${PORTNAME}-${PORTVERSION}-compat.tar.gz
+DISTFILES+= apache-tomcat-${PORTVERSION}-compat.tar.gz
PLIST_SUB+= JAVA14=""
.else
PLIST_SUB+= JAVA14="@comment "
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index 82d47b2d0ba0..0f57d1a27cd3 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 5.5.12
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
-DISTNAME= apache-tomcat-${PORTVERSION}
+DISTFILES= apache-tomcat-${PORTVERSION}.tar.gz
MAINTAINER= liukang@cn.freebsd.org
COMMENT= Open-source Java web server by Apache, 5.5.x branch
@@ -74,7 +74,7 @@ PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
.include <bsd.port.pre.mk>
.if ${JAVA_PORT_VERSION:C/^([0-9])\.([0-9])(.*)$/\1.\2/} == "1.4"
-DISTFILES+= ${PORTNAME}-${PORTVERSION}-compat.tar.gz
+DISTFILES+= apache-tomcat-${PORTVERSION}-compat.tar.gz
PLIST_SUB+= JAVA14=""
.else
PLIST_SUB+= JAVA14="@comment "
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index 82d47b2d0ba0..0f57d1a27cd3 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 5.5.12
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
-DISTNAME= apache-tomcat-${PORTVERSION}
+DISTFILES= apache-tomcat-${PORTVERSION}.tar.gz
MAINTAINER= liukang@cn.freebsd.org
COMMENT= Open-source Java web server by Apache, 5.5.x branch
@@ -74,7 +74,7 @@ PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
.include <bsd.port.pre.mk>
.if ${JAVA_PORT_VERSION:C/^([0-9])\.([0-9])(.*)$/\1.\2/} == "1.4"
-DISTFILES+= ${PORTNAME}-${PORTVERSION}-compat.tar.gz
+DISTFILES+= apache-tomcat-${PORTVERSION}-compat.tar.gz
PLIST_SUB+= JAVA14=""
.else
PLIST_SUB+= JAVA14="@comment "
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index 82d47b2d0ba0..0f57d1a27cd3 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 5.5.12
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
-DISTNAME= apache-tomcat-${PORTVERSION}
+DISTFILES= apache-tomcat-${PORTVERSION}.tar.gz
MAINTAINER= liukang@cn.freebsd.org
COMMENT= Open-source Java web server by Apache, 5.5.x branch
@@ -74,7 +74,7 @@ PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
.include <bsd.port.pre.mk>
.if ${JAVA_PORT_VERSION:C/^([0-9])\.([0-9])(.*)$/\1.\2/} == "1.4"
-DISTFILES+= ${PORTNAME}-${PORTVERSION}-compat.tar.gz
+DISTFILES+= apache-tomcat-${PORTVERSION}-compat.tar.gz
PLIST_SUB+= JAVA14=""
.else
PLIST_SUB+= JAVA14="@comment "