aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-04-04 00:34:33 +0800
committermi <mi@FreeBSD.org>2002-04-04 00:34:33 +0800
commit307e105f6e826fa3a78e72cd638e498faebe0adb (patch)
treea361494948a7d6068a93224a58e47b5d877e9fa4 /www
parent8a3c42d02799f8cc34dbc65ee8b012f74eff51f3 (diff)
downloadfreebsd-ports-gnome-307e105f6e826fa3a78e72cd638e498faebe0adb.tar.gz
freebsd-ports-gnome-307e105f6e826fa3a78e72cd638e498faebe0adb.tar.zst
freebsd-ports-gnome-307e105f6e826fa3a78e72cd638e498faebe0adb.zip
Tidy up ``import'' statements to avoid warnings by the latest Python-2.2.
When de-installing, try removing any .pyc or .pyo files generated by Python compiler next to the .py files we install. Not bumping up PORTREVISION, since it still does not work with the new Python and worked without the fixes with the earlier one. Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/linbot/files/patch-compat43
-rw-r--r--www/linbot/pkg-plist1
-rw-r--r--www/webcheck/files/patch-compat43
-rw-r--r--www/webcheck/pkg-plist1
4 files changed, 78 insertions, 10 deletions
diff --git a/www/linbot/files/patch-compat b/www/linbot/files/patch-compat
index 81dc79d37b38..7cf29a908699 100644
--- a/www/linbot/files/patch-compat
+++ b/www/linbot/files/patch-compat
@@ -1,7 +1,6 @@
-diff -ru /tmp/lb/linbot-1.0/myUrlLib.py ./myUrlLib.py
---- myUrlLib.py Sun Mar 14 13:24:20 1999
-+++ myUrlLib.py Wed Jul 18 20:42:57 2001
-@@ -37,6 +37,7 @@
+--- myUrlLib.py Sun Mar 14 14:24:20 1999
++++ myUrlLib.py Wed Apr 3 10:52:19 2002
+@@ -37,6 +38,7 @@
import htmlparse
import debugio
import sys
@@ -9,7 +8,16 @@ diff -ru /tmp/lb/linbot-1.0/myUrlLib.py ./myUrlLib.py
def get_robots(location):
-@@ -105,7 +106,10 @@
+@@ -77,7 +79,7 @@
+ self.init()
+
+ debugio.write('\tparent = ' + str(parent),2)
+- from urlparse import *
++ from urlparse import urlparse
+
+ parsed = urlparse(url)
+ self.scheme = parsed[0]
+@@ -105,7 +107,10 @@
if (parent is None):
Link.baseurl=self.URL
@@ -21,6 +29,15 @@ diff -ru /tmp/lb/linbot-1.0/myUrlLib.py ./myUrlLib.py
if Link.base[-2:] == '//': Link.base = self.URL
debugio.write('\tbase: %s' % Link.base)
if self.scheme == 'http':
+@@ -257,7 +262,7 @@
+
+ def is_external(url):
+ """ returns true if url is an external link """
+- from urlparse import *
++ from urlparse import urlparse
+ parsed = urlparse(url)
+ scheme = parsed[0]
+ location = parsed[1]
--- robotparser.py Sat Jan 9 19:01:45 1999
+++ robotparser.py Wed Jul 18 20:29:13 2001
@@ -37,7 +37,7 @@
@@ -88,3 +105,19 @@ diff -ru /tmp/lb/linbot-1.0/myUrlLib.py ./myUrlLib.py
return open(filename,'r').read()
+--- htmlparse.py Wed Mar 10 23:51:25 1999
++++ htmlparse.py Wed Apr 3 11:10:55 2002
+@@ -48,5 +48,5 @@
+ based on parent"""
+
+- from urlparse import *
++ from urlparse import urlparse
+
+ method=urlparse(url)[0]
+@@ -125,5 +125,5 @@
+ the <BASE HREF=> tag."""
+ import htmllib
+- from urlparse import *
++ from urlparse import urlparse
+ from formatter import NullFormatter
+
diff --git a/www/linbot/pkg-plist b/www/linbot/pkg-plist
index 451fa0247d7b..757627a71d8a 100644
--- a/www/linbot/pkg-plist
+++ b/www/linbot/pkg-plist
@@ -25,6 +25,7 @@ share/linbot/schemes/httplink.py
share/linbot/version.py
%%PORTDOCS%%share/doc/linbot/USAGE
%%PORTDOCS%%@dirrm share/doc/linbot/
+@unexec rm -f %D/share/linbot/*.py[co] %D/share/linbot/*/*.py[co]
@dirrm share/linbot/plugins
@dirrm share/linbot/schemes
@dirrm share/linbot
diff --git a/www/webcheck/files/patch-compat b/www/webcheck/files/patch-compat
index 81dc79d37b38..7cf29a908699 100644
--- a/www/webcheck/files/patch-compat
+++ b/www/webcheck/files/patch-compat
@@ -1,7 +1,6 @@
-diff -ru /tmp/lb/linbot-1.0/myUrlLib.py ./myUrlLib.py
---- myUrlLib.py Sun Mar 14 13:24:20 1999
-+++ myUrlLib.py Wed Jul 18 20:42:57 2001
-@@ -37,6 +37,7 @@
+--- myUrlLib.py Sun Mar 14 14:24:20 1999
++++ myUrlLib.py Wed Apr 3 10:52:19 2002
+@@ -37,6 +38,7 @@
import htmlparse
import debugio
import sys
@@ -9,7 +8,16 @@ diff -ru /tmp/lb/linbot-1.0/myUrlLib.py ./myUrlLib.py
def get_robots(location):
-@@ -105,7 +106,10 @@
+@@ -77,7 +79,7 @@
+ self.init()
+
+ debugio.write('\tparent = ' + str(parent),2)
+- from urlparse import *
++ from urlparse import urlparse
+
+ parsed = urlparse(url)
+ self.scheme = parsed[0]
+@@ -105,7 +107,10 @@
if (parent is None):
Link.baseurl=self.URL
@@ -21,6 +29,15 @@ diff -ru /tmp/lb/linbot-1.0/myUrlLib.py ./myUrlLib.py
if Link.base[-2:] == '//': Link.base = self.URL
debugio.write('\tbase: %s' % Link.base)
if self.scheme == 'http':
+@@ -257,7 +262,7 @@
+
+ def is_external(url):
+ """ returns true if url is an external link """
+- from urlparse import *
++ from urlparse import urlparse
+ parsed = urlparse(url)
+ scheme = parsed[0]
+ location = parsed[1]
--- robotparser.py Sat Jan 9 19:01:45 1999
+++ robotparser.py Wed Jul 18 20:29:13 2001
@@ -37,7 +37,7 @@
@@ -88,3 +105,19 @@ diff -ru /tmp/lb/linbot-1.0/myUrlLib.py ./myUrlLib.py
return open(filename,'r').read()
+--- htmlparse.py Wed Mar 10 23:51:25 1999
++++ htmlparse.py Wed Apr 3 11:10:55 2002
+@@ -48,5 +48,5 @@
+ based on parent"""
+
+- from urlparse import *
++ from urlparse import urlparse
+
+ method=urlparse(url)[0]
+@@ -125,5 +125,5 @@
+ the <BASE HREF=> tag."""
+ import htmllib
+- from urlparse import *
++ from urlparse import urlparse
+ from formatter import NullFormatter
+
diff --git a/www/webcheck/pkg-plist b/www/webcheck/pkg-plist
index 451fa0247d7b..757627a71d8a 100644
--- a/www/webcheck/pkg-plist
+++ b/www/webcheck/pkg-plist
@@ -25,6 +25,7 @@ share/linbot/schemes/httplink.py
share/linbot/version.py
%%PORTDOCS%%share/doc/linbot/USAGE
%%PORTDOCS%%@dirrm share/doc/linbot/
+@unexec rm -f %D/share/linbot/*.py[co] %D/share/linbot/*/*.py[co]
@dirrm share/linbot/plugins
@dirrm share/linbot/schemes
@dirrm share/linbot