aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-11-26 14:44:58 +0800
committerjbeich <jbeich@FreeBSD.org>2018-11-26 14:44:58 +0800
commit31111c9137cba8b4d42c2a8383845241293af74e (patch)
tree13ae4002aa50e6b13a2ac6f18f412720697168b5 /www
parent18b91388e1175c8be335e48c0615de362c887fd0 (diff)
downloadfreebsd-ports-gnome-31111c9137cba8b4d42c2a8383845241293af74e.tar.gz
freebsd-ports-gnome-31111c9137cba8b4d42c2a8383845241293af74e.tar.zst
freebsd-ports-gnome-31111c9137cba8b4d42c2a8383845241293af74e.zip
gecko: unbreak with more strict regex(3) on FreeBSD 13
In file included from ../.build/dom/workers/Unified_cpp_dom_workers0.cpp:11: dom/workers/ChromeWorkerScope.cpp:56:10: error: use of undeclared identifier 'JS_InitCTypesClass' if (!JS_InitCTypesClass(aCx, aGlobal) || ^ dom/workers/ChromeWorkerScope.cpp:61:18: error: unknown type name 'JSCTypesCallbacks' static const JSCTypesCallbacks callbacks = { ^ PR: 233453 Reported by: kevans
Diffstat (limited to 'www')
-rw-r--r--www/firefox-esr/files/patch-bug150975720
-rw-r--r--www/firefox/files/patch-bug150975720
-rw-r--r--www/palemoon/files/patch-bug150975720
-rw-r--r--www/seamonkey/files/patch-bug150975720
4 files changed, 80 insertions, 0 deletions
diff --git a/www/firefox-esr/files/patch-bug1509757 b/www/firefox-esr/files/patch-bug1509757
new file mode 100644
index 000000000000..9260fc5d5f81
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1509757
@@ -0,0 +1,20 @@
+Don't rely on GNU regex extension for character classes.
+
+$ echo --with-system-nspr --with-system-nss | gsed -e 's/--with-system-nspr\S* *//'
+--with-system-nss
+$ echo --with-system-nspr --with-system-nss | sed -e 's/--with-system-nspr\S* *//'
+sed: 1: "s/--with-system-nspr\S* ...": RE error: trailing backslash (\)
+
+diff --git old-configure.in old-configure.in
+index 7722587fadac..acf5d8d67a60 100644
+--- old-configure.in
++++ old-configure.in
+@@ -4405,7 +4405,7 @@ ac_configure_args="$_SUBDIR_CONFIG_ARGS"
+
+ # --with-system-nspr will have been converted into the relevant $NSPR_CFLAGS
+ # and $NSPR_LIBS.
+-ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr\S* *//'`"
++ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr[[^[:space:]]]* *//'`"
+
+ if test "$_INTL_API" = no; then
+ ac_configure_args="$ac_configure_args --without-intl-api"
diff --git a/www/firefox/files/patch-bug1509757 b/www/firefox/files/patch-bug1509757
new file mode 100644
index 000000000000..9260fc5d5f81
--- /dev/null
+++ b/www/firefox/files/patch-bug1509757
@@ -0,0 +1,20 @@
+Don't rely on GNU regex extension for character classes.
+
+$ echo --with-system-nspr --with-system-nss | gsed -e 's/--with-system-nspr\S* *//'
+--with-system-nss
+$ echo --with-system-nspr --with-system-nss | sed -e 's/--with-system-nspr\S* *//'
+sed: 1: "s/--with-system-nspr\S* ...": RE error: trailing backslash (\)
+
+diff --git old-configure.in old-configure.in
+index 7722587fadac..acf5d8d67a60 100644
+--- old-configure.in
++++ old-configure.in
+@@ -4405,7 +4405,7 @@ ac_configure_args="$_SUBDIR_CONFIG_ARGS"
+
+ # --with-system-nspr will have been converted into the relevant $NSPR_CFLAGS
+ # and $NSPR_LIBS.
+-ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr\S* *//'`"
++ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr[[^[:space:]]]* *//'`"
+
+ if test "$_INTL_API" = no; then
+ ac_configure_args="$ac_configure_args --without-intl-api"
diff --git a/www/palemoon/files/patch-bug1509757 b/www/palemoon/files/patch-bug1509757
new file mode 100644
index 000000000000..deafe5844ed4
--- /dev/null
+++ b/www/palemoon/files/patch-bug1509757
@@ -0,0 +1,20 @@
+Don't rely on GNU regex extension for character classes.
+
+$ echo --with-system-nspr --with-system-nss | gsed -e 's/--with-system-nspr\S* *//'
+--with-system-nss
+$ echo --with-system-nspr --with-system-nss | sed -e 's/--with-system-nspr\S* *//'
+sed: 1: "s/--with-system-nspr\S* ...": RE error: trailing backslash (\)
+
+diff --git old-configure.in old-configure.in
+index 7722587fadac..acf5d8d67a60 100644
+--- configure.in
++++ configure.in
+@@ -4405,7 +4405,7 @@ ac_configure_args="$_SUBDIR_CONFIG_ARGS"
+
+ # --with-system-nspr will have been converted into the relevant $NSPR_CFLAGS
+ # and $NSPR_LIBS.
+-ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr\S* *//'`"
++ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr[[^[:space:]]]* *//'`"
+
+ if test "$_INTL_API" = no; then
+ ac_configure_args="$ac_configure_args --without-intl-api"
diff --git a/www/seamonkey/files/patch-bug1509757 b/www/seamonkey/files/patch-bug1509757
new file mode 100644
index 000000000000..d7c7718af2cd
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1509757
@@ -0,0 +1,20 @@
+Don't rely on GNU regex extension for character classes.
+
+$ echo --with-system-nspr --with-system-nss | gsed -e 's/--with-system-nspr\S* *//'
+--with-system-nss
+$ echo --with-system-nspr --with-system-nss | sed -e 's/--with-system-nspr\S* *//'
+sed: 1: "s/--with-system-nspr\S* ...": RE error: trailing backslash (\)
+
+diff --git old-configure.in old-configure.in
+index 7722587fadac..acf5d8d67a60 100644
+--- mozilla/old-configure.in
++++ mozilla/old-configure.in
+@@ -4405,7 +4405,7 @@ ac_configure_args="$_SUBDIR_CONFIG_ARGS"
+
+ # --with-system-nspr will have been converted into the relevant $NSPR_CFLAGS
+ # and $NSPR_LIBS.
+-ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr\S* *//'`"
++ac_configure_args="`echo $ac_configure_args | sed -e 's/--with-system-nspr[[^[:space:]]]* *//'`"
+
+ if test "$_INTL_API" = no; then
+ ac_configure_args="$ac_configure_args --without-intl-api"